Drobo

reading back stale data?

Hey folks, I’m seeing something kinda disturbing with my new DroboFS. I have it mounted via AFP on my mac. When I save a file out to the drobo, then switch away from my editor and switch back, the editor tells me the file has been updated on disk and asks if I want to reload the file. If I tell it to reload, I get the N-1 version of the file. It’s like my write didn’t happen. I confirmed the correct data is actually on disk via an ssh session. I saved the file, switched to console and dumped the file, then switched back to my editor and it shows the file has been modified on disk… sure enough if I ask it to load the on disk version, it reverts the last change.

Now I see iTunes is running into what might be similar problems. My iTunes database is on the drobo shared filesystem, it comes up saying that it can’t find a file, so I do “get info” from the menu and choose to do the locate dance, I see a flicker of activity on the drobo, so it seems to have written it, then it proceeds to show me the info using the old track location.

Anyone else seen this? Is there something unhealthy about the afp service here? I have the 1.0.5 firmware and am running 10.6.4 on most of my macs. One is 10.5.whatever-is-current.

I have not seen anything like this on my DroboFS but have seen similar when using other types or filesystems/protocols. The issue is usually to do with a clock skew. The two devices have different times so one will report the file on the other is newer. It may be worth checking that times and get them both reporting to a single NTP server if possible.

thanks quigsau, that looks to have been the problem. For whatever reason the drobo had picked an NTP server in Romania (I’m in the US) and had drifted a couple seconds off from my local NTP server… but then every time it checkmarked with the upstream server it would goto a different time.

How do I adjust my Drobo FS’s clock? I think I might be having this same issue (but with Time Machine). Thanks.

It looks like you can’t really directly, at least attempting to do so through the normal means didn’t seem to work for me.

Honestly, I found a reboot helped immensely once I figured out what the problem was… it got a better ntp server from the pool.

If you’ve installed dropbear and don’t mind hacking around with the bits of the OS they probably don’t want you to, I can post how to point it at your own chosen NTP server instead of picking one from the public pool. I wish they would make that a configurable option in a future firmware update.

That’s ok, I’d only wreck something. :wink: