RE: Drobo 5N, health 'critical', drives - POSSIBLE FIX!!!

I got my problem fixed. I tried ALL suggestions given to me by members (and thank you very much) and none of them worked: I used the DroboRepair (FSCK) operation, I unplugged each and every cable and connection and left it ‘cold’ for extended periods, I removed the drives and did a reset of the Drobo5n. I removed all drives from the 5n and put in a single, new, blank disk and did formatting and rebuilt the Drobo, and none of this worked to fix the problem: drives containing data were all in ‘good’ health, Drobo5n couldn’t mount, and health of Drobo read as ‘critical.’

But: I fixed it. What ended up working was - I found a mirror that still held Drobo firmware v.3.2.0. I installed that on the malfunctioning 5n appliance; restarted, and ignored the ‘warnings’ to upgrade to 3.2.3. So: I stepped back a version in firmware.

The thing came immediately back to life: Drobo Health = “good”, all drives and data intact, reading green, and I’m back in business now.

There should be a depot for older/legacy firmware and dashboard versions someplace. Someplace eas(ier) to get to. I think there may be something very wrong with 3.2.3. MHO…

hi just my thoughts on versions…
ideally there should always be the firmwares, and dashboard versions and release notes available for each and every release. (simplest way would be a basic html page with table and links, and a comments column saying to read the release notes) - ideally the release notes would be updated with any (after the fact) pertinent information if possible.

this way, people could more easily match versions etc.