Drobo

Randomly unable to mount shares

I have several shares, and since the last new firmware/dashboard, most of them mount on reboot no problem. However, randomly some of them will not mount and attempting to mount them in the dashboard will throw the ‘system resource in use’ error. Unlike before the upgrades, they do not appear in my computer where I can manually remove them and then re-add them on the next reboot. Now they stay locked until drobo decides to load them again on a random later reboot. While I can get to the locations by manually creating a network shortcut, this renders drobobcopy unusable.

I need all of my shares to load all of the time. I can’t have some of them just decide not to let me access them for many reboots at a time. This needs to be fixed already.

I am using windows 7 64.

Have you used the net use command in command prompt to delete the unavailable drive letters?

The computer does not see the shares unless I go and manually mount them using map network drive, and then dashboard continues to see them as unmounted.

And I’ve seen that when shares have been mounted, assigned a drive letter, no longer available for that drive letter but dashboard and windows is still trying to mount to that drive letter and that’s why you get the system resource in use message when trying to mount from Dashboard.

So, Have you deleted the unavailable shares/drive letters in command window with net use?

I do not understand what you are saying. I need complete sentences.

BTW, drobo dashboard is now unable to mount any shares at all, no matter what I do. I now have to mount everything via map network drive.[hr]
Everything now has to be mapped. Unmapping and rebooting results in nothing appearing. When mapped, everything is listed as available. When not mapped, everything is listed as available, but the system throws the resource error if you try to click the checkbox.[hr]
I can’t reply normally, the system insists on putting it at the end of this reply.[hr]

Perhaps I can break the sentence down into more-digestable chunks…
Jennifer has seen that when shares have been mounted and assigned a drive letter,
those drive letters are no longer available,
because they’re assigned to a mounted share and Windows is still trying to mount that drive letter
so that’s why you get the “system resource in use” message when trying to mount the drive from Dashboard.

So… you need to “clean out” the existing mapped shares before Dashboard can properly mount the share.
You need to Disconnect the existing mapped drive letters by right-clicking the mapped drive letter in Windows Explorer and selecting Disconnect.

If no mapped drives appear in Windows Explorer, try opening Command Prompt and type NET USE
You should see something similar to

[code]New connections will be remembered.

Status Local Remote Network


Unavailable Z: \DroboShare\Drobo Microsoft Windows Network
The command completed successfully.[/code]

Apparently on my laptop I have a “leftover” share from when I had DroboShare connected. It does not show up in Windows Explorer, but apparently it’s still there. Thus, the drive letter Z: is reserved and can’t be used for other devices.

So, now I type NET USE Z: /DELETE and I get

[code]New connections will be remembered.

Status Local Remote Network


Unavailable Z: \DroboShare\Drobo Microsoft Windows Network
The command completed successfully.[/code]

Now drive Z: is free for use and mounting.
You may have to do this multiple times if you have multiple drive letters mapped.

This is not a Drobo issue. This is a Windows issue. The same thing happens to me from time to time on my work machine, a different machine from the one I’m on right now, that has never touched a Drobo. Drive H: is a mapped network share on a server. But if I plug in a USB stick, sometimes it too wants to be drive H:, and it doesn’t mount with a new drive letter, because H: is already in use.

I was really hoping this was my issue with “Resource still in use” as well, but alas, the only share that NET USE shows is y:\drobo-fs\droboapps.

I am unable to mount either the public or an admin share. I have rebooted both machine and drobo, uninstalled drobo dashboard and downloaded it from the site (yes, there is a secret unlinked download location that Support will provide you), disabled anti-virus etc.

Also, strangely, the “Advanced Controls” button grays out quickly after logging in. I have no idea what could be causing that, but I think it is while the drobo dashboard is attempting to connect to shares. If you click it quickly, you can still get in to the Advanced Controls area.

Definitely strange.

@Everman:
“Resource in use” errors happen in Windows even with shares on other Windows machines or servers. Usually it happens to me when the network connection drops off and is later restored.

Just to be sure, are File and Print Sharing and Drobo Dashboard set as exceptions to the Windows Firewall?

Ok, i just ran into this problem trying to mount the DroboApps folder. I was getting the “resource in use” error. Checked the net use and no “Unavailable” mounts listed. I manually mounted the rest of my folders (as i had problems in the past with dashboard mounting my shares) so I disconnected all my shares, and made sure net use was clean and click tried to mount the drobo apps folder and it worked. It seems the dashboard keeps track of the letters the drives were mounted to and tries to mount to that same drive letter, even though i already mounted something to that letter.

I am hoping a re-install will clear the dashboard cahce.

Windows somehow keeps track of the last drive letter the drive was on that machine.

For example, my work machine has a mapped drive H:, but I also have a USB stick that once was H: on this machine. When I plug the USB stick into the machine, either I don’t see the USB stick (it mounts with no drive letter assigned), or I lose my mapped share and get the stick’s content as H:.

Once I can see the stick, if I go into Disk Management and assign a different drive letter to the device, then things are OK until I run into another letter conflict. It’s a weird Windows thing.

Yes, definitely a windows issue.

Uh… hate to throw a spanner in the works… I have the same issue wtih dashboard. On MacOS.
I have two DroboFS units and in several situations I’m unable to mount both shares.
Same error of system resource in use.

Then please open a support case.

I was commenting on windows liking to use the same drive letter even though it’s not available as a windows thing.

The system resource use is happening in both OS’s.