Drobo

PureFTP Root cant write to disk Nor can be seen outside of the network

Ok, im a drobo NEWB.

I have it all set up… have pureFTP installed… and can ftp to drobo using the ROOT account default WITHIN my network.

I need to see this outside of my network, and when i assign port 1024 to the drobo… i simply can NOT ftp into it.

can someone tell me if this port is not the proper port anymore?

Also… i can only download things… i need to UPLOAD stuff from outside of my network INTO the drobo…

any clues?

You need to use either port forwarding (if using active FTP) or port triggering (if using passive FTP) to ensure the traffic gets between the Drobo and the outside world.

i am port forwarding 192.168.1.112 to port 1024

i read that in one of the very limited documents.

is this correct? if so… its not working.

keep in mind usually FTP protocol uses a UDP + TCP port, 20/21 are defaults for most FTP programs, so if you change it sometimes you gotta forward two specific ports.

What port are you accessing from the outside?

If you’re not accessing port 1024 from the outside world, then you should be port-forwarding port 20 and 21.

Here’s a good explanation of Active vs Passive FTP.
http://slacksite.com/other/ftp.html

Note the lines that represent what ports on the server end are being used. Those are the ports at your router that need to get forwarded to the internal address.

In Active FTP, clients are “hitting” ports 20 and 21 at your router, and those get forwarded to ports 20 and 21 on the actual server (in your case 192.168.1.112:20 and 192.168.1.112:21).

For Passive FTP, the server chooses which port the client should establish its data connection with. Because the port changes, usually you have set up port triggering (and not just forwarding) to have the router open up the incoming data port and route the data to your server properly.

Alternatively, if your FTP server allows you to limit the passive FTP port range, you could just port-forward the entire range to the server on the inside, though that leaves more ports open.

Active FTP is easier to set up, but Passive FTP is more efficient when there’s more traffic.

i actually just dont understand alot of what your saying… its not that your not correct in saying it the way you do…

but i cant access any controls via a gui on the pureFTP app. so i cant see anything there…

all i have is my router ports to control.

im using the default settings in pureftp cuz i just dont know where to change them.

are you saying i should just open and forward ports 21 and 20 to the 192.168.1.112 ?

and then use my external IP + :20 or :21 to log in? using the default root/root password it makes you use?

cuz if thats what your saying… i have tried that.

so im hoping i am overlooking something super simple.

please advise

-c

Ignore what I just said here…

i dont know how to see the gui for pureftp… is there a URL?

I thought that was what you were trying to get to… Guess not (I don’t use PureFTP).

Okay, complete and total restart… Ignore my last post.

  1. Can you access FTP from inside your network, via an FTP client like Filezilla, CuteFTP, WS FTP, etc?
  2. Once you can verify that works, forward ports 20 and 21 on your router to ports 20 and 21 (respectively) on IP address 192.168.1.112. This should give you active FTP support. However, if PureFTP ties to use passive FTP, then it’ll connect, but not be able to transfer the directory listing, because your client won’t be able to connect the data connection.
    If you don’t get a directory listing, see if you can disable Passive FTP support in PureFTP? I don’t know if it’s enabled by default or not.

yea. i have the admin tools for drobo… but that is useless. unless im missing something

how do i access the root settings for the purftp? is there a gui for pureftp?

im assuming its the ONLY ftp app for drobo.

if im wrong… let me know. im on droboFS

Do #2 above, and disable Passive FTP in your client, if it has an option (it seems Pure FTPd doesn’t have much in configuration).

i can easily get on the ftp on my network. im using transmit, or cyberduck… AND OSx native works too

but not from the outside.

the ports your saying… ill try to open both of them up for (21,20) and try again.

You definitely need the ports forwarded. Active FTP uses TCP ports 20 and 21.

OK,

i removed some of the left over junk in my port forwarding… and now 20 and 21 are assigned to .112 and its WORKING…

but now i cant upload anything. i can only download.

any ideas?[hr]
the ONLY user that can log into this ftp is “root”

even tho my shares have other users assigned.

thats what i think im stuck on

What error do you get when you try to upload?

ok, with cyberduck it works now…

so the big question: how do i prevent people from looking around the ftp when root / root gives them access to everthing.

how do i set users and permissions for the ftp?

Sorry, you’re beyond my knowledge of Drobo FS and Pure FTPd… I’m sure someone else who’s using it will chime in. :slight_smile:

ok thanks anyway… ill idle by and hope for the best.

-c

edit the /etc/passwd file and for the user account that is going to ftp into the DroboFS, you want to edit the home directory to be the location they start with on system and end it with ‘./’ For example say you want user to start in /DroboFS/Shares/Public/FTP/ and you want that the be the root directory for that user (ie they can’t go higher up that FTP) then change their path to:

/DroboFS/Shares/Public/FTP/./

As for permissions, you should read up on chmod and chown

here is the passwd file:

you can see that after the first root is a bunch of jiberish. then the root directiory login.

then below that is some nobody code. is that preventing my regular login users from use the ftp with their user and passwd?

you can see i have two users below that. netviper and upload.

how can i assign those users to the FTP?

I want each user to have their own folder and own login information.


root:$1$$oCLuEVgI1iAqOA8pwkzAg1:0:0:root:/mnt/DroboFS:/bin/sh
nobody:x:99:99:Nobody,:/:/bin/false
avahi:x:100:100:Avahi Daemon,:/:bin/false
netviper:x:1000:1000:Linux User,:/home/netviper:/sbin/nologin
upload:x:1001:1001:Linux User,:/home/upload:/sbin/nologin


thanks for helping… i think im getting closer to a real solution now.

-c