Drobo

Pure-FTP FXP Howto

Hi

I couldn’t find it on the forum, so I’ll post it in case anyone else needs it.

I have two Drobo FS’es, and want to be able to transfer files directly between them with FTP (instead of e.g SMB via a client PC). The easiest (for me) way to do this is using FXP with FlashFXP from my Windows PC. The way this works is that FlashFXP acts as a sort of command center for the ftp servers on both drobos, and can initiate transfer directly from the ftp daemon on one drobo to the other, without going through the PC.

Sounds nice, doesn’t it? Well, out of the box, the pureftpd droboapp isn’t configured for allowing FXP, but the capability is there, and easy to enable (see http://download.pureftpd.org/pub/pure-ftpd/doc/README, search for “FXP”) just by adding a command line parameter to the pureftpd startup.

The simple two-step solution is as follows:

  1. Edit the service.sh file in the pureftp droboapp folder to add “-w” to the command line for starting the daemon, so that the start() function reads like this (I used vi from the shell, but you can probably do it with any windows based texteditor via the DroboApps share, too):

start() { ${prog_dir}/pure-ftpd -w -g ${pidfile} -O clf:${logfile} >> ${logfile} 2>&1 & }

The only thing different from the default command line is the “-w” wedged in between “pure-ftpd” and “-g”.

  1. Restart the pureftpd daemon (the ftp “service” in Windows parlance) by ssh’ing in (requires dropbear installed), navigating to the app folder and issuing the following command:
./service.sh restart

You could also just restart the entire drobo if you’re not comfortable using the shell for this, or you simply do not have dropbear on your drobo.

Do this on all the drobos you’d like to enable FXP for. Now you can do FTP directly between them using e.g FlashFXP from a client machine.

Please note: FileZilla cannot do FXP, and I am not aware of any other decent free FTP-clients (for Windows) that can either.

Tusse.

Thank you so much!
Now I have to figure out how to enable FXP on the USB storage on my Asus router haha.

Transferring via USB to PC then over wireless to the Drobo (GBLAN) is taking forever. :frowning:

But thank you again for this.

If anyone cares:
I have an Asus RT-N16 router. To enable FXP, I put a custom firmware (TomatoUSB) and added a custom config for the server that was running vsftpd (pasv_promiscuous=YES)

Everything seems to be working now :smiley: