ProFTPd and Firmware updates

Greetings to Richardo and anyone else reading this thread,

I have had an odd issue. It seems that each time Drobo pushes a Firmware update and I install it on my Drobo5N, it breaks ProFTPd. I can’t start the app and eventually have to do a reinstall. Has anyone seen this behavior and, if so, have you found a fix for it so that it doesn’t continually break?

Also, what are the chances of getting ProFTPd added as a Drobo-certified app, so updates can be pushed through the Drobo Dashboard instead of side-loading them?

Update: Ok, I figured out part of the problem. It appears that whenever I run a firmware update on the Drobo 5N, it resets not only the root password, but also overwrites the hosts file, effectively removing the IP address for ProFTPd. I replaced the hosts file and it started up. Has anyone else seen/solved this?

The questions about ProFTPd as a Drobo-certified app still stands.


The latest version of ProFTPd solves hosts this problem. Did you give it a try?

I believe I am currently running the most up-to-date version (1.3.5) and have had this issue every time Drobo pushes a firmware update, which overwrites my hosts file. When I get a chance, I can attempt an upgrade/reinstall of ProFTPd, just to make sure. Is there a location where I can find the current version number?


Just reinstall the latest version to make sure. All the releases can be found here: