Problems with mounting Drobo on Raspberry Pi

I was running Sonarr on RPi and was able to mount directories on Drobo.

I upgraded the DRobo 5N to fw 3.5.6

Now the Pi does not mount directories.

If I mount directly from the Pi using

sudo mount // /drobotv -o file_mode=0777,dir_mode=0777,nobrl,username=XXXX,password=XXXX;


// /drobotv -o file_mode=0777,dir_mode=0777,nobrl,username=XXXX,password=XXXX;

into /etc/fstab

does not auto mount on startup.

I have tried to edit cmdline.txt to add rootdelay=20
but that does not help.

To summarise, it worked ok with the old FW.

any help will be appreciated.


hi basil,
i think in one of the recent firmware updates, the root logins were changed. (maybe tweaking your script to use a different login method and then to maybe sudo it can help auto log in again?)[hr]
this thread might help a bit too:

I login as admin so the changes to root dont apply.
(it took me a while to work it out)

I dont understand why I can mount them directly from the command line but fstab does not work.

I have not worked out how to get a script to work on linux.
(I am a very elderly nooby.)

Thanks for the thought though.


ah ok no problem, lets wait a bit as there are some other users who know a lot about logins and apps and even some who know script-foo :slight_smile:

// /var/www cifs uid=www-data,gid=www-data,file_mode=0770,dir_mode=0770 0 0

Is how I have mounted a directory on my DROBO FS to my PI for web serving
It auto mounts on boot and has been working like this for a while now

I am not an expert at anything (unless you count crashing model helicopters)


I fixed it by adding ‘cifs’

Thanks for the help.


nice one basil (and rob)

[quote=“bhbloom, post:1, topic:142249”]
I was running Sonarr on RPi and was able to mount directories on Drobo…[/quote]


I’m glad you were able to solve it with robocog’s help. I currently run Sonarr on Windows, but would like to move it to either my Drobo (although there is currently no DroboApp for it) or my Raspberry Pi. Can I ask you a couple questions about running it on your RPi?

First, I’ve read about people running Sonarr on a RPi 2nd generation, but not 1st generation. Is yours a 1st generation or 2nd generation RPi?

Second, what OS do you run on your RPi?

Third, did you have any trouble with Sonarr dependencies, ie mono?

Thanks in advance,

P.S. Although my questions are directed at Basil, if anyone else has run Sonarr on a Raspberry Pi I’d love to hear from you as well.

[quote=“harrv, post:8, topic:142249”]

Hi harrv, I’ve run Sonarr on a Raspberry Pi 2, and 3. Currently using it on Raspberry Pi 3, and it definitely works best there. Used to use SABnzbd+, SickBeard and Couchpotato on a RPi 1, which was fine for unattended operation but wicked slow for hands-on direct user interaction.

No issues with any of the dependencies. Tutorial I used was here:

However, you do not need to go through the painstaking manual mono installation they have there. Just install mono from apt-get, install Sonarr and everything will work flawlessly. Can take a few minutes to start up the first time you launch it, but it works quite well once set up. I cannot currently get my Drobo 4-bay Gen 2 to actually mount on the Raspberry Pi (Thread here:, but Sonarr, SABnzbd+, and Couchpotato all work admirably. The latter two were fine even on a Raspberry Pi 1.

Thank you for taking the time to write that reply. That’s useful info. My two RPis are first generation, but if I can’t find a way to run Sonarr on something that I already leave turned on, then I’ll probably get a RPi3 for that, based on what you’ve written. I tried for a day or so to get it to run on an RPi1 without luck (because of Mono issues on the RPi1, primarily).

hehehe in a nice way i find it both interesting and funny that some of the apps have funny names :slight_smile:

so far (from memory) i have seen these app names being used:
couch potato, (which is me at the moment) :slight_smile:
and also a drop bear,
and even a midget spy :smiley:

Hi Ben

Sonarr works on the Pi 2 and 3.

I have also got ti to run as an unofficial app on the Drobo albeit with some problems.

  1. the ost processing does not deal with files in subdirectories.
    once the files are copied to the main download directory it then parces them correctly.

  2. I am also running Plex on the Drobo and it stops almost every day and needs to be restarted.

this does not hapen on the Pi2 and Drobo at home.