Drobo

Problems with Dashboard 2.0.1 (mac) ?

So I updated to DD 2.0.1, that bit seemed to work OK.

Since then I have had irreparable damage to some disk images held on my DroboPro (TM Backup sparse bundles, SuperDuper image files) caused by several lockups, the drobo dismounting and generally things getting stuffed.

I have a support case open (110614-000026) but have had to remove the Dashboard software and shutdown my DroboPro to keep my MacMini running (it just acts as a server for all my other stuff). Where can I download the previous DD version from?

Although to be honest, I’d prefer to give the unit back for a refund (alas outside suppliers 1 year return - Drobo want to refund me?), not too chuffed with the Pro at the moment, as I’ve had the reboot loop problems and kernel panics before and have lost confidence in the product.

The last straw was it was just sitting attached, and I’d flipped over to my other RAID box as primary ( I backup the Pro daily, because of previous issues) - re-building one of the TM backups to that drive. The DD just disconnected the DroboPro locking the MacMini up with it, volume on the Pro didn’t mount on a reboot so it may be stuffed now.

So, what to do my expensive black brick…

I installed 2.0.0 on my MacMini/original Drobo combination in the vain hope that it actually did something more than the old Dashboard, alas no such luck. I did a “check for updates” (after searching for five minutes to find that option!) and it said I was up to date, when clearly I’m not, as you have 2.0.1.

Sounds like I should skip this update, but what’s the point of a check for updates feature that doesn’t find updates?

DD 2.0.1 is a waste of bytes. Destructive operations are too easily accessible in the GUI, the iSCSI on Mac disconnects and crashes (hard), etc…

Seriously, Drobo needs to do some testing under load before they release stuff like this. Horrible.

Rolled back to 1.8.4 which seems to work.

I’d would, but the volume on the Pro is none to well. Plugged it by FireWire to do some test - won’t put the dashboard on again, been burnt too many times now.

Just had enough of the Drobo experience.

I’m going to install GlobalSAN which I have in use in a client site. Works much better than the pathetic Drobo Dashboard.

Wonder if GlobalSAN works in Lion?

Not sure, I also use the ATTO initiator to other iSCSI boxes. Very stable and performance better than the Drobo pro. Happy to pay for it, had an email to say it’s supported in Lion too.

Comment back from support, use the GlobalSAN iSCSI initiator until DD is fixed (!).

Well, that is a leap of faith too far given OS X Lion is soon to be here. Data is corrupt on the DroboPro, so to try and rebuild it then ‘hope’ a new dashboard will come along and not stuff it again, that requires more customer dedication that I am able to offer.

I have experienced some instability with the DD on my DroboPro once in a while as well. And am now interested in third-party iSCSI driver if it will work well with DroboPro.

After reading the forums here, I’ve read many have suggested GlobalSAN. And you’ve suggested ATTO (Xtend SAN iSCSI?) too. Have you had experienced with both (ATTO and GlobalSAN) to suggest which is more stable/ speedier vs the orginal DD?

Will I be running into compatibility issues with the DroboPro because I’ve read people had problem with GlobalSAN long ago.

Please advise, thank you.

Yes, the ATTO is the one you mention. I have never tried to use any third party software to talk to the DroboPro although they said to use the normal iSCSI port (3260) so it must be possible. The downside is lack of any management, so ability to cleanly shutdown or restart. Others on these forums have done it and report it did work.

I have used the GlobalSAN initiator against other iSCSI boxes I have, but could only get v3 to really work with stability under sustained load, this doesn’t like 64bit through. The current v4.1 is supposed to be 64bit, but has no mention of Lion support and GlobalSAN won’t help with issues. I gave up on it when it was ending it’s beta phase, the stability didn’t seem to be improving.

The ATTO installed and worked out of the box, has never missed a beat and is fast. It’s also $200 a copy which is probably why, but they’ve said it will be supported under Lion. I put that on and have never looked back.

My DroboPro is now, however, a large black doorstop as I’m not going to rebuild the data on it again.

Thank you for the informative reply. It’s sad to hear that you had so much trouble with your DroboPro. Do you ever suspect there chances that it’s caused by 3rd party iSCSI driver compatibility issue? Having heard of your experience, I’m not sure if I should get rid of DD even though I wanted to.

The worst I’ve experienced with the DroboPro iSCSI is that it disconnects once in a while, gave me some “Drive is not eject correctly…etc” type message, and reconnects itself again. Luckily all these random disconnections happens when nothing is transferring. However, I’m not sure it’s good for the drives in the DroboPro in the long run.

This is the only iSCSI device I’ve used, so I don’t know if other iSCSI devices in the market experience random disconnections or is DR product’s iSCSI not implemented well enough.

I found after a couple wake-from-sleeps the Drobo Dashboard will be unable to detect my DroboPro even though the drive itself stays connected on my Desktop, and I was able to access it fine. So not I just kept DD closed (stay quit) and open it only when I want to check storage space or change settings.

I think the Drobo concept is a good one, but sometimes I felt some part of the device is half-baked, mostly on the firmware/software side of thing. I hope DR is still making enough money, I’d hate to see something I spend money on goes to waste, especially when it’s not cheap. I’d probably spend the same amount in some MartinLogan speakers I’ve been eyeing recently and enjoy myself then deal with the trouble & fear of data loss and corruptions.

So, rjc, what are you backing your DroboPro on? I’d like to hear some life-after-drobo recommendations in case sh*t happens. Some RAID5 NAS drives?

I have never used a 3rd Party iSCSI initiator to talk to the DroboPro. I have noticed that if I reboot my switch, I get the drive disconnect as you describe. However the problems I have don’t do this, what happens in Finder goes a bit non-responsive and the Drobo seems to come and go. Errors thrown up in the Kernel logs, on the odd occasion a Kernel Panic too.

I use a ReadyNAS NVX Pioneer over iSCSI (available in the latest software) to hold the bulk of my stuff at the moment. For a unit of roughly half the cost, with 5400 RPM drives as opposed to the 7200 RPM in the Drobo - it out-performs it. I don’t use it for nor NAS stuff (CIFS/SMB), just as an iSCSI target (but with multiple clients). I also have a couple of large FW drives which I bought when the DroboPro problems started. Each night at 0100 my MacMini would image itself to the DroboPro, then at 0200 delta changes to the data on the Pro would be copied to other media (using ChronoSync). So I have copies of everything on the DroboPro, but spread around other non-protected media. Data I cannot rebuild (such as digital photos) also go onto drives and into a fire safe when I feel the need to do that.

I wanted to go iSCSI to keep the filesystem native HFS+, as I front the majority of my storage by a MacMini this works quite well. That leaves me free to store the data on what I like, without having to reconfigure the other stuff I have that uses the data - my media will always be on //macmini/itunes regardless of where it is behind the scenes, for example. iSCSI also enables the disks to be where the noise isn’t a problem, all the Disks and fixed computers are on a UPS too.

Don’t get me wrong, I do like the Drobo concept. I had a smaller 4 slot unit but it was so slow I couldn’t stream multiple music tracks from it to my Sonos without dropouts. So I jumped and went for the DroboPro, initial problems I put down to user error. I even wiped my MacMini clean and re-installed thinking something on that was causing the problems. I have had the dreaded DroboPro reboot loop issue (after using the dashboard to shutdown the unit to move it) and the recent pretty dire upgrade have left me feeling that if the management/driver software can be that bad, how much risk is my data exposed to?

FYI, Drobo Dashboard 2.0.X does NOT work with a Drobo Pro. (at current writing) - at least not on a Mac.

I had numerous corruptions and iSCSI disconnects and went back to 1.8.4 and have had months of rock solid stability.

May I ask which Dashboard version did you installed on the DroboPro. Is it 2.0.2?
On the download page the newest version of Dashboard for DroboPro is 2.0.2. I’ve downloaded 2.0.2 for my Pro but still somewhat jumpy about installing it…

I went ahead and installed DD 2.0.2. Everything was fine for 10 minutes or so after reboot. Then DD 2.0.2 lost connection of the iSCSI even though Finder still show its mounted. Then Finder froze…so had to force restart the iMac.

I uninstalled DD 2.0.2 and installed latest version of GlobalSAN iSCSI initiator. I found the GlobalSAN instruction under the DR support page:
http://support.drobo.com/app/answers/detail/a_id/600/kw/globalsan/r_id/100004

Seems to be fairly stable after install. The latest version was said to support Mac’s sleep so don’t have to unmount drive before you sleep the computer.

However, even DR support said you can use Drobo Dashboard with GlobalSAN iSCSI: “One can now use Dashboard as normal, noting again those LUNs targeted (“used”) by the GlobalSAN initiator”

I later found it probably only apply to the higherend business models that support SAN storage ability.
On my Dashboard, Drobo Pro was not detected with the GlobalSAN + Drobo Dashboard combination.

Conclusion:
GlobalSAN (version 4.1 build 279) works pretty good with DroboPro (I’ll run for a week and see it’s more stable than DD without disconnections).

If you are using it on a DroboPro, you cannot use Drobo Dashboard to manage/change settings after you use 3rd-party iSCSI initiator.

So if one want to use 3rd-party initiator, one should set the IP address with USB/FW using Drobo Dashboard, then connect iSCSI with 3rd-party initiator.