Drobo

Problem with shrinking volume

Hi,

I have a Drobo version 2 connected via Firewire 800 to my iMac on Snow Leopard.

I previously had four hard drives in it:
2TB
2TB
2TB
1.5TB
In use: 4.3TB

I decided I would like to move some data onto a standalone drive so removed the 1.5TB drive. This meant the Drobo started asking me to insert a new drive as I had nearly 4.3TB of data on the three 2TB drives, too much. So I copied lots of data off the Drobo onto the standalone disk and now have 3.16TB of space used on the Drobo.

The problem I now have is that it won’t reshape, and sits there coloured red saying it can’t protect against failure.

I had an old .5TB drive that I thought might help the situation so I plugged that into the spare Drobo slot and unfortunately it still won’t reshape or protect against a hard drive failure. It looks like this now:

2.0TB
2.0TB
2.0TB
0.5TB
In use: 3.16TB (stated capacity - 4.07TB)

What can I do to make the drive reshape and reprotect my data? Is there something I can do to kick this process off? Do I need to replace the 0.5TB hard drive with another 1.5TB hard drive as this is impossible - if this is the case will I now lose data if I try to swap the 0.5TB hard drive as the data has partially been moved to the 0.5TB drive?

Help!

Have you tried rebooting the Drobo?

Thanks for the reply. I have tried rebooting the Drobo, but it has just booted back up with the same effect - no reshaping and still red.

I have since taken out the bottom 0.5TB hard drive I inserted to leave me with 3 2TB hard drives. I’m going to move approx 0.5TB off the Drobo onto this drive which will leave me with 2.7TB used out of 3.6TB capacity. I’m hoping then the reshape will start after I reboot it again.

Have you emptied the trash? Both Win and Mac hide files in some location when you delete them. Until you empty the trash they still take space.

were you ever able to get this fixed? I’m having the same problem, I had 2x400gb and 2x500gb drives, and removed one of the 400gb drives. it just sits there warning that i must insert a fourth drive, and if i insert a smaller one (ie 160gb) it complains that the replacement drive is too small. Also running Snow Leopard, tried Disk Utility’s Repair Disk function, no change even after multiple reboots of the drobo and the computer. I will try plugging it into my Leopard system, maybe I’ll have better luck on it.

@kmethas when you go into dashboard > advanced controls > data tab, what is the percentage for full and free space available?

Its been almost a month, @honeykrak never replied. 1.5,2,2,2 = 1.5,2,2=5.5 for protection with 4.3 used. After removing the 1.5 s/he had 2,2,2 = 4 protected with 4.3 data on it. WTF? His/er data is still there, but not protected.

Adding the .5 drive shows .5,2,2,2 = 4.5 protected capacity with 4.3 used, or 95.6% full.

@Kmethas did a similar thing – remove a large drive and replace it with a smaller one.

THIS IS DUMB, PEOPLE.

Drobo is hungry and wants a larger drive. Feed it. DOn’t remove a large drive and replace it with a smaller one.