Problem connecting to USB port Lose all lights

I have a Drobo 5N that I have had for about 4 months. I do not keep Drobo connected and powered up unless I am doing some back ups. Now when I power up and plug in the Drobo to my PC I lose all the green ok lights for drive bays as well the power light turns from green to amber and all the blue storage lights disappear. I used the Drobo maybe a month ago with no issues. The USB port I am plugging into is a I/O Gear USB card that was on the compatible list provided on Drobos website and when I plug other devices in same port I plugged Drobo into it works fine. I can plug Drobo into another PC and it works fine and the loss of all the lights does not happen. Any ideas what could be going on???

Wait… 5N or 5D??
5N does not have a USB port…

Assuming you are referring to 5D, have you tried updating the driver on that PC?

If you are using a Renasas based one, it should be at least version and above.
The lights disappear because it went into standby. And that happens when Drobo does not detect a data connection.

Whoops yes its a 5D. I have a 5N also. I will have to check drivers but as far as I know I have not updated any drivers recently and it worked about month ago when I backed some data up and I did not have this problem.