Power outage, and now I have no file system. :(

A couple of days ago I got an alert that my home server was down — turns out there was a 30 minute power outage. Normally my UPS is supposed to kick in and shut down my Mac Mini that has a Drobo 2nd generation attached to it. Looks like that wasn’t the case.

When I got home and rebooted my mini the Drobo came back on, but one of the drives was flashing red. This has happened in the past but usually a reboot fixes it, and here it seemed to work as well.

I can see the Drobo in DD and it shows the proper amount of drive usage, but there’s no volume listed - it says “not formatted”, and looking at diskutil info for the drive shows it a having no file system. :frowning:

And YET, running fsck_hfs on it does return the proper volume name. The drobo has been churning away for about a day with all four lights flashing amber (DD says it’s in the middle of data protection).

Is there any way to get this fixed or at least mounted so I can pull the stuff off of the Drobo, or am I SOL?

Many thanks for any help anyone can provide.

if it thinks it is rebuilding the first thing to do is let it finish rebuilding… then see what the status is

some people have had everything suddenly pop back to normal once the rebuild finishes…

i’d definitely advise not trying to fix things until it finishes

Okay, so the rebuild completed and I’m still stuck in the same situation - no volumes are available. I can see the partition that has the data when I run diskutil, and I was able to even run fsck_hfs on that partition which returned no errors. But I still can’t mount that partition.

Any other ideas? I have backups, but we’re talking terabytes of data and I’d like to avoid having to resync all of that if at all possible.


i dont know, im not a mac guy

i can tell you that a lot of people seem to have had success with diskwarrior

i’d suggest that if that is not your only copy of the data - then your best bet is to just reset it and start over

i would be wary that any “repaired” version of the file system may have some corruption - and it could be hard to spot / find until you find that crucial file which doesn’t open

if you do have backups, then personally i’d just nuke it and start fresh

It’s alive! I had to rebuild the partition map (I used Testdisk, which I hadn’t heard of until this morning) but things are working now.[/align]

well done

it might be worth running some kind of read-only mode of mac drive checker, maybe diskwarrior has a read only mode, just to make sure there’s nothing else which might have problems, but like docchris said usually after an outage it recovers on its own.

(i had to leave it overnight a couple of times in the past and then after a full power down and restart, all was fine - fortunately for me everything on it is backed up to another drobo so i was able to run a full file-by-file comparison and a few checksum tests and all was ok)

I have the same kind of problem with a 2nd gen Drobo at the moment. After power outage the Drobo isn’t able to mount in OSX. Worked perfectly before that.

The Drobo shows up in Dashboard (2.2.3) and in Disk Utility, all lights are green, it’s 60% full (6 blue lights), standby works, boots like normal, but doesn’t show it’s volume to the OS it seems. Tried on other Macs and via USB in stead of Firewire, nothing helps :frowning:

Is this Drobo braindead?

hi hang in there sp,
have you tried booting up the drobo gen2 (after keeping it off for at least 5 minutes), but with Only the power cable inside?
and then after all lights are green and leds seem in synch, to then try to plug it into the mac via usb?

(i had to do this a few times in the past, on a windows machine, and it seemed to do the trick)
i then ran a chkdsk on each volume one by one after wards too.

In addition to what Paul suggested, also run Disk Utility and see if any volume appears in there. Maybe OSX just isn’t auto-mounting it for some reason.
If you can see the volume in Disk Utility, you can run a filesystem check (“Repair”). You can mount it manually. You can also use something like Drive Wizard to fix problems.
If you can’t see the volume, then it might be time to contact Tech Support. Drobo clearly sees a volume with data on it, so the question would then be “why does Drobo see a volume, but not present it to the OS?”

For what it’s worth, I got fed up with the whole system after years of hassles and dumped Drobo for a Synology NAS. That said, if you able to mount the disk but see no partitions Testdisk is your friend. Not easy to use, but it worked for me.

Once you get things readable again, BACK IT UP - and DON’T overwrite any old backups you might have - make a fresh new one, just in case the data behind the files you see has gone wacky.
I doubt this will be a problem, but it’s better to be safe than sorry.

Alternatively you if you do have a semi-recent backup, you can run a CRC/SHA1/MD5 verify against the backup as a confidence check.

In the past there have been a handful of occasions when one of my Drobo Gen 2 units just got “stuck” and needed a cold restart (unplug power, wait 30 seconds, plug power back in, wait until it finishes booting).

For anyone else who may come across this thread…
My Drobo Gen 2 units are significantly slower to respond while it’s in the process of a rebuild. I once had it connected to my PC while rebuilding and it took 5+ minutes to bring up the directory listing when I tried to access it during rebuild. So now I try to avoid using it during a rebuild.
You still can use it… you just have to be patient - it may appear to be dead/unresponsive but be extra, extra patient - likely things are fine, it’s just very very busy trying to re-establish fault tolerance for you.

Thanks for the replies guys,

I did a repair via Disk Utility as rdo suggested, but this halted after 2 hours into a “can’t repair this disk, backup all your stuff asap, etc”. So after that, I tried Disk Warior but that didn’t even start a repair, just sees the Drobo and tells me "Directory cannot be rebuilt due to disk hardware failure (-36, 2738).

How crazy is this? My Drobo smiling at me with all green and blue lights, Drobo Dashboard telling me all is fine and nothing to worry about, but in the meantime my Drobo is actually rendered useless :confused:

I contacted tech support in Europe, sent them the diags, but they couldn’t help me right away so have passed it on to tier3 support in the US. Now praying that they have something of a solution to my problem :frowning:

Yes - unfortunately it looks like your data has become corrupted… and drobo is sitting there happily duplicating and protecting that corrupted data :S

(Uh, yeah. I meant Disk Warrior. No idea where “Drive Wizard” came from.)

I’m sorry to hear that didn’t work, spscheele. Whenever I’ve talked with Drobo Tier 3 support, I’ve found very capable and experienced people with deep knowledge of Drobo. That doesn’t guarantee they can recover your data, though.

I wish you “viel erfolg” good success – and recent backups.

Unfortunately this is a case where the storage device itself may be fine, and the data stored on it protected from loss, but the data on it has been corrupted, most likely due to the unsafe shutdown on the power cut. So as Docchris said, Drobo is happily making sure that you don’t lose any bits - it’s just unfortunate that those bits aren’t making sense to your Mac.

I’ve had this happen on loose drives, flash drives, as well as Drobo - if the host machine doesn’t complete its changes to the filesystem successfully, the filesystem may be corrupt regardless what kind of device it’s stored on. :frowning:

Best of luck to you, hope you can get things recovered with minimal time and loss!
BTW, have you figured out why your UPS didn’t trigger a safe shutdown? Perhaps the battery charge is no longer holding so it’s having a sudden rather than gradual discharge?

A -36 error is often a communication error. If you have the Drobo connected via FireWire, switch to USB and then try Disk Warrior again. Or vice-versa. Also, booting from the Disk Warrior disk can sometimes help or connecting the Drobo to a different computer and trying Disk Warrior from there.

as far as i know, a pc formatted drobo should be accesible on a mac,
im not sure if a mac formatted drobo would be visible on a pc (or actually accessible) but maybe you could try a windows machine to see if it recognises the drobo?

(also, have you actually shut down the mac during this? eg a full shutdown of mac, and wait a bit and then cold boot the mac? just in case the mac os thinks it’s still mounted somehow)

Hi guys,

Thanx again for all the feedback and good luck wishes :slight_smile: I tried basically everything in my knowledge (I’m an IT guy, so not completely clueless) and what I could find in the Drobo support guides, but nothing worked.

I’ve received some very good help from Drobo tier3 support already. They advised me to run a deep scan with Data Resque 3, which has been scanning for 4 days straight now and is only at 12%, so I guess I’ll have to be a bit more patient.

to be continued!

(by the way, I have a crashplan.com backup of the Drobo, so all is certainly not lost)

wow - a crashplan backup for a drobo - your internet connection is WAY WAY faster than mine!!