PMU Battery Replacement Drobo 5D

I recently had the dreaded blinking green light on my power supply and my 5D would not power up. I was told that my unit was gone and beyond repair but I tried one thing before tossing it in the trash - removed all the drives, cut the low voltage end off of my power supply and hooked it up to my lithium battery car jumper which is 12 volts to see if I could get the unit to power on - it did. I left the power only only for a few seconds and once I saw it would work, (If you do this, use only a regulated power supply and be sure and get the polarity right and you are doing this at your own risk). I ordered a new power supply. Everything works great! But, in the discussion with tech support I was told that my unit was 7 years old and that the battery on the PMU was probably bad and that I just needed to purchase a new unit for $664 or send mine in for repair for $420. It is working now with a $65 power supply but now I am worried that it is a ticking time bomb due to this $5 internal battery design flaw. Does anyone know how to replace this battery or do I just leave it to fate and never know when I am going to lose all my data (yes, I have a back up).

My understanding is the battery allows the Drobo to keep running long enough during a power outage to finish writing any cached information to disk. Personally I would not worry about it.

Yes, I would like to replace the battery as well. In other threads, there is mention of the dead battery being involved in the Drobo 5D not powering up at all…which is happening to me right now. I also received the big $ upgrade offer, but am waiting on a new power supply first to see if that works (no indicator light at all). Hopefully that works, but there seem to be many cases of that not being the total solution.

@Moodle mentioned that the battery is in the back (after taking it apart)…and after removing it, all was good. I’d like to not only remove it but replace it.

Perhaps Moodle can share where it’s located? I’ve opened the unit and removed the drive bays, but don’t see it yet. 4 or 6 screws(?) look like they would allow to remove the back (with the fan assembly and such) but not sure I want to go that deep without knowing better what I’m going to find there.

Thanks for any help! (Don’t know why Drobo won’t make this a serviceable item or user replaceable if it can extend the life of the unit…ahhhh, right. If they extend it, then you won’t upgrade to a new one! :wink: But it’s not like it’s useless…it serves an important role in backing up and protecting the unit, and having a fresh battery seems like a very good idea!)


Update… The new power supply worked, so dodged a bullet. But I did take the unit apart and explore the battery situation (while waiting for the power supply to arrive).

The battery - at least in my unit - is a Joules Milles Bumblebee B 2150mah 3.6v battery pack with a connector to the board in the back of the Drobo. So it ultimately is replaceable - if you can find the battery! I haven’t been able to find it anywhere, and have written to Joules Milles in China but got no response. (The battery also says it’s a Panasonic CGR 18650 CH cell (haven’t looked for that yet…perhaps should do!). Whether it comes ready to install with the wiring is unknown - or did Drobo do that themselves?

So if you’re comfortable figuring out how to take your unit apart, the battery is replaceable. Of course, Drobo has said they don’t offer replacements. So you’re on your own. If I find a battery source, I’ll update again.

The 18650 batteries are widely available and if you battery pack is made up from these it should be a fairly simple fix. If you have a Batteries Plus in your area they can easily build you a new battery pack within a day (usually). Or maybe try their website if you can’t get to a local brick and mortar location. {[]} This site is another source.
Good luck, you’ve got this.

I have been struggling with my old Drobo 5D and not being able to power it up easily. I’ve replaced the power adapter once already. After reading this post, I hypothesized that the backup may be dead and interfering with a clean power flow during startup. After getting access to the battery (that was no fun), I just unplugged it (did not replace it). After putting the Drobo back together, I find it powers up just fine now!! I plug my Drobo into a UPS system so I am not concerned about not having the backup battery. Taking it out of the power path just solved a big problem for me.

1 Like

Good job finding a solution.