Plex Update not working


Please move to the correct forum is this is the wrong place!

I have tried to update to the newest version of Plex ( more than once, and even though the update seems to “work” my NAS is still running the older version. I copy the plex.tgx file to the Drobo Apps directory and then restart the drobo. When I browse to the apps section after restarting I am prompted to update the Plex software. However once that is done I login to the plex portal through the web and it is still the old version.

I have tried restarting the drobo again afterwards with the same result. What am I doing wrong that it will not update?



Don’t click update in the drobo dashboard after manually installing. The dashboard only checks if the version on the drobo matches what the drobo app web service has as the most recent version listed. It doesn’t actually check to see if the installed version is newer than the version available via the app interface. Indeed, you manually install that latest version, and then Drobo Dashboard reinstalls the previous version.

I’ve always had this issue with Crashplan, but it can take more than a month for the app interface in Drobo dashboard to report an update, compared to checking or in this case, directly on the Plex website. very sad this is so slow!!!

Is best to go to and check for the latest Plex Server for Drobo (NAS) and download it from there. Then manually update the Plex. After manual update the Plex Server to the latest from site, simply ignore any prompt from the Dashboard about there is an “update” for Plex.