Please help - Drobo not seen on Mac


I have a frustrating problem I really need help with. I have a Gen 2 Drobo that’s been working fine on Windows. I wanted to reset/format it and use it on my new Macbook. I reset the drobo and powered it down… Moved it to the Mac. Dashboard on the Mac does not find it but Disk utility does. After exhaustive research I tried to format using Disk utility. Error. I used first aid which did not produce any errors but nothing changed. I tried to mount it in disk utility but nothing happens. I moved it back to PC and dashboard finds it straight away. I have the idea to format fat32 but the only option is NTFS. So I format NTFS and move it to the Mac… Dashboard again does not see it, BUT the drive mounts on my Mac (in finder and on my desktop). But obviously I can not write to it as it is NTFS. I know there is software to enable this but I am hesitant to use it… Dashboard still does not see the drobo.

Is there anything else I can try?

Thanks for any help

hi jon, some of the tips on this page may help you, though especially in step 8:

am not sure if you were using the latest overall dashboard version, though you might need to try the latest version of dashboard for your gen2 from here as well, just in case to see if one works better than the other: