Pinhole reset for Drobo FS does not work

Hi. I have lost access to my Drobo FS via Dashboard. The Drobo picks up an IP, but when I scan it with nmap, it seems no ports are listening. The data seems to be intact, as indicated by the capacity LEDs in the back, but without the network, there is no way for me to access it.
I was wondering if pinhole reset might help restore networking back. But again, without Dashboard my only option is the reset pinhole. I have try differnt steps and procedures that I saw on this forum and elsewhere on the Internet. Nothing seems to work. How do I reset my Drobo FS to factory defaults without Dashboard? Any help and advice would be greatly appreciated.

I had a Drobo FS until recently. I had to perform a pinhole reset before giving it away. The documented way (which seems to have disappeared from Drobo’s site) did not work. I had to find some other users that had had similar experiences. Here is the method I ended up using (you can disregard the bits about firmware upgrades):

I hope that helps you out!

Regards,

Dom

Thank you for the reply, Dom. I think I’ve come across this procedure and attempted it without success. I was unclear about it. Step 3 requires the removing of the power adapter from the Drobo. Then Steps 4 and 5 require pressing and holding of the pinhole and power buttons at the same time. Then Step 6 mentions waiting until lights come on. Well, is power being reconnected to the Drobo at one point? If not, then how are any lights going to come on? As far as I know, the Drobo does not have any internal batteries.

In rereading it, I think I was a little unclear in my instructions.

You almost need 3 hands to perform the pinhole reset. Between steps 5 and 6, you need to plug in Drobo, while pressing the power button AND the pinhole reset button. Then, you wait until the top red light turns on. I’m going on memory of a process that I did about 2 years ago, though.

In any case, I hope that can help you.

If I shut down the Drobo gracefully from the start, then plugging power back between steps 5 and 6 does nothing. I have to press and release the power button for it to power on. But if I just unplug power while it’s running, then it’ll power on automatically when power is plugged after step 5.

However, I didn’t have any luck with the procedure. Does the reset produce a unique bootup LED pattern? Because when I go through the reset, the Drobo boots up exactly the same way as a normal startup. How do I know if the reset is getting triggered?

At this point, I think that one of two things is happening. Either the reset is not working at all for some reason. Or it is resetting, but the problem that the Drobo picks up an IP, but no other network services or ports are starting, is because something got physically shorted or died in the circuitry, and factory reset does nothing for it.

I remember the pinhole reset being really finicky. It took me many attempts to get it to work. The one I posted is the one I remember working, but it’s been some time so I may be remembering wrong.

Can you try connecting to Drobo directly to a computer, bypassing any network hardware? Maybe you’ll be able to pick up on it in link-local?

One other thing to consider: DroboFS only supports SMBv1. This has been disabled in modern OSes for some time as a security risk. Though you did say that nmap didn’t see it at all either…

The direct connection seems like your best bet for now.

I tried connecting my laptop directly to the Drobo. I could ping it at IP 169.254.213.234. But again, nmap did not show any ports open (all 65k ports in rejected state). I even tried my old router and set up the Drobo on a different local LAN.

SMBv1 is not the issue. It has been enabled on all my devices. And nothing changed in my environment. I had shut down my Drobo through Dashboard a couple of weeks ago. The next day I powered it on, but it never reconnected to Dashboard again. So, something to its NAS/CIFS/SMB services failed.

I was lucky that a friend had a working Drobo FS. I put my hard drives in it and everything works there. I am now transferring my data to another NAS disk. Part of me wanted to fix the Drobo, but I think maybe that’s not a good idea. It’s just an accident waiting to happen. Lesson learned from all this - don’t buy any device with a single interface to the data. It’s a single point of failure. I always thought that it’ll be a disk failure that would jeopardize my data and was very meticulous in always setting up at least a RAID 5. But it was the networking that got me,

Thanks for your help, Dom. After I migrate all my data I’ll try to reset the unit a few more tries, since you said that the process is very finicky. If I get it in working condition, then I can use it as a second backup. Or maybe sell it on ebay. Otherwise it’s going in the trash.

Glad you were able to back up your data. That’s the most important part. I got rid of my FS as it’s become a security vulnerability due to the aging technology stack in the way I want to use it. I gave it to my brother who is using it on a separate network that is only used for Drobo, but that kinda defeats the purpose of having a NAS for me. I too was most worried about disk failure when I first bought my Drobo, but I learned through this experience that RAID is not a sufficient backup solution, so I keep my data backed up in multiple locations now. And unless something miraculous happens with Drobo coming out of Chapter 11, I’m pretty sure my next NAS will not be a Drobo.

Good luck!

Regards,

Dom