Drobo

Permission Issues - Can't add new images using Lightroom

I’m on a new MacBook Pro using the first edition of the Drobo. Have 75% of the space free. Can access Drobo and view files, just can’t write to the Drobo. Looked at Drobo permissions and I have “Read/Write” access.

When trying to add new images to my Drobo (from a card) using Lightroom Drobo is not allowing me to write the files. Even backinging up a Lightroom catalog won’t work. I can view past images that were imported, but for some reason I can’t import any now.

On the tech support article “Why is Drobo or DroboPro suddenly read-only and what do I do about it?” (http://bit.ly/1Rw4T4)

I did the first bullet (shut down) and that didn’t work.

Tried the second bullet
Use the Cocktail disk utility (available from Apple’s website).Tried but I was never able to start the program without it crashing.

Third bullet - Try using Repair Permissions from Disk Utility on the Mac to fix the permissions on the Drobo or DroboPro drive. When I went in to the Disk Utility “permissions” was grayed out. I ran a check and everything came back in good order.

So do I really need to do the below:
If the steps above do not solve the problem, then carefully read and consider applying the information contained at the following link; this may involve performing steps as a “Super User” (e.g. sudo -rm), within OS X’s Terminal application, so be very careful and deliberate.
http://support.apple.com/kb/HT2963?viewlocale=en_US

If anyone has run into this I would really appreciate some advice. I’m stumped. Thanks.

Assuming your Drobo is working fine I would look at the OS X permissions.

If you right-click on your Drobo and select “Get Info” it will show the properties.
Look down the very bottom for the tick-box “Ignore Ownership on this volume”.

When this box is checked then the Unix-style permissions are ignored and you can write to the drive. If the box is unchecked then you can only write to it if you are the ‘owner’ as per the Unix Permissions on the folder.

From memory the box should be ticked by default so you can write to the drive.

This is the first setting I would check.[hr]
BTW if the tick-box is greyed out you will need to click the padlock icon to unlock it by supplying a username/password for an admin level user.

@ajspencer - Thank you! That worked. For some reason the checkbox was off. I recently added a 4th HD to the Drobo and wonder if that had anything to do with changing the permissions. I wouldn’t think so but your suggestion fixed the issue. Thanks.