ownCloud with v3.3.0 ?

I installed Dashboard 2.6.10 on Win7 laptop and fw 3.3.0 on my 5N. Selected the ownCloud app, seemed to install OK, but when I select ‘Configure’ I see a smaller window that soon shows “Navigation to the webpage was canceled”.

Seems to be the same issue mentioned by Don in a previous thread.

[quote]But if there is already older Apache 1.3.x DroboApp in the /mnt/DroboFS/Shares/DroboApps folder… the installer script thinking there is already Apache. But is a older version not Apache2.

The only way is to update the older Apache 1.3.x DroboApp to newer Apache2 DroboApp.[/quote]
If I understand the comment there, it seems like the solution is to somehow install Apache2? If so, could someone please post detailed steps on how to accomplish this? Thanks

hi, on that window, if you were to rightclick and bring up the properties of that page, does it show the full url address where it is trying to access?
(if the url contains any sensitive login info though, please mask it before posting)

For ownCloud to work… you need:

  1. Apache version 2 (A MUST)
  2. Locale (DroboApp) (Needed, if not you will see some error message on the initial ownCloud setup page due to UTF8 support)
  3. mySQL (DroboApp - Recommended)

*mySQL DB back-end is recommended by ownCloud, if you are running ownCloud server with multiple users access. By default, the DB back-end is SQLite which is not recommend for multiple users.

Lastly…

a) ownCloud user accounts are independent and separated from Drobo user accounts. Meaning they are NOT sync.

  • Although ownCloud has modules to sync SMB user account (Drobo users) with ownCloud but it will NOT work in this case. As one of the require binary is missing from Drobo 5N. Which I won’t go into details.

b) Also note that … you will need to “mapped” all the ROOT Shares or folder(s) within the 5N to each ownCloud user. And what permission of read/write. Meaning… whatever you set on Drobo Dashboard permission for certain Shared Folder to certain user… is not sync … they are independent and separate. Be careful.

For (b) … you will need to enable “External Storage” support module in ownClould. And then mapped what PATH you need to the ownCloud User account.

Example:

/mnt/DroboFS/Shares/Videos mapped to ownCloud user AAA with read.write permission.

Installing ownCloud should automatically install Locale, mySQL and Apache v2.

Can you try uninstalling it and reinstalling it.

If there are problem, please repost and we’ll try and diagnose.

Cheers!

Jason

… thanks for the helpful replies, but it’s now changed to what’s shown below:

Looks like it tried to install something anyway.
I presume the orange triangle’s are indicating something is not quite right. Any ideas what to try from here?

:slight_smile: that’s a really small pic.

Anyway… if I’m not wrong. If any of the installed DroboApps appeared to have a ! exclamation mark… that means this DroboApp package is not “compliance” to the current DroboApps Framework.

Maybe Ricardo may have a better explanation.

you can re-start Drobo to clear it up. Sometimes, it will clear up just by clicking on something other than “Drobo Apps” like “Shares” then come back to “Drobo Apps” I’ve noticed when uninstalling sometimes the “refresh” of the “Drobo Apps” screen gets this way and clicking off and back usually fixes it. If not, restarting has always done the job.