Drobo

Owncloud - using browser to config - too slow

I am having an issue with owncloud on my Drobo 5N.
When I login through a browser (with the admin account) in order to change a setting, it runs so slowly that it is unusable. I am completely unable to change any access any shares because the page never loads…
I can add and remove users, but it runs slower than I would expect.
I tried it on all the major browsers with no change in behavior
The Drobo firmware and apps is up to date, with no pending updates

Actually using Owncloud from workstations presents zero issues, and performance is normal, uploading and downloading files

Any help greatly approciated

Sorry, I can’t say I’ve ever seen that happen. Have you tried the OwnCloud forums?

The odd thing about this is that I have found that if I use the iPhone app, I am able to manage the folder permissions with no issues! - (I was walking the dog and trying out the app on my phone and discovered that I could change permissions, no problems).
So I use the browser to change users, and the iPhone app to change folder permissions…