Drobo

OSX - DroboPro iSCSI problematic

I am having problems with the iSCSI connection. When it works it is incredibly fast, but every few minutes, under heavy load - so say, uploading a file from drobopro to the net, while converting a video file located on the device, while listening to an iTunes library also on the device, the data throughput will simply cease, and sometimes go as far as freezing the entire computer, not just an application (this is unusual under OSX). The DroboPro then will decide to switch off.
Could it be that the Data Robotics iSCSI initiator for OSX is slightly buggy? I remember on the old forums that people were complaining about the DroboPro copying in “bursts” when using iSCSI

From what I remember from the old forums, this stop-and-go behavior was reported on multiple OS’s (including Windows Server 2008 and Linux, IIRC).
You could see if GlobalSAN’s initiator works better for you.

Has anyone tried the GlobalSAN initiator? I’m skeptical of using an initiator that might damage the Drobo or my system. What is DATA Robotics Take in this?

I am having similar problems with Windows 2008 Server. I find the DroboPro to be capable of REALY great speeds, but every now and then it suffers a major slowdown and the Windows 2008 Server is inundated with Event Log messages like these:

iSCSIPrt Error - “Target did not respond in time for a SCSI request”
iSCSIPrt Error - “Initiator sent a task management command to reset the target.”

These are interspersed with events like this:
“The description for Event ID 129 from iSCSIPrt cannot be found”

Eventually, the Windows 2008 Server and DroboPro seem to regain connection and the data stream speeds up again, but after 2 or 3 minutes it starts all over.

Once, it just kept spewing those errors until I restarted the DroboPro.

I consider this quite serious. As long as this continues, I would not consider my DroboPro “trustworthy”.

The issues on my unit have gotten far worse now. It stops transferring data for 30 seconds, then continues for 30 seconds, and it keeps doing that until everything is copied. If you’re trying to watch a movie that streams over 60 minutes, this makes it so tedious that you give up.
I too find that the drobopro is capable of fantastic speeds, but due to the slow-down, it takes longer copying large files over iSCSI than to a good olds USB 2 hard drive. I no longer think that this is down to the iSCSI initiator provided by Data Robotics, but rather a fault in the drobo’s OS.

I’m having similar problems. Event log is flooded with iscsiprt errors. I’m on W2K8 x64, with a dedicated nic. Tried it with jumbo frames off or on. I have 8x 500gb drives on dual disk redundancy mode.

corndog, have you noticed your drobopro simply disconnect from dashboard and unmount completely in W2K8? I seem to get this every 1.5 days and nothing (retry iscsi initiator, disable/reenable nic, etc) i do would regain connection unless i powercycle the drobopro.

It would be great if someone from Data Robotics would have a look in this forum. I remember this same issue being discussed lengthy (didn’t own a drobopro at the time) in the old forum, but the thread wasn’t carried over.
As this issue seems to be occurring on not only my machine and not only under OSX, I am daring to suggest that it is down to the firmware/OS of the device. Can we expect an update soon? Or at least an official reason why this is happening?

How is your drobopro being connected? Do you use a MacPro and having it connected to the other ethernet port? Or going through your gigabit router? I have mine connected to a gigabit switch and assigned an IP to the drobopro because I use an iMac and only have one ethernet port in the back, but it’s been working great without a hiccup so far.

I have a macbook pro (unibody), drobopro is connected directly via ethernet. Why not firewire or USB? Because when the Drobo does decide to work, it’s blazingly fast over ethernet. But not being able to listen to a song on iTunes fully before it stops half-way, waiting for data from the drobo, is frustrating.
The proper time-outs however only really happen when transferring large files, so over 1 gigabyte in size. If you use iStat Menus you can watch the the dips in regular intervalls. Or if you use one of the many apps to test read/write speed to drives, the drobo will have fine peak speeds, but the graphs will show very low dips.

I’ve only had that happen once so far. I’m also running my DroboPro on Win2k8-x64

I had it on a Mac Mini running Leopard Server for a while, but Dashboard on the Mini was unable to download updates. It continues to be a major disappointment for me that I can’t seem to find any solution where the DroboPro “just works”. I have to give up something with every option I try.

So far it looks like the Mac is the better option. Updates are a pain but at least the thing stores data reliably. I may have to switch back to the Mac.

Corndog, my drobopro is connected to my iMac like yours through a switch. I followed your method from the old forums. So since you said you have experienced the same issue once like Sonndorf did, I will be looking out for those issues as well. However, at least I did not experience any problem updating firmware last time on my mac. I did notice that the drobopro is copying data with bursts. Sometimes 7MB/s and with constant bursts up to 70-80MB/s. Is this the “burst” problem everyone is talking about? That’s what I saw when I ran the AJA System Test that tests drive speed.

I have the same problem with those burst during copying, especially large data.

I think I am experiencing similar issues. I am attempting to do a Time Machine backup of 3tb of data and it has been running for over 5 days and is only about 80% complete. From what I understand, iSCSI should be about to handle about 250gb an hour, so a 3tb transfer should take about 12 hours. I spoke with support and they are asking me to set the iSCSI connection to a manual IP rather than DHCP. I am going to test that today and see if it helps.

hugowren - that seems extreme. Even with the issues that I am experiencing, I have just backed up 980 GB of video footage (each file is minimum 1 gig), and that completed in under 9 hours. And that’s with the occasional burst. The machine is connected via iSCSI directly to a macbook pro. Are you using a switch in between or something?

No switch, the Pro is directly attached to a Mac Pro. It’s running 10.5.8 and all of the latest Drobo Pro updates.

Well, it could of course also be down to the fact that the TimeMachine Software is slowing things down - I don’t know the exact way in which it does the magic it does, but it could be a part of the problem. What read/write speeds are you getting from your DroboPro?

Is anyone from Data Robotics following this? Can we have an update on this issue please? It seems to be affecting a lot of people.

I had the same problem when trying to update Drobo Dashboard as a standard user on the Mac. I had to download 1.5.1 from the Support pages, and install it manually. See the thread about requiring Drobo Dashboard when using iSCSI.

Judging by the lack of response from the men and women in charge of this forum, I have given up hoping for a solution soon, and have gone back to firewire 800. That is as stable as it was back when I used the Drobo V2

@Sonndort, did you contact their support team and open a case? I just registered and its clear from the TOS that this is for information sharing, not a way to “officially” open a support case.