Original Drobo Yosemite woes

I have an original Drobo which is becoming increasingly unreliable. When I upgraded to Mavericks, I started having issues where the drive would not mount, and then applications trying to access it would cause multiple numbered drobo folders in /Volumes. Now that I have upgraded to Yosemite, the drive mounts sometimes, other times it takes an extremely long time to mount or does not mount at all, and then the finder and most of my running applications hang and must be force quit. Sometimes the computer must be force restarted.

I’m annoyed that a piece of high end hardware seems to have reached end of life not by mechanically failing but by not keeping up with newer operating systems, but I’m willing to bite the bullet and upgrade the enclosure since I’m now locked into having all my data across these drives.

What I want to know is if I upgrade my enclosure, will I simply be able to move my existing drives into the new Drobo?[hr]
Looking at the Drobo Dashboard, I may have been incorrect about which model Drobo I have. The listed Firmware is 1.4.2 … which makes it a 2nd gen, correct?

When it mounts, the Drobo shows as being healthy and having sufficient capacity.

I am sorry to hear of your issues. My first thought is have you run Disk Utility Verify/Repair on your Drobo, this does not sound like a familiar issue, if you contact support we are happy to review your log files. To address your question, Yes you can migrate from Drobo Gen 2 to newer Drobo - here is our KB link for Migration instructions:
Hope this helps.
Thank You.

I have the same problem. Under Mavericks and previous versions of OS X, the Drobo gen 2 performed perfectly. Now under Yosemite, same machine, same FireWire chain, the drive hangs, and takes down the machine with it.

Disk Utility tells me that the drive, when functioning, has no problems.

I have Drobo Dashboard 2.6.3 installed, and the latest firmware installed in the drive.

The machine can go for only part of a day before the Drobo kills it.

I really have no confidence in the drive, and I really don’t want to spend hundreds of dollars to replace something that worked perfectly last month.

This seems to be a common problem … Are any solutions forthcoming?

Switch to USB. I had issues with my Gen2 stability using Firewire starting with Mountain Lion.

After switching to USB, it has been completely reliable. The speed difference is negligible.

I Too have a GENERATION 1 4 bay drobo, that has worked flawlessly under smow leopard. Now I have upgraded to Yosemite and after initailly not being seen, it appeared on my finder list. All was fine for about 2 weeks, however this morning it disappeard when I clicked on it, and wont come back after a reboot.

I can see it via drobo dashboard (v2.5.4) and the firmware is 1.4.2.

dashboard has no reported issues and the drive is shown as healthy.

This seems to me to be a drobo / Yosemite issue and not hardware related.

The drive contains all my images from 2004, and although i have these images on numerous other (unconected HDD) the idea of the drobo was a single storage location.

I’ve tried switching to a usb connection with no Joy

For what it’s all worth, I was having so many other problems with Yosemite on my machine that I reverted back to Mavericks using Time Machine. Now everything, including the Drobo, is perfectly happy.

I’ve got a 5D, and when I upgraded to Dashboard 2.6.3, I started getting kernel panics and reboots of my Mac after my Drobo was powered up and on. I’m currently working a support case, but we’re still in the form-letter phase of supplying what part number power brick I have…

Today’s email from Drobo support:

“Hello Andy …
Thank you for your update. We can not guarantee this older model will work with the new operating system. We have made necessary updates with our new/current models. We are no longer making any updates to this particular model.
I would recommend to look into migrating your disk pack to either the Drobo Gen3 or the Drobo 5D.”

How about no? How about not deprecating perfectly good hardware because you’re too lazy to update your drivers to support the latest operating systems? It’s not like Developer Previews of Yosemite haven’t been available for months.

So instead of migrating to a new Drobo, I’m looking at other suppliers. If Drobo is unwilling to support its customers, its customers have no obligation to support Drobo.

My 1998 Dell Inspiron also still runs fine. I should be mad at MS that it won’t run Win8?

Drobo posted a EOL notice for the Gen1 and FS years ago.

hi i’d be very much interested in knowning what possible options a hardware company has, in terms of asking microsoft / apple etc, what codebase / protocol / driver is allowing their product to currently work, and what can be done to better ensure that it will always have that codebase / driver available for future operating systems?

surely there must be a benefit to have this, such as a compatibility mode/module for future compatibility?

but do companies do this?
is there a process for this?
does the operating system provider ask for too much money and hence not sustainable?
does it take too much hard drive space for the overall o/s etc and apple refuses?

i think its either overlooked, or it has a simple answer, or its more convoluted than that and they cant disclose it?
im curious now :slight_smile:

(apart from the general idea relating to the above posts, it also came to me when thinking about new website designs that no longer support older browsers… eg if your code already works in browser version x, why stop it from seeing the website when a new browser version is released? the code already works in that version :slight_smile:

Im having the same issues with my recent upgrades to Yosemite on my Mac and have the firmware 1.4.2. I have a Gen 2 Drobo which has been great backup hardware for me and working for years. I can see my Drobo in Dashboard but will just not mount. Previously while upgrading to 10.10.3 I had to use the Disk Utility and do a disk repair which was successful and I have been doing regular Time Machine backups. For 2 weeks now after shutting down and restarting, Drobo just won’t mount. I’m going to try the USB route as mgriffin34 has suggested and see what comes of it. Fingers crossed
I tried the USB route and still no luck so I’ve tried the disk utility route again and got an error saying the disk utility cannot repair disk! I’m trying the repair one more time. I just don’t get why the Dashboard says my Drobo is healthy and Mac won’t recognize?

hi, we had a mac issue that a user posted recently, where they had to use another tool as disk utility wasnt able to fix, over at this thread:

its good to have a look for info purposes, but before you try anything could you try to power all down, and then to try another (different usb cable / and or port, just in case its the cable or port?) it might not be but if you have one to hand, we had another case where the cable was at fault too.

Hello Paul and thanks for the help. I’ve tried different ports, cords etc. It looks like I may have to give Disk Warrior a try. Do you have to boot from DW?

Hi eaphotos1,

I have just quickly took a look at your issue, and it might be able to resolve and get access back to your data. This is going to be a long post … with details to what you are seeing and the steps to be taken.

*By the way, I’m the guy responded to the thread that Paul posted. Is going to be similar to that thread …

  1. In OSX, Drobo Volume having issue mounting. Resulting multiple “volume” mount points namely with numbers … such as Drobo-1 Drobo-2 etc… under /Volumes

*This issue is fairly common in Linux or OSX. Is called duplicated mount points.

Every partition(s) needed to be mounted on a mount point for its data to be accessible in OSX. Mount point in the background are simply “folder” sort of… In OSX mount point in general will take the name of the volume. When a partition is mounted to a mount point… that “folder” is now containing all the data.

When you eject or unmount a partition/volume from OSX, OSX suppose to clean up the mount point by removing it from /Volumes. But for some cases, it failed to do so. Leaving the mount point in the /Volumes.

So Let say… the orphan mount point left over is /Volume/Drobo
The next time Drobo boots up again, OSX will attempt to mount the Drobo Volume under /Volumes/Drobo BUT there’s the problem… there’s already a /Volumes/Drobo in there. What OSX did now is to mount this Drobo volume under a new mount point … /Volumes/Drobo-1 etc…

The key point is ONE mount point can only be mounted to one partition.

That’s the background info…

Now back to your issue:

  1. We are going to clean up all the orphan mount point(s) … so that OSX will be able to mount the Drobo again under the “correct” naming…

  2. Power OFF the Drobo … if you have multiple Drobos …power them OFF all of them. This is to prevent us from accidentally deleting a mount point that is valid and mounting to a Drobo volume. We don’t want to accidentally delete that mount point and its data.

  3. Once ALL Drobo is powered OFF… (just in case… :stuck_out_tongue: unplug all the cables connecting the Drobo to the Mac … USB, FW or TB)

  • Open OSX Finder, under the menu of the Finder. Click Go > Go to Folder … and enter /Volumes
  1. Finder should display all the “devices” or “Volumes” there… can you see any Drobo, Drobo-1, Drobo-2 etc… something similar to this…
  • Now using Finder, go into EACH of these Drobo naming folder… and make sure …double sure that they are indeed EMPTY… no data in them…

  • Delete every one of them … using the Finder. OSX may prompt you to enter your OSX password… to authenticate. As you are doing a so call “Admin Privilege” action.

  1. Once you have delete all of them, reboot the Mac… and go back to /Volumes again and check if they come back :stuck_out_tongue: I suppose not. Just check.

  2. Once all this is done… is time to get the Drobo unit power up … and connect it to the Mac.

  3. Can the Drobo be mounted now… on both Desktop and Finder…? If yes… and can access all the data. Problem solved!

  4. If not… don’t panic…

  5. Is all the Drives in the Drobo GREEN light? Yes, meaning the Disk Pack is ok.

  6. Now let’s check the Capacity Blue Lights… You should have some Blue Lights … each blue light indicating 10% used disk space in the Disk Pack. If you seeing some blue lights… GOOD! Meaning there is used space and data likely to be intact. Just that OSX not amount to mount it.

  7. If the Drobo Dashboard can detect the Drobo, open it up… under Volumes. You should be seeing the Drobo Volume(s) listed there. Are they listed as filesystem HFS+? Unknown or RAW?

  • If the Dashboard is showing the Drobo volume filesystem as HFS+… but Finder is not able to mount it. This means there is a minor issue with the Partition Table and it needs to be repair.

  • Both “Unknown” or “RAW” … means it suffers a little more corruption that there is no recognise filesystem.

  1. Final check… before we get into DiskWarrior. Open OSX Disk Utility …
  • In Disk Utility, you should see a Drobo Device (Parent). Under it… you should see a “grey” out Drobo Partition which is your Drobo Volume. Seeing this is also good news… Meaning the Drobo Volume (Partition) is recognised by OSX. Just won’t mount due to partition table or filesystem corruption.
  1. Get yourself a copy of DiskWarrior…
  • A note here… DiskWarrior is a good OSX repair tools but is not GOD. But the success rate is high.
  1. Since you are repairing a NON-SYSTEM Disk or Volume. You do not need to boot from DiskWarrior Boot USB or DVD. Simply install DiskWarrior into your Mac… and run the the DiskWarrior app like any other OSX app. Point it to your Drobo device and its volume to repair…

Reference thread:

Good luck…
Let me know if

a) You are not able to clean up the various Drobo-1, Drobo-2 orphan mount points using the OSX Finder. I have other method to delete them but it involves using Terminal and Commandline … not sure if you are comfortable with it.

  1. Finder should display all the “devices” or “Volumes” there… can you see any Drobo, Drobo-1, Drobo-2 etc… something similar to this…

After I do this…I don’t see my Drobo in any of the volumes when powered down. What should I do next?

I ponied up for Disk Warrior and it solved the problem! Disk is now mounting and Time Machine is operational and backing up. Thanks!

thats cool news. thanks don and well done eaphotos