One partition not mounting (Drobo 2G, Mac)

I have a Drobo 2G with two partitions. One of the partitions fails to mount while the other works fine. Any ideas why?

Here are the details:
[]Drobo 2G, connected with FW800 through another drive (that is of for the moment) via a Thunderbolt adapter (I just saw now while browsing Drobo’s forums that this isn’t recommended, but it has worked pretty ok for the last year)
]Mac OS X El Capitan
[]The Drobo contains 4 x 2TB drives, split in two 4 TB partitions. One contains about 3 TB of data (the Time Machine disk that is now unresponsive), the other less than 1 TB. Usage is around 75%.
]The Drobo shows four green lights and seven blue
[]In Drobo Dashboard, everything is supposedly healthy and working, except that the partition that cannot mount is not listed with its usual name but as “Drobo”, and the volumes list doesn’t show how much data it contains
]Disk Utility is stuck at “reading drives”
[*]In Activity monitor, I can see “fsck_hfs” taking about 1% of processor time
So, reading Drobo Support, I came across a mention that these symptoms might indicate that the file system is being repaired. ( How long do you think this process might take? Minutes, hours, days? Are there any other options than let it run for as long as it needs and hope for the best?

Update: As I wrote this note, the Drobo decided that it wanted to go to sleep and the other partition also stopped responding. My Drobo does that from time to time when it’s been idle for a long time (maybe because of the Thunderbolt adapter?). fsck_hfs then dropped to 0% (after 5-6 hours of processor time) and after unmounting the second partition (by pulling the cable, when nothing else worked), Disk Utility woke up immediately.

Any advice on how to proceed? Should I wait it out, do something else or just format the Drobo and start over? Can I do that without erasing the second partition?

hi jonasg, if your file system checks are still in progress, i would try to wait it out if you can.
if it stops, or your drobo ends up going into standby mode, you could try powering off, and then simply removing firewire and connecting directly via usb straight to the computer, and then powering on again.

does fsck continue, if so, hopefully it will remain on in that way while it can continue (though you might need to disable the computer from going into its own sleep modes.)

if (or when) there is no more fsck taking place, if you could then try disk utility again, (this time being on a direct usb connection) does it get any further?

Thanks for the reply Paul! Yeah, I’ll switch to USB and see if it behaves better, and try to wait it out for now. But I probably won’t do that for a week, as I’m about to go away on vacation for a bit. I’ll get back to you later if I have any updates.

ok no worries, will be here when you get back
(assuming i dont get hit by yet another car) :slight_smile: