Notes and first impressions on the Drobo 5N

First off, they’re shipping. I have a tracking number showing mine will be arriving tomorrow. I’ll have some initial impressions then.

Migrated disk packs only operate at 75% of full performance (likely due to the FS using EXT3, whereas a new 5N disk pack uses EXT4). No word on whether it’s possible to copy everything off the Drobo and then reformat the disk pack from scratch as EXT4.

mSATA accelerator options are limited. Although Drobo lists four models, the OCZ is a Drobo exclusive and massively overpriced, and the Intel is similarly overpriced given the measly 40GB capacity. The Crucial drive (which has been the most oft-mentioned one in these forums) is out of stock in the 64GB capacity - for the rest of the quarter (I spoke with Crucial today - they’re not manufacturing any more this quarter). So the options are an SSD that’s a bit small and carries a bit of a per-GB price premium due to being the smallest offered, an SSD that’s too large for the Drobo to make use of, or one that’s more expensive than the (unavailable) competition. I chose to save a little money and get the Crucial 32GB.

There are already firmware release notes for the 5N. First one on the list - “DroboApps currently available on Drobo FS are not supported on the Drobo 5N”. Obvious, expected, but still disappointing. A couple issues around scenarios with different MTU’s, spindown not working for long intervals (if you know that already, then disable those options in the Dashboard for the 5N!), and a Time Machine issue that I just can’t parse.

That’s my report for the day. :slight_smile:

And now I’ll also be able to post notes on the Synology DS1512+, as that arrives on Tuesday. We’ll see who stays after a month and who goes home.

Hope to hear some good and informative comments on these soon…Thanx!

First impressions:
[list][]Drobo unboxing experience is second only to Apple.
]Initial boot (no drives) took quite a while, with a long “initializing” status shown in the Dashboard. Mysterious, but at least the Dashboard told me it was doing something. Since the blinking light pattern was very unfamiliar, I was glad to have the info.
[]Once drives were populated (while the unit was shut down, of course), the Drobo 5N came up with the old FS disk pack with nary a complaint.
]Drobo Dashboard is a lot more detailed with its info. It may not have SMART and SNMP data, but it shows individual drive details, serials, health, and just a lot more good information. Much happier with that experience.[/list]

Detailed performance tests will have to wait a bit (still need to get data merged, backed up, and let the thing settle) - and recall that the FS disk pack will incur a performance penalty of its own - but…
[list][]For a quick copy of a few GB to the 5N, I was seeing typically between 50-70MB/sec, maxing out at 78.6MB/sec, or up to 630Mbps write performance. That surpasses best read performance I could get out of the FS. While there’s quite a bit of headroom yet, there’s no doubt this is a different beast than the FS performance-wise. Note that this means folks who are still using USB 2.0 hard drives (as I am on some machines) will now see the USB bus as the bottleneck, not the Drobo.
]That proceeded merrily along for 7.75GB, and hit a wall. This is probably “new unit housekeeping”, but the drives started churning like mad and the copy stopped dead with 4GB remaining. After several minutes it finally resumed at the previous speed.
[*]Deleting a folder with a dozen files still sat there thinking about it for at least half a minute, so netatalkd still has it’s interminable issues.[/list]

Maybe it’s an artifact of the FS diskpack; I’ll know once everything is backed up, reformatted, and rebuilt on a proper 5N disk pack with an mSATA accelerator next week. And then we can test the 5N head-to-head with the 1512+.


[quote]jochs@lightning ~ $ ssh drobo
jochs@drobo’s password:
$ pwd
$ [/quote]


If the “backdoor” for DroboApps is you just have to set up the share and all that yourself, that’s the “nudge, nudge, wink, wink” method of doing it I was asking for. So far at least a few packages work straight up - notably OpenSSH and nano. Bash would not load due to an ncurses library issue - but the fact that anything is loading at all… well, consider me damned happy. :slight_smile:

EDIT: It appears that the install script has the path to “DroboFS” hard-coded. It’s likely then that this will only function for migrated FS diskpacks. I’m discussing this with Drobo Product Development. If this vanishes in the first firmware update I’ll be most displeased.

EDIT 2: After discussing the matter with Drobo Inc, DroboApps support will continue to work on an FS disk pack such as mine - it’s not accidental, and won’t be pulled back. However, there is no method to enable the functionality on a new disk pack, so new 5N users will have to wait for official support to roll out at a later date.

Thanks diamondsw for those very interesting “first impressions”.
What about the fan noise, especially when the Drobo is idle and the disks supposedly sleepy ?
And what about the power consumption under the same conditions ?
I have a Drobo v2 in my living room, and have never upgraded because of greater noise specs with all the new models.

I can’t judge idle noise levels as the drives have been busy ever since I hooked it up, whether doing it’s own housekeeping or me running backups. I’m likewise curious as to how it sounds with the drives spun down. I’m fairly certain the new fan is quieter than the old one, and seems to be keeping the drives cool enough despite my constant use (the only warm one is my lone 7200rpm Samsung). I don’t have any numbers for power usage either before or after, although I wouldn’t expect it to be too different - the drives are going to consume more power than anything else.

This is wonderful and what i was looking for.

I am still on the fence as to what i should do

Upgrade my FS to a 5N or go with the Synology DS1512+

I will be waiting for your reviews…Thanks for the update so far

Although I’m still waiting on the Synology to arrive (should be tomorrow), I can say that the speed has continued to impress. One oddity though - the drives still have never spun down. While the fan is keeping them cool, it’s a tad annoying. I may reboot the unit just to see if I can’t get it to spin down that way.

EDIT: After several days of work, the Drobo 5N spun down last night and has remained idle. Unit is damned near silent - I can’t hear it at all when the drives are idle. No more fan swpas!

thanks for the reports diamondsw, this made me finally bite the bullet and order one.

i managed to find a Crucial m4 mSATA on eBay for $81 (64GB, brand new, seller with good rating) and i am on the process of cleaning up some space from my FS so i can slowly but steadily format and move the drives to the 5N (should be here by this weekend), this is going to take a while :V (3x 3tb + 2x 2tb, about 7TB used atm)

whenever i finish with this torture i’ll throw in some reports as well, i guess i’ll throw my FS into eBay after i’m done with this.

The Synology DS1512+ has arrived; I’m just finishing up a backup of the Drobo 5N before trying it out. I’m also going to try to tweak the install script to make absolutely sure it will still load my apps from a “5N” diskpack.

The physical design of the Synology is quite interesting. It’s not as elegant as the Drobo (I don’t miss drive caddies one bit), but it sure has the ports and features. Half a dozen USB ports to direct connect hard drives (would make backup a LOT easier), 2 eSATA ports for expansion, and 2 Ethernet ports for link aggregation and better speed. And no worrying about apps. Ever. At the same time, the 5N is simple, quiet, and the SSD cache is still very intriguing.

Sorry to disappoint, but I won’t be able to post Synology experiences. I’ve decided to keep the 5N and return the Synology. Several reasons:
[list=1][]The performance of the Drobo 5N has been excellent, and has never been the bottleneck. Any additional performance from the Synology ends up purely theoretical.
]The SSD accelerator for the Drobo 5N should help with I/O contention, which is a common issue I face. Synology doesn’t have anything similar.
[]I already have a Mac Mini as a 24x7 server, so the numerous features on the Synology for this (web server, file downloads, media streaming) just don’t apply to me. Others will love those features; they just aren’t for me.
]I have no interest in anything other than a flexible and expandable RAID, so all of the non-SHR RAID options are kind of moot.
[]With DroboApps confirmed to work on my unit (and improved support coming later in the year) the Synology loses its edge there.
]If I were to “borrow” the disks from the 5N to use in the Synology, when I put them back in the 5N I’d have to format them as a new diskpack - and then I won’t be able to re-enable apps.[/list]
The Synology is a very interesting product, and a lot of people will find a lot of value in it. It just happens that it doesn’t overlap with my usage scenario that well, but the Drobo does.

Hi, I am a little confused on this point, or it this is conjecture?
If I understand it right from the OP, DRI doesn’t claim support for DroboAPps on the 5N.
Then you migrated your DroboFS diskpack into the 5N and found that they appear to work.

Do we know for certain that the 5N formatted drives won’t allow DroboApps?

Thank you. I have found this thread interesting and appreciate your review, so far.

Afraid so, I confirmed it with Drobo Product Development. There is no way to create or mount the DroboApps share on a 5N diskpack. No share, no way to load apps. An FS diskpack with it already enabled neatly sidesteps that issue.

ok, So, If i purchase the 5N, can you at least do a write up on how you think we should install it.

I am not catching on with this 5N/FS disk pack stuff. so,if you dont mind, can you at least tell us what we need to do with our FS and 5N

Is it just simply taking the drives out and putting them in the 5N or what…THanks for your time. I was just about to get the Synology box, but i might as well get the 5N as you say the speeds are there and that is all i really care about.

I too have a mac mini as a server so no need for the rest

If you can get it posted, i can order my 5N tomorrow

Thanks again for your great post

Also, i was getting ready to buy some bigger drives…If i do, should i put them in the FS first, let it build its stuff and then take it to the 5N or what

As long as you have enabled DroboApps on the FS first (it’s an option in the Dashboard), then all you have to do is put the diskpack in the 5N - the functionality will remain enabled. You can then continue to remove and add drives as needed, as long as you don’t lose the whole disk pack (due to multiple simultaneous drive failure or similar). As long as you replace drives one-by-one and keep your data intact, you could in theory replace every drive and still be the same disk pack (and thus keep DroboApps).

From the sounds of it, we’ll get official support (and apps) later on and this whole issue will be moot.

well, my 5N is here and so is the Crucial m4 SSD, i am still ~extracting~ the data from it so i can install all my drives as fresh ones so i guess i can throw some benchmarks on that since i personally don’t care about DroboApps since i too have a MacMini working as a 24/7 server anyways.

i should be done migrating everything around this Saturday, i was getting around 25’ish MB/s on my FS, i moved the drives to the 5N and i am getting around 35MB/s or so at the moment (simple cut and paste into external drives).

here’s a few screenshots of the 5N with all my drives and the disk reporting:

disk info:

NOTE: it currently has my FS pack and i too can confirm that the couple of apps i had installed on it were still there (not that i care really :P)

I found it hard to get good throughput numbers for the 5N, just because I kept running into bottlenecks elsewhere (Mac Mini hard drive, ~60MBps. USB 2.0 HDD, ~30MBps. Wireless network, ~20MBps). I’d think the Drobo 5N was running at FS speeds and realize something else was bottlenecking, not the Drobo.

Also, mine took a few days to “settle” and spin down, so there may be housekeeping and layout activities going on for a bit.

Very interesting. Thank you for clarifying.

yeah, i was going to bed and i figured i’d test something out after a while, as you mention there clearly was some sort of housekeeping going on since the first time i tried moving something into my desktop i got around 33MB/s, i just tried again and i got 61MB/s.

then i decided to try and move data into 2x different externals in 2x different computers, one is getting 33MB/s and the other one about 25MB/s while transferring at the same time, i guess i’ll finish clearing this stuff a bit sooner than i expected :slight_smile:

also, i noticed via the Drobo Dashboard that the mSATA drive i got has the ~bad~ firmware (aka: it will basically kill itself after X amount of hours (i cant remember how many specifically, but its an issue all m4’s had)) so i ordered a mSATA to SATA adapter so i can update it.

Thanks for the reminder to check the mSATA firmware - I’d forgotten about that issue with Crucial drives (and have one arriving tomorrow).

I wonder if I can update the firmware on the Crucial SSD from the Drobo 5N itself, seeing as I can SSH into it? Probably not, but I have to try. :slight_smile: