Drobo

Not the smartest thing I've ever done.

Hello All,
I was having problems with a single drive. Red blinking light telling me to replace. Instead of doing the smart thing and replacing, I decided to see if this could be repaired.

  • I ran SeaTools and SpinRite on the bad drive. Everything came back as passing so I put this back in the Drobo.
  • Still showed the blinking red light, I changed positions of the drive thinking it may be a backplane issue. The blinking red followed the drive so it was a drive issue.
  • I decided to give the repair route one more try. I upgraded the firmware on the drive and wrote zeros. I got ~60% through (hours of time) and thought this would be enough to try putting the drive back in the Drobo.

My having changed the drive positions… I zeroed the wrong drive (There’s no emoticon for what I’m feeling).
I now have “Bad”, “Mostly Formatted”, “Good”, and “Good”.

I bought new drives (yes, should have been step one) and tried (without luck):

  • dd’ing from “Bad” to “New”. “New” now shows as bad as well.
  • Moving the HD drive circuit board from a new drive to bad then a new drive to “New”.
    Is there anything that can be done besides a good cry, format, and start over.

I believe now the issue isn’t the bad drive as in Hardware Issues, but Drobo sees the “New” as having orphaned files/ corrupt filesystem.
Any way to force a drive to be seen as good so I can at least attempt to run some HFS+ tools on this.

I realize there may be files that were written after the drive was reported as bad, but it wouldn’t be many.

I opened a ticket (online form), and got a call telling me there was nothing that could be done.
This is fine, but I feel like it was a tier one trying to close the case instead of offering options that - while might cost some $$$ or be technically advanced - at least be an option.

Yes I do have backups of the family photos, but I didn’t back up TBs of data that was not as vital - but would still be nice to have.

Regards.

i you have managed to clone the “bad” drive onto your “new” drive - then the only reason it isnt working is because you have also managed to copy the “bad” flag that drobo sets (dont even ask about removing this).

however that means you now have good, good, and New-but-flagged-bad.

which is 3 out of your set of 4

if you get on the phone to drobo support - get them to send you the read-only firmware for drobo.

it will basically let you READ from all the drives - it will even accept drives flagged as bad, but still functioning.

it is intended for data recovery only. so it will let you get your critical files off (make sure you have somewhere else to put them)

let us know how you get on / what support say[hr]
The read-only firmware was developed (i think) as a result of the seagate 1.5tb drive fiasco

the drives kept on freezing - for over 30 seconds. so drobo would flag them as bad, and remove them from the disk pack

but in fact it was just a firmware issue making the drives take a LONG time to respond, once they started responding they would carry on as normal.

so DRI develeoped a firmware which would accept all of these functional but flagged drives - back into the disk pack, in order to recover the data from them.

which , to me, sounds perfect for getting data back using your fully functional clone of your bad drive.

get hold of tier 3 and see what they say!

Thank you very much for the information. Your suggestion gave me the first hope I’ve felt in over a week.
I decided to update the ticket with the request for the firmware. I’ll call them depending on their answer.

I’ll post back here with the results.

Thanks again.

best of luck!

@trinroth, I feel your pain. I have lost data due to drive failure, and viruses. I have lost more due to my own “user errors”.

I haven’t had time to try this yet, but thought I would post information regarding the read-only firmware. No actual firmware install is needed to do this.
This info may already be in other posts, but I hadn’t thought to search for this thinking it was an actual software install:

  1. Please standby your Drobo and disconnect the data then power cable
  2. Please eject all 4 drives out of the Drobo at least 2"
  3. Connect the data then power back to the Drobo
  4. Once the Drobo is seen by the Drobo Dashboard
  5. CTRL-ALT-SHIFT-R toggles between set/unset of read-only mode.
  6. Once the settings are changed, Dashboard will prompt for reboot of
    the unit, please do so
  7. Once the unit is back up from the reboot please standby your Drobo
    and disconnect the data then power cable
  8. Please firmly insert all 4 drives
  9. Connect the data then power back to the Drobo
  10. If the Drobo mounts please copy any and all data you can recover off
    the Drobo

I hope this isn’t something I’m supposed to keep secret. It seems like something that would be good to know in the event of a failure.

wow, i did not know that - this could be incredibly useful to know!

Damn, this could have saved my data last time I bricked it :stuck_out_tongue:

I would like to add a few comments in regards to this. The Read Only mode is used in specific situations such as improper shutdowns, frequent power outages, or multiple drive failure which can cause Drobo to become unstable and enter a reboot loop. The Read Only command attempts to stabilize Drobo long enough to allow you to get your data off of Drobo if you don’t have a recent backup of your data. We strongly recommend you contact tech support to see if your scenario applies as there are some prerequisites in order for you to use this feature. If you have any questions or concerns please contact support.

trirnoth - did it work, did you recover anything?

Admittedly, I’ve been focused more on restoring what backups I have, recovering data from desktop/ laptop drives that I had moved to the Drobo, recovering data from my camera SDs using PhotoRec (http://www.cgsecurity.org/wiki/PhotoRec), … all this because I’m in somewhat of a denial and don’t want to know for certain the fate of my data. Plus I wanted to make sure I could get all I can before having to use/ overwrite these devices.

I was only able to get the Read-only firmware to work once. The one time it did, it still showed the one drive as bad and the Drobo Dashboard showed “Too many drives removed”. Step 6, where the Drobo requests a reboot, did not happen during any other attempt.
Downside to the CTRL-ALT-SHIFT-R in Step 5 is that it is the same message “Read-only state updated successfully.” whether one is turning this on or off. Would be nice if it stated “Read-only state updated to ON.” or “Read-only state updated to OFF.”

I am saving the original Drobo drives for a day where I can devote a lot of time and maybe have access to a second Drobo to test the Read-only firmware.
I am under the impression that the drive isn’t really bad in the hardware sense, just out of whack in the filesystem. Thinking this is proved by the DD’d copy to a good new drive still shows up as bad.
In the meantime I bought 2x2TB Hitachi drives to hold my content until I get this all sorted out (good or bad).

I did update my ticket with Drobo requesting any other methods, including sending the drives to them. I haven’t heard back, but have a feeling the costs would be beyond my pay scale.

Thanks for asking, I’ll definitely update this if anything works out.

[quote=“trirnoth, post:11, topic:1414”]
I am under the impression that the drive isn’t really bad in the hardware sense, just out of whack in the filesystem. Thinking this is proved by the DD’d copy to a good new drive still shows up as bad.[/quote]
Actually I’m not sure on that…
Drobo does keep track of which drives it has marked bad.

Whether Drobo writes something “special” to the drive (which would be cloned to a new drive), or if it just looks at the serial number (which shouldn’t be cloned to a new drive), I’m not sure…

Drobo only looks at serial numbers of drives when flagging them as bad. It does not write anything to a bad drive.

This being the case, is there any way to erase a “bad” flag? Or is this what the Read-only firmware was supposed to do.
As stated in my original post,
I ran SeaTools and SpinRite on the bad drive. Everything came back as passing so I put this back in the Drobo.
I bought new drive and DD’d the contents from bad to new.

Neither produced results and both showed as bad. Would be nice, even if temporary, to get this seen as good to transfer the data.

There ya go… It uses serial number, which shouldn’t change (unless you do some physical cloning or have some super-awesome tool).

I believe some customers have had good results (posted on here) by putting that drive in the drobo and doing a PIN reset of the drobo with that drive in it and only that drive.

Thanks all for the responses.

I was under the impression that a “PIN reset of the Drobo with that drive in it and only that drive” will completely format that drive.
If this is the case, my situation of having: “Bad”, “Mostly Formatted”, “Good”, and “Good” OR “New From dd of Bad”, “Mostly Formatted”, “Good”, and “Good” is something I am a little leery to try - even though my data is probably gone anyway.
Friends tell me to format, shed a tear, move on - but I’m just not ready for that yet.

i think jennifer was meaning solely how to unflag a drive as bad - as far as i am aware this would ALSO wipe it.

but i am happy to be corrected if i am wrong, jennifer?

That is correct.

I thought you said you had realized you needed to restore from backup and wanted to be able to use that drive because you feel the drive was not bad. Did I misread that?

If so, I apologize.

Sorry for the confusion.
I’m currently using my Drobo with 2 new 2TB drives restoring as much as I can on to these.
Someday I’ll admit failure and format my 1.5 TB drives which are currently sitting and doing nothing.
A part of me was hoping the Pin Reset would unflag but not format.