No XP-Comatible Formatting?

Need to reformat my Drobo S. Running the latest firmware and Dashboard. When I try to format it, it only gives me the option for Win 7 compatible NFTS. I need the older XP compatible format, so I can use it on a Win XP machine AND a Win 7 machine for backups. Of course, it won’t be plugged into both machines at the same time.

What happened to the other options (XP compatible NTFS and FAT 32) on the formatting page?

Windows XP and FAT32 are each limited to 2TB disks. Did you partition larger than 2TB volumes?

Yes, It was formatted larger for GPT. But, I want to start over an have 2 volumes as XP compatible, each being a max of 2TB.

Your problem isn’t the partition sizes, but the “virtual drives” that Drobo presents.
To remove all data and have 2TB partitions, use Drobo Dashboard to remove the existing volumes, and then to add new ones.

After looking at the documentation, I had tried to do that earlier, but don’t have the option.

According to the documentation (, when you are looking at the volumes, there should be a “Remove Volume” button. Its not there. When I click on the volume, the only button at the bottom of the page is “Rename Volume”. In fact, the screen I get doesn’t even match the one in the referenced document. That screenshot shows “Mount” and “CHAP” columns, but mine only has ID, Volume Name, File System, Used, and Max Capacity. I even went to Tools -> Check for Updates and confirmed that I have the latest versions of of Dashboard and Firmware.

Maybe this is something particular to the Drobo S?

The Drobo S doesn’t support Smart Volumes like the DroboPro and now business-class Drobos do.

The referenced document sounds like it’s for an iSCSI mount or something completely different than what we’re dealing with. :slight_smile:

You need to RESET your Drobo, which will delete all your data on it, then it will ask you what volume size you want to use for Thin Provisioning. Any NTFS option larger than 2TB will end up as a GPT volume, which Windows XP does not support.

Thanks for the reply, but I tried a reset, and it still did not give me any formatting option other than the GPT NTFS. BTW, I’m using an eSata connection.

As for the documentation, that is the one that was presented to me when looking up docs for the Drobo S.

After a LOT of trial and error, I finally got this issue resolved, although in a very bizarre way:
o Connect the unit to an XP machine via USB
o Load the original version of the Dashboard from the install CD (I know you’re not supposed to use an old version of Dashboard with the latest firmware, but it was worth a try) Could not find a way to go back on the firmware level
o Reset the unit and was able to allocate the XP-compatible volumes from the old Dashboard, which gave me all 3 formatting options
o Reconnect unit to the Win 7 Ultimate 64-bit box via eSata
o All 5 bays turned red, and latest version of Dashboard on this box said there was only one drive installed and it was bad
o Shut everything down and rearranged the drives in the unit so that no drive was in its previous position
o Start everything up again, and magically, there were 5 green lights and the Dashboard showed the 3 volumes I had allocated on the XP box
o Perform a backup of a small non-critical drive in my system to volume 1 in the Drobo, restore to a separate drive, compare the two drives, and everything matched
o Repeat backup/restore process using volume 2 in the Drobo

I’m fairly certain that’s all the steps I performed, as this process took a few hours and I was at my wits end trying to get this to work.

After all that, when I go back to Dashboard, it STILL does not offer me any formatting option other than the GPT NTFS. I don’t understand why the folks at DR took the other two options away from us.

Maybe Drobo Dashboard detects Win7 and doesn’t offer backwards-compatible partitioning options?
I’m curious what you see with the latest version of Dashboard on your WinXP computer.

That could be, although it should always give you the 3 options and not assume anything. In fact, I do plan on using this unit to also backup a 32-bit XP Pro machine.

Now you’ve got me curious also. Might be a day or two before I can test again, but I will hook it back up to that test XP machine, load the new dashboard and see what it says.

Thanks again for all the replies

hi i have a drobo s as well, and also needed xp and win7 to use it, so when i first got mine i set it up from the start at 2TB max volumes and ntfs. (at the time it gave me an option to choose xp compatible 2TB partitions, which was perfect for me)

i dont know if anything has changed with newer versions, but i really sure hope that we always have that choice of 2tb compatible volumes…

(just to clarify… i set it up initially on the win7)

Just ran a test by plugging the Drobo S into a Win XP Pro (32-bit) machine and loaded the recommended version of Dashboard (2.4.3) for this unit. Went to the Format page, and it only gives me the GPT NTFS option, which has to be a bug, since XP would not even recognize that format!!!

Can you post a screenshot of the window(s) you see?
Alt-PrtScn will get the active window.

Ok, will do. I’ll hook it back up tot he XP box tonight.

Go ahead and use the Win7 NTFS format option, just set the volume size to 2TB. It will format as GPT, but it still has an MBR so XP should be able to mount it.

Already tried that early on in this process. It was unrecognizable to XP, which can’t handle GPT formatted volumes.

Why was the option to choose from 3 different formats taken away in the newer versions of Dashboard?

I partitioned another volume on my DroboPro. DashBoard said it would be compatible with Server 2003, Vista, or Win7 (no mention of XP), but a 2TB volume was MBR and it worked fine.
I realize DroboPro and DroboS are different products, but maybe this is a useful data point.
WinXP, latest DashBoard 2.4.3, latest DroboPro firmware 1.2.2.

The MBR partition on a GPT volume is a “protection” partition - put simply, it exists only to make sure Windows doesn’t prompt you to format the drive, as it does when it does not recognize any partition table.

As rdo says, I think/hope what might have happened is that the partitioning part has been abstracted away from the volume size.

Technically the formatting is NTFS either way, so instead of presenting two separate NTFS options, you simply have NTFS, and the volume size you choose determines whether it’ll be MBR (<= 2 TB) or GPT (> 2TB).

Windows may be smart enough to automatically choose MBR for <= 2TB volumes. I just got a spare drive so I’ll try to check this over the weekend.

Below is the download link to the last version of Dashboard that will give you the XP compatible formatting option. I verified it works with firmware 2.1.5 and creates an MBR partition.

Thanks Sky! I do have that XP-compatible option again. However, and its no big deal for me anyway, the FAT32 option is still missing.

Any idea why these options were dropped in later versions of dashboard? No doubt, someone had a reason for this, but it just doesn’t make sense to take away that functionality.

For the curious, Windows 7 prompted me whether I wanted MBR or GPT at the Initialize this disk prompt… So it doesn’t seem to automatically choose.

I’d guess FAT32 was just a support headache as many people don’t know that FAT32 doesn’t support files >4 GB, and by the time they realize that, they’ve probably put a nontrivial amount of data on the unit.

Maybe FAT32, NTFS (MBR) and ext3(?) could live behind an “Advanced options” or something.