No more DroboApps downloads

Thank you so much, Dom for sharing the files!!

  • I put the myDrobo.tgz in \DroboApps\ and rebooted 5N2 and didn’t kick-in the installation.
  • I tried the manual installation, it keep trying for about 15mins and failed to install the application message came up.
  • I unzip the file and put into the \DroboApps\ and rebooted again. It’s showing not that the application installed but didn’t start. I clicked on myDrobo ‘wheet’ icon to configure it. There were two options ‘Create account’ and ‘Transfer account’. I tried to create a new account and got this error message.

myDrobo DroboApp

myDrobo account creation failed.
Please try again later.
Error code: 127

  • Then I tried the transfer account but again the same error code: 127
    myDrobo DroboApp

myDrobo account transfer failed.
Please try again later.
Error code: 127

  • Before trying to myDrobo I already uninstalled the DroboAccess and DroboPix and rebooted.

  • I also switched between the two Firmware 4.2.2 and 4.3.1 but same results.

  • I’ve other apps also installed and checked the hidden file in \DroboApps.servicerc the following showing.


I also tried to factory reset the Drobo 5N2 from the ‘Tools’ and tried to reset through PinHole but didn’t work. I’ve a backup and everything is working including Storage, DLNA, Plex etc and can reset again if that may fix the issues.

I’m using 5 Seagate NAS HDD’s of capacity 2x12TB, 2x14TB, 1x18TB and 1TB mSATA SSD for transfer acceleration.

Drobo Dashboard version is 3.5.0 on Windows10.

I would appreciate any suggestions and thank you so much for your help!!

Best Regards,

Finally MyDrobo App started, it requires Apache and Python2 to be installed.

These applications DroboAccess, DroboPix, Konken, and Wordpress has dependency on myDrobo…

Stay tunes, I think I’m on roll post you provided the DroboApps Dom!!!

Best Regards,

Glad you got it working!

TBH, I don’t trust myDrobo/DroboAccess to keep running for much longer, so I set up a DDN service by other means to access my files remotely.

DroboPix is still kinda useful. I like the one-touch backup of all my photos to my NAS. But the mobile app hasn’t been updated in forever and will probably stop working with a future Android/iOS upgrade. Already the location-based auto-backup stopped working a while ago on Android.

Anywho, if there’s any way I can help out, let me know.



I agree with you that there wouldn’t be any future upgrades and we need to lookout for some other options. Could you please share some details about ‘DDN Service’ you mentioned above. Is it on the Drobo Box or or Nvidia Shield or any PC?

I personally luv Drobo as I never had any issues before until I ran into some issues with Plex upgrade and had to factory reset and then realized that Drobo has stopped the support as on Jan 23rd, 2023. Any recommendations what is next best NAS in the market with some Private Cloud Storage features.

Best Regards,

So, a DDNS, or Dynamic DNS, service allows you to have a “pretty name” for your home network. I use because it’s free and works quite well. So, you would have a name for your home IP address (where your Drobo lives) like This is basically what Drobo was offering with DroboAccess (ex: You can now access your home network from anywhere in the world with that DDNS address. You do need to have some process on a device on your home network that will send your IP address changes to the DDNS service, but it can be as simple as a script that runs every 5 minutes or so (DuckDNS gives many instructions on how to do this).

Next, you’ll need to set up your router to forward requests from outside your internal network (from the internet) to the appropriate device inside your network. For example, if you’re running an FTP server, you would set your router to send any requests to ports 20 and 21 to the internal IP address of your Drobo. So, a request to would be sent to your Drobo (and not any other of the devices connected to your router).

As for a Drobo replacement, if you’re looking for an appliance type device (like Drobo), one of the more popular options is Synology. Personally, I think I may have outgrown these kinds of devices and might take on a more DIY type project running Unraid or TrueNAS on my own hardware. But for now, my Drobo is still serving me just fine. Plus, I’m quite comfortable compiling apps to keep them updated and secure, so I won’t be replacing my 5N2 quite yet.



One more thing: if you are still using Drobo to host Plex, I would recommend against using the version last distributed by Drobo. Plex themselves still maintain and update their Plex for Drobo builds. Grab the .tgz file from Plex directly.

On my end, I stopped running Plex on my Drobo directly since it was not so good with transcoding when I started using Plex remotely. It was fine for Plex inside my home, though.

Thank you for your comments and suggestions!

  • Yep, I’m using the latest version of Plex downloaded from the Plex site. Plex releases so many updates since it’s a manual upgrades, it’s administrative overheads. I’ll give attention to when there is any issues only and yeah transcoding is not that great outside of home but still works fine on phone.
  • myDrobo is installed but Public DNS is broken so can’t register any more or transfer my existing account so it is currently useless. I think I need to use to make it work. Is there a way I can run it on Drobo box or Nvidia Shield? Other option I can run on an windows laptop.

Best regards!

Hello again!

Glad Plex is working well for you. I think I just outgrew the NAS-hosted version of it myself.

For myDrobo, I suspect existing accounts will keep working until the certificates eventually expire. But new accounts likely can no longer be created.

For duckdns, you have a couple of options. If you want to run it on Drobo, make sure your cron is enabled on Drobo (it’s disabled by default). See here for how to enable cron:

Once you have cron enabled on Drobo, you can follow the instructions for duckdns here:

For your Nvidia Shield, there used to be an Android client for DuckDNS, but it seems to have disappeared from the Play Store.

You could also run a Windows Task to update DuckDNS. The instructions are on DuckDNS’ website. If you’re on Mac, the instructions are also there and also use cron.

One last thing, if you have an Nvidia Shield, you may want to consider running your Plex Server on it, instead. It is much more capable than the Drobo is. You can still have all your content stored on your Drobo with your PMS running on Shield. :slight_smile:

1 Like

Hello Dom!

Thank you so much for your all support and suggestion. I caught up busy and could check your messages in time or try this out but will try this weekend how it goes.

I think it makes sense to run Plex on Nvidia Shield. I need to research on DuckDNS and then how can I configure in myDrobo to recognise the so that DroboAccess and DroboPix get connected since these two app looking for the myDrobo to be configured first.

Best Regards,

1 Like

I don’t think you’ll be able to replace MyDrobo with DuckDNS directly for the MyDrobo app. Using DuckDNS would be a way to bypass using MyDrobo and DroboAccess at all.

Does DroboPix require MyDrobo?