no droboapps in dashboard?

I can manually install droboapps but i cannot get any of the official ones to show up in the dashboard…

Also, is there a way I can use my Private Internet Access account on the drobo? I know openvpn settings exist for it, im just not sure how to do the whole openvpn thing or how well it works.

And the final thing I need is for the drobo to show up as a DLNA type device. It is a mapped drive right now but it doesnt have any DLNA capabilities, so only my 2 computers are shown by my receiver as networked devices. I think mediaTomb does this, or miniDLNA from the repository.

I’d like to update for the sake of anyone else here.

Support ticket was opened, they are still working on this. Apparently this is the 3rd time ever that this has happened. is the address it tries to connect to. Most of the droboapps are available from there.

Dropbear is available on the forum, but I used openssh with putty on the windows side of things, so i was able to log in as root (UN root PW root). I’m going to ssh in again as my own user (UN shrimants, PW ******) and see if that works.

I’ll be getting Nano so I can edit text files, OpenVPN so i can try to use Private internet Access, and probably the Plex app. I dont know if that is a plex server or plex client app. hopefully i can manage to configure plex to do full-size file streaming except to DLNA devices, which I’ll want mp3 instead of FLAC streamed. For my videos, i know the drobo wont do any transcoding, as it is just not powerful enough. Thats OK, as i prefer to use my computer and access files as a file share as opposed to getting a transcoded stream sent.

I’ll keep you guys updated if I can. let me know if its helping anyone.

Were you able to get this set up? If so can you provide a tutorial on what was required?

Still trying to get it to work. Here’s an update of whats happened so far:

I figured out the droboapps problem. i have Internet -> ATT 2wire gateway -> netgear router -> devices as my configuration. The problem was that the drobo doesnt make a regular HTTP web request (or something) and it never manages to reach past the router.

The fix for this is to place the ATT modem into “modem only mode” or “through mode”. This essentially disables all networking and routing functionality of it, and uses your own router as the main routing device. This was a complicated process, and it changes every couple months, so i’m not going to get into it here. Basically, search for “through mode” or “att disable routing 2wire” and you’ll have to translate the old settings into the new att dashboard settings to figure it out. A lot of it was trial and error, during which I had no internet access apart from tethering to my cell.

For the openVPN part: i’m not quite there yet. here’s what i’ve found out:

  1. install Dropbear through droboapps. ssh into the box using something like Putty on windows. IP = drobo ip. Username = root, password = root.
  2. type ‘passwd’ and change the root password. for the love of god, change it.
  3. get the openvpn tgz file and place it in //droboapps. reboot the drobo or, as root via ssh, type /usr/bin/ install. This will install the app and you can see it as a folder instead of a tgz in your droboapps folder.

ignore the stuff about “needing zlib, openssl, tun/tap driver” and all that. those are instructions for compiling source, not for using precompiled binaries.

This is basically as far as i’ve gotten. You will need to download the openVPN zip file from Private internet access. then you take the .ovpn scripts that you are interested in (for me its usually US East, US California, or CA Toronto. CA Toronto has port forwarding enabled, the others are just local/fast).

you will also take the crl.pem file and the ca.crt file. all of these (.pem, .ovpn, .crt) go into your DroboApps/openvpn/etc/[put them here].

Then this is where I get stuck. you can go to Droboapps/openvpn and type ./ start in order to start the openvpn service.

Now here is why i’m confused: I cant figure out how to make it start automatically. i cant even manually start openvpn with the right credentials to make it connect. i keep getting errors regarding it not being able to open the cert or the pem file. so im not sure what im doing right/wrong at this point.

PIA doesnt have command line instructions for using it, though thats my next stop: their chat room. I’m pretty sure ive got openVPN where it needs to be though.