Drobo

No connection via iSCSI

My DroboPro connects fine via USB 2.0 but will not enable a connection through iSCSI. My system indicates a 1GBit/s connection and has dynamic IP activated when the ethernet cable is connected instead of the USB cable. The dialogfields in the MS iSCSI initiator ar all empty!! But I would have no clue what to enter if manual configuration is required … Anyone any idea? By the looks the system is not able to retrive a dynamic IP from the DroboPro … setting everything to fixed IP the connection is established but it still seems to be a problem with the connector

OK … after turning of the dynamic IP handling and setting a fixed IP (first with enabled USB connection and the dashboard) then in my network settings the connection was established on a network level! After manually entering all available data (fixed IP, Subnet Mask and no DNS) in the iSCSI initiator SOftware as well as manually activating the targts in the initiator through numerous sub-tabs I could see Drobo drives in the XP Explorer … and could copy files …

But something still seems to be screwed: The Dashboard SW can’t see a Drobo anywhere. Can’t get it to connect. It always says “Ready to connect”. Diagnostic will not open.

This is NOT what I call an easy installation procedure … and iSCSI help is nowhere available …

What OS are you on?
What version of Dashboard are you running?
What version of MS iSCSI initiator are you running?
Are you removing the USB cable when you are connecting the ethernet cable?
Does dashboard see the Pro when you are connected via USB?
Are you connecting to your NIC card on your computer/server or are you connecting through a switch?

  1. Win XP Pro, SP3
  2. Updated Dashboard and Firmware today …
  3. Updated MS iSCSI today
  4. USB cable is removed when connecting via iSCSI (always only 1 cable a time)
  5. Yes, I can communicate with dashboard to Pro via USB. That way I assigned my fixed IP to the Pro
  6. Pro and Computer are directly connected through the Ethernet cable comming with the Pro. No switch in the middle.

So the Pro and NIC are in the same subnet for ip addresses?
MS iscsi discovers the target of the Pro?
What happens when you refresh?

When you going from the usb to iscsi, did you turn it off via the dashboard then swap out cables or hot-swap cables?

  1. Yes, elsewise I would not be able to access the DroboPro now through the Windows Fileexplorer and copy files
  2. Eventually it did after adding the fixed IP myself and activating the targe manually
  3. What do you mean with “refresh”? The button in the iscsi? Don’t think that’s necessary … tried it anyway. Did not change anything. In the iscsi dialog there is only one target portal active. I have no entry in the iSNS Servers Field.
  4. I shut down the computer, changed the cables and started windows again

OK, just for your information: For some stupid reason and after rebooting DroboPro and my System plenty of times it seems to work now … (without changing things above). Don’t know what suddenly caused the system to work … doesn’t feels good, but at least it works now.