NFS service

Hello!

I’ve just become a drobo 5N user. I use it mainly for video content and stream from it via Windows share (SMB).

The problem is that my multimedia player (Mede8er MED1000X3D) is having difficulties streaming high bit rate (~50Mbps) content via SMB.

I have been advised to steam via NFS protocol as MED1000X3D has a better performance this way.

How do I make my drobo 5N NFS accessible?

You can download the NFS droboapp from here: www.droboports.com/app-repository/nfs-1-2-8

Enable DroboApps on your 5N, then using your desktop computer browse the SMB share \drobo-5n\DroboApps\ and copy the NFS .tgz file in there. After that reboot your 5N. After reboot your 5N should be automatically exporting all shares over NFS.

Thank you for the info!

I have 2 more questions.

  • How do I configure NFS shares and access to them?
  • How do I remove NFS service if I choose to do so?

There will be a file called “exports” inside the folder \Drobo-5N\DroboApps\nfs\etc. That file contains the list of shares and their options.

To remove the NFS service, you can either use the Dashboard or just remove the “nfs” folder inside the DroboApps share and reboot the Drobo.

Thank you again!
I got NFS up and running as needed. :slight_smile:

I would like to chime in on this one, I am having the same issue… I cant get the exports to line up with the source i need it too. The closer i feel i get, the further away it seems to be.

I’m sorry, I don’t understand what the problem is. Could you please rephrase it?

im sorry.

I have loaded and 1.2.8 is running in the Apps.

When i try and access the NFS share under public folder, the folder is empty.
It will see the folders but all of them remain empty. im not sure what i did wrong.
I have deleted and reinstalled NFS 1.2.8 several times but still have not had any luck.

Please post your exports file. Do you have SSH access to your Drobo?

JD I know you pm’d me on this one. Please make sure you have configured your exports file. Do this by accessing it via SMB (windows) share as you would any other share on the box. DroboApps folder, subfolder nfs\etc

The file exports has no extension and should be opened in something linke notepad++

Can you confirm if you have done this and if so what’s your contents?

sorry it took me a little but to get back… Here is my export file.

Last login: Mon Nov 17 16:55:09 on ttys000
/Volumes/DroboApps/nfs/etc/exports ; exit;
jasons-iMac:~ jasonthomas$ /Volumes/DroboApps/nfs/etc/exports ; exit;
/Volumes/DroboApps/nfs/etc/exports: line 1: syntax error near unexpected token (' /Volumes/DroboApps/nfs/etc/exports: line 1:/mnt/DroboFS/Shares/Public 192.168.1.0/24 169.254.176.35(rw,insecure,no_subtree_check,all_squash,anonuid=99,anongid=99)’
logout

[Process completed]

There is another export file that is labeled " export.default" in the ETC folder
This is what it contains
/mnt/DroboFS/Shares/Public 192.168.1.0/24 169.254.176.35(rw,insecure,no_subtree_check,all_squash,anonuid=99,anongid=99)’

My Drobo5N sits on static 192.168.1.200
I have 2 shares on it.
The main share is labeled MEDIA
The second Share is public, i have not used it.
The MEDIA share has several sub-folders such as Movies, TV Shows, Children, ETC and those have folders in them with MKV and MP4 files as well as some other data to describe the contents of each.

Example.

Media/Movies/Iron Man
I have played with the settings and dumped a file folder in public and a MKV movie file in it and it would see the folder but it was empty and the file could not be seen.
I have started over and installed 1.2.8 again and i haven’t gotten that far back.

The export file does not seem to have the ability to make changes in it via TextEdit.
The export.default one can have changes made to it.
I have installed SSH on the Drobo but really do not know how to use it to be perfectly honest. I have stopped it but it remains in the DroboApps section.

I am using an IMac but have the boot option via Parallels to use Windows if i need to.[hr]
also if i try and connect to server in IMac via “Server Connection” it states Permission denied when using the mount points in the export file.
I do not understand why i get the Syntax error on line 1

Try this line in your exports file instead:

/mnt/DroboFS/Shares/MEDIA *(rw,insecure,no_subtree_check,all_squash,anonuid=99,anongid=99)

This file is usually protected against changes, so you have to login to the 5N as root and edit it there.

By the way, if you don’t mind me asking, why is it that you need NFS? If it is giving you so much trouble, why not use SMB instead?

I have now asked myself the same question…lol
SMB has some issues starting up from a dead sleep, the hand shake seems to take longer for some reason and NFS may be a faster up time.

I need to understand how to login to the Drobo as well. I need to restart SSH btu when i did last and typed ssh root@ ipaddress it said denied…this is from the terminal on my imac