Drobo

NFS on Drobofs

Hi
I need a help for NFS on DoroboFs . If somebody has tried and worked let me know . I install DroboApps and installed NFS also , it did not work with my server .
Please let me know

thanks

Works fine for me, If you post your exports file and the mount command you are using you may get more help.

Here is the Exports file content

/test 192.168.10.4(rw no_root,squash)
Let me know if anything wrong in it .

thanks

There are a couple of things wrong with it.

  1. The path needs to be relative to the DroboFS’s root directory. So, you probably want it to be /mnt/DroboFS/Shares/test
  2. The commas and underscores are in the wrong place.

The correct line should read:

/mnt/DroboFS/Shares/test 192.168.0.4(rw,no_root_squash)

Kind Regards,

Red

Just one more question
Do I have to specify
/mnt/DroboFs/Shares/test
even there is no directory in drobo as /mnt or DroboFs or /Shares

Thanks in adavnce

You just need the one line:

/mnt/DroboFS/Shares/test 192.168.0.4(rw,no_root_squash)

The reason for the “odd” path is that the nfs server runs on the DroboFS. The “test” share you created lives on the drobofs at the path I specified.

Kind Regards,

Red

Thanks very much for your help … I was able to connect .
Regard

Happy to help. NFS has been around longer than Windows has had networking support and it’s performance is still superior to Microsoft’s SMB and CIFS protocols.

Hello,

I’m trying to get my NFS to work to no luck.

Trying to access it from a linux box via the showmount -e 192.168.7
Export list 192.168.0.7:
That’s what i get.

Export file looks like this
/mnt/DroboFs/Shares/ 192.168.0.*(rw,no_root_squash)

I have DHCP on a number of machines so I want the whole span to be allowed to access the drobo.

SO how can I when I’m logged in through SSH on the Drobo verify that the shares are mounted or do any other type of verification? When I can verify and confirm that it’s working I will try and pair it with my Tvix box.

Are there any other type of setups I need to do besides the exports file ?

bump

Try:
/mnt/DroboFs/Shares/ 192.168.0.0/24(rw,no_root_squash)

Works for me…

It doesn’t change anything for me either way.

I wonder what’s wrong, does anyone have some ideas on how to trouble shoot and/pr verify that it’s set up correctly.

Finally, it seems like I can find the NFS mount :wink: Don’t know what I did but it’s working now.

Now the next issue. Samba is fast as crazy but NFS is slow. It takes minutes to list all folders in a directory on the Drobo ? Anyone has had anything similar ?

I hope you don’t mind me tagging on here, but I’m having a similar problem and hope someone can enlighten me on the missing step that makes nfs work. Here is my current exports file:

/mnt/DroboFS/Shares/ *(rw,no_root_squash)

I restarted the Drobo just in case that was needed. On my iMac I type the following:

“showmount -e 192.168.2.115” and the result is the same as yours:

Export list for 192.168.2.115:

With nothing else shown.

Also when I try to mount a share from the command line I get a permission denied error (since, I assume, the directory isn’t being shared). I’m not sure what else to try and the documentation is a bit on the thin side. Any suggestions?

I thought I replied to this last week but my reply seems to have disappeared. I had to make two changes to make my setup work:

  1. I had to change the * to 192.168.2.0/24 because otherwise the shares would not export.

  2. I had to ssh into the Drobo and manually run ./service.sh restart to make the exports take effect. Restarting the Drobo, oddly enough, did not seem to properly restart unfsd.

2a) At some point while I was messing around, the /mnt/DroboFS/Shares/ line stopped sharing anything below the Shares directory, so I had to create individual entries in the exports file for each share.

Now I can see the shares on my Mac and MythTV boxen. The only other issue is that I could see only the top level directories I had previously copied via Samba. I had to chmod -R 777 * in order to be able to access the NFS shares from my Mac. chmodding something to 777 always seems like a bad idea to me; is there some other way I can get actual rw access to my shares since the “rw” in exports doesn’t seem to be doing the trick?

I’m just going to keep replying to myself in case it helps someone else and also in case someone else sees a better way to accomplish what I did. I was able to achieve rw without 777 by changing the exports to read:

/mnt/DroboFs/Shares/Music 192.168.2.0/24(rw,all_squash,anonuid=0,anongid=0)

This had the effect of making my Mac and Linux computers write to the Drobo using uid/gid 0 which is root on the Drobo. That means I had full read/write access.

Unfortunately, upgrading my Leopard install to Snow Leopard messed it up again. It deleted all my NFS shares, and upon re-creating them in “Disk Utility” I am unable to write to the Drobo via Finder. When I try copying a file it gives me an error 36 and puts a zero-byte file with the name of the file I was trying to copy on the Drobo. Oddly enough this file shows that it is owned by my OS X user instead of root when I look at it in terminal. Since my user doesn’t have read/write access to the share, it can’t write the file. I can copy just fine from terminal and can create directories in Finder that will show root:root ownership, but any files I try to copy in the GUI fail.

I’ve tried messing with export parameters such as insecure and adding a hosts.allow to the Mac with “ALL : : allow” but so far I’ve had no success. My NFS shares on my Linux box mount just fine on the Mac, so it’s a problem I’m only experiencing with the Drobo/unfsd. Naturally tech support says they don’t support nfs on the DroboFS, so I’m left with peer support here and trial-and-error. Any ideas?

@ bevier69 - Did you manage to sort out your NFS connection? I am having a real problem trying to connect to my TViX box on NFS, and wondered, being as you mentioned having a TViX box too, whether you have been able to establish an NFS connectionwith the Drobo?

For anyone else that may be able to help, my Export file is:

/mnt/DroboFS/Shares/Drobo 192.168.0.0/24 (rw,no_root_squash)

The Drobo is on a static IP address of 192.168.0.7, which I have entered into the TViX along with the network share name of //Drobo/Drobo (this is the what I have named the Drobo and the name of the share - this is the network share used bymy laptop and Sonos system). The TViX has a static IP of 192.168.0.11

I have Apache, Drobo Admin, Dropbear SSH, UNFSD and FUPPES all installed in the Drobo Apps and active.

I have virtually no knowledge of Linux, and so have been struggling to access the Dropbear SSH. I eventually downloaded something called PuTTY and seemed to be able to login to the Drobo but that is as far as I can get. I tried using a ‘showmount -e localhost’ command, but this showed nothing.

I can connect between the TViX and the Drobo on both Samba and UPnP via FUPPES, but Samba is very slow (stuttering video streaming) and FUPPES has lots of limitations in terms of files types it won’t recognise, so I really need NFS to work.

Does anybody have any ideas or suggestions?

Cheers,

Gareth[hr]

@ Doomedtx - I will try your suggestion above, can you tell me (in lamens terms!) how I go about manually running the ./service.sh file?

I am currently trying to refresh UNFSD with changes I make to the Exports file by restarting the DroboFS, but if this doesn’t bring the changes to Eports into effect then I’m not going to get anywhere.

Looking at my post above, is PuTTY the correct way to access the SSH to run Service.sh?

Thanks,

Gareth

As far as I know, you still need to use the full path, so the share should be mounted as nfs://Drobo/mnt/DroboFS/Shares/Drobo

Use PuTTY to login to the DroboFS. Then type the following commands:

[code]# cd Shares/DroboApps/unfsd

./service.sh restart[/code] (note the “./” before service.sh!)

After a few seconds the nfs service should be restarted with the new export settings in effect.

[/quote]

As far as I know, you still need to use the full path, so the share should be mounted as nfs://Drobo/mnt/DroboFS/Shares/Drobo

[/quote]

Thanks for the reply Doomedtx, just to clarify, are you saying that everything in the speech marks below should be in the path in the Export file:

“nfs://Drobo/mnt/DroboFS/Shares/Drobo”

Would you also expect this to be the full share path entered into the Client (in my case the TViX)?

Your export file seems fine as is. On your client, instead of just “//Drobo/Drobo,” it would need to use the full path. I’m not familiar with TViX or how it maps NFS shares, but if you’ve already defined the server “Drobo” with Drobo’s IP on TViX, then your share path would be “//Drobo(or nfs://Drobo if required)/mnt/DroboFS/Shares/Drobo.” Otherwise you might need to use “//<Drobo’s IP Address>/mnt/DroboFS/Shares/Drobo.”