New User Experience

I opened my 5N box on Christmas morning, courtesy of my dear wife who snaked it from my Amazon saved cart… I’ve hit a few roadblocks with the setup, so I’d like to share my experience here, in hopes of getting suggestions, and providing feedback to the developers of the device.

My primary use for the Drobo 5n is a media server, with automated Usenet downloads, to download TV shows to stream along with my backed up movies.

I am an intermediate user at best… so rather than spending a ridiculous amount of time converting an old PC into a media server, I was happy to find out the Drobo had it already packaged.

I have had it sitting in my cart for months trying to rationalize the extra cost, and was stoked to find it under the tree on Christmas morning.[hr]
Initial setup went well… I formatted a drive (still waiting for the rest to arrive) set up preferences and shares, and installed Plex. That was simple, if time consuming. But I hit a roadblock with the Usenet apps. Sickbeard and friends all failed install, and won’t run.

I dug around here, and found out about the a python prerequisite. Not the end of the world, but it sort of defeats the purpose of the prepackaged apps, doesn’t it?

I put the python 2 setup file into the droboapps share, and rebooted. The setup file did not disappear, but a Python folder and install files was created. I can’t tell if it’s running, as it is not shown in the app space on the dashboard, so I tried installing the other apps.

Same problem.[hr]
I poked around a bit, uninstalling and reinstalling, rebooting, etc… then I hit up tech chat. The tech recommended that I uninstall python, and download the latest here:

Did that, still have the same problem. I tried to hit up tech chat again, and got the “leave your email” autoresponse. Since then I’ve gone as far as restoring to factory, and starting with Python2. I keep running into the same problem.

Any ideas?

There are many, many apps that require python. Some of them very small. Does it make sense to include a huge dependency (python is 26MB) with each python app? Sabnzbd is just 3 MB, Couchpotato is just 3 MB, and so on.

Ideally there would be a way to install dependencies automatically, but that is not the case right now.

That is exactly what you are supposed to do. Just place it there and let it be.

Try this: remove everything, reboot the Drobo. Then get the latest python2 from, copy it inside the DroboApps share, restart. Then copy the rest of the usenet apps, and restart. That should work.

Ricardo, thanks for the reply. That’s exactly what I did, except I didn’t get the files from droboports. I’ll try that when I get home tonight.

Amazon delivered my remaining HD Drives and my SSD for the accelerator bay, along with a UPS and a few other goodies. Now I can’t wait to get home and try the fix; hopefully it works and I can make this thing go.

A couple of questions for the brain trust; Is there any way to verify successful install of Python? I’m concerned because the Python2.tgz file didn’t delete after the reboot, even though the contents appeared to unpack into a new folder. All of the other apps I added, the tgz file disappeared after install. Does this mean something went wrong when it was installing?

Also, what video format do the rest of you favor for streaming in-network? I have been ripping to MKV with MakeMkv and Handbrake, but I have some devices that don’t recognize that format. Do you use MP4 or other formats instead? What converters do you use?[hr]

The version I used last night that I got from the link I posted is the same one as what’s on droboports. The link refers to their github site.

There’s a note that says “Include BDB, libffi, and expat as dependencies”

Does that mean I have to add those before I can successfully run Python? Is Python dependent on any other apps being installed first?

As advised, I downloaded the most recent versions of Python2, Sickbeard, Sabnzbd, and Couchpotato from the droboports app repository here:

I installed my new drives, and my SSD in the accelerator bay (yay) and removed everything but the Apache folder from my Droboapps folder. Drobo is happy. All green and confirms the accelerator SSD is active. Sweet.

I then copied Python2.tgz (2.7.8 for drobo5n) to my Droboapps folder and rebooted.

Time passed…

As before, a Python folder was created and populated, signifying an install, but python2.tgz was not deleted.

I copied sickbeard.tgz, sabnzbd.tgz, and couchpotato.tgz into the droboapps folder, and rebooted again.

More time passed… I feel like a kid waiting for cookies to bake, or a stoner waiting for pizza delivery. Time slows to a c r a w l . . .

I could really go for a pizza right about now.[hr]
… Reboot complete.

Couch Potato: Application is stopped. Will not start.

Sabnzbd: Application is stopped. Will not start. Offers update.

Sickbeard: Application is stopped. Will not start. Offers Update.

I’m beginning to think that my Drobo did not install Python and never will. Ok, how’s this? servicerc reads as follows:


No “YES” for python. Any ideas? Can I update the OS, refresh it or something?[hr]
Whoa… the python2 folder on my droboapps contains only one file: host_uid.txt. It is a text file with my Drobo 5n serial#.

Trying again.[hr]
OK, brain trust. I’m at a loss here. Still no response from the tech team, despite reopening the ticket from earlier.

Should I try to manually update the firmware? I have 3.1.1 [8.35.45] and the manual firmware site is 3.1.1

Should I force a firmware update? Does that update/replace the firmware even if it’s already current?

After a manual firmware update, deleting the apps, and rebooting, I tried again to install Python. This time the python2 folder populated, and Python2.tgz disappeared. I take it that’s a good sign…

Added my apps and rebooted.

Couchpotato = Running.
Sabnzbd = Running
Sickbeard = Running

Thanks y’all! I’m on to the next step.

So far, so good; My apps installed fine, and I am now up and running with Sickbeard and Sabnzbd.

Clearly the Python2.tgz file not deleting was a sign of a failed install. After multiple failed installs, the fix was forcing a firmware update, and then Python installed fine.

It’s not exactly a plug and play experience, but well within my amateur capabilities, and much simpler than learning to build my own server.

At this point my feedback for the dev team is that you should either include Python2 as a preloaded app, and/or include a flag to notify new users of apps that require prerequisite Python install. That might reduce the tech support demand.

My feedback for new users is to read the forums before you get too far into your installs, and get your apps going before you add data to the drives.

I wish I had done that; I’m a bit miffed that I didn’t get it going last week when I was off, and now have to wait until after work to play with it… but I’ll get over it. had some basics on how to configure Sickbeard and Couchpotato with Sabnzbd. I sorted out all of the api keys, search, and news providers, and both SB and CP are successfully searching and snatching. They both also confirm communication with Sabnzbd… but Sabnzbd was doing nothing.

Error log showed the unzip, par2, and unrar missing, so I followed the instructions in another post to get par2 and unrar from droboports, saved in the app folder, and rebooted. Both appeared to install fine, but after reboot I still get the same error from sabnzbd.

I did edit the file, as noted here:

But that did not remove the error. Is there further configuration needed on those programs? Should I uninstall and re-install sabnzbd?

so… I uninstalled and re-installed sabnzdb Without Updating it. I used the most recent version from droboports, and of course had to do the config again, and update the api keys.

But sabnzbd is now a happy camper, cranking away on downloads without a single warning.