Drobo

New firmware 1.1.2?

Hi everyone

After rebooting my machine due to my drobopro crashing Dashboard just notified me that there’s a new firmware release. So I told it to go ahead and apply it. It failed on the first attempt:

Update

The Drobo Firmware update was unsuccessful.

Please review our support website at www.datarobotics.com/support.

Going to give it another shot and see what happens.

Edit: 2nd try didn’t work either. I’m wondering if I don’t have a defective unit here. Rebooting everything involved and trying again.

Didn’t see the update http://www.drobo.com/support/updates/firmware/

Perhaps it was pulled before it could be installed on your unit. My dashboard says also there is nothing new.

3rd time was the charm. Strange that it’s not there. Hope I didn’t just install some bad firmware!

Where are the release notes???

I have no idea where the release notes OR the actual firmware update is, it just showed up in my dashboard.

I just installed it, seems to work fine. First time round. The releasenotes are easy to find :wink: click on the 1.1.1 releasenotes and in the URL replace the last 1 with a 2.
The strange thing is, it’s been saying “Data Protection in Progress” in the dashboard, but no lights are blinking or anything on the actual machine. I’m keeping my fingers crossed :wink:

My dashboard doesn’t say that protection is in progress at least :slight_smile: It all shows as expected here, just still seeing poor performance. Hopefully the DP crashes have stopped … only time will tell.

P.S. The 1.1.2 firmware and release notes now seemed to be linked on the main support pages

I got a little curious about the whole “data protection in progress” - quitting and restarting the dashboard did the trick.

So far, I’ve been unable to download 1.1.2 successfully, and I can’t find where it might be posted for the old Ctrl trick (or whatever it is).

It occurs to me, however, that DRI never seems to test running in STANDARD mode, as opposed to Admin mode. Has anyone successfully downloaded the new firmware while running a standard user? I hate to have to uninstall and reinstall it, for little reason.

EDIT: That was the problem – as I expected. I installed Drobo Dashboard into my Admin account, and the update worked. Now I will have to reinstall it once again, so that the iSCSI initiator will work when I am running in standard mode – as anyone who has half a brain ought to, unless they want to their systems to become spam 'bots.

Now I can get back to testing again.

However, I’d like to quote something Jennifer said when the new forum started up:

"DroboSpace is now operated by the Drobo experts in the Data Robotics Support organization, with the new goal of responding to questions, providing useful feedback, and otherwise supporting the Drobo user base.

“Some of the advantages of the new and improved DroboSpace include:
• Quickly respond to hot topics with our in-house response team
• Provide direct information to our community without third-party lag time”

Well, excuse ME, but several of us have wasted quite a bit of time to research the issue of unacceptable performance, and honestly trying to help DRI in dealing with this problem, after several people have said that Tech Support has claimed that they cannot recreate the problem, and (presumably) don’t understand what is happening.

And then, after everyone has spent hours trying to debug this problem, and the performance thread has grown to five pages, SUDDENLY we see a new firmware update, with no notice, and apparently no beta testing? Contrary to the usual practice of letting things cook for a while, this is now available immediately?!

And no one knew this was coming? None of the Data Robotics Support organization, or anyone charged with “quickly responding to hot topics” and “provide direct information without third-party lag time” – NONE of these people could have said, just once, “We know something is wrong, we are actively working on the problem, and putting a fix through QA as we speak. We hope to have at least a partial fix available by August 20th.” They couldn’t even say that?

Then what, pray tell, IS the purpose of the new forum???

The new fw didn’t help anything regarding the speed problem. Wasn’t it the speed problems that let us switch from Drobo V2 to Pro??? Well here we are again.

That’s exactly why I switched to the Drobopro!

I’d like to see an improvement to the entire firmware update/notification process. Since you have to register a DroboPro unit with support via its serial number, how hard would it be to do an email blast to DroboPro users prior to, or in conjunction with, a firmware upgrade? This could be as simple as a notice that a firmware upgrade is coming along with a link to download it and any corresponding tech notes. The first time you are aware there is a firmware update is when your dashboard it asking you to download/install it, which to be safe, should probably never be done sight unseen of tech notes or a backup/safety procedure being run first. Hopefully DataRobotics will be ab le to improve this overall process quickly and easily since it will remove an obvious point of contention over communications with their end user installed base. Just my two cents worth…

Speed concerns were why I skipped drobo altogether and went right to drobopro (well and for the extra space of course).

I had the same issues - Are you running it on iSCSI?

I was and ended up having to hook up via USB2 to apply the new firmware - then it worked. I hooked back up the iSCSI and then about a week later there was another update - that one applied no problem.

I am now up to:

1.1.2 and the 1.5.1 dashboard

No I was connected via FW when i had the issues as i can’t use iSCSI on OSX 10.5.8 with a PPC machine.

I think my issues were related to the fact that I had had a few crashes with the drobo before hand (including reboots of it and the OS as it took everything down) and it was likely on the verge of crashing or crashed when i tried to perform the upgrade. Since updating at least I haven’t crashed the drobopro again (yet!)

Well hey thats good news then…

Yes on that front. Still having other issues that the 1.1.2 update didn’t resolve though :frowning: