myDrobo / Drobo Access on Drobo 5N

I cannot figure out for the life of me what’s causing slow connectivity to my Drobo 5N remotely. Firstly, my subdomain (not real) takes a very long time to load up and it wildly inconsistent. Once I’m able to get in, I’ll set multiple files for upload and in which some will complete and some won’t. Why? I have no idea. Is myDrobo / Drobo Access just very unreliable or am I doing something wrong? Any port forwarding needed? Btw, the Drobo 5n is on a 300 x 20Mbps circuit.

Files: Typically between 500MB - 1GB files.

Drobo 5N:
Firmware - 3.5.11 [8.90.81921]
Installed Apps: myDrobo, DroboAccess, Apache, Locale, MySQL, & Python 2

I’ve uninstalled, reinstalled, and reset the Drobo plenty of times. The same issue remain. It’s working very well as a NAS but the apps seem to be really hit or miss.

Do you have any issues accessing it locally? If it just remotely, it could be whichever provider is between you and your Drobo…or any part of the path from here to there.

It’s the same behavior locally. Shares and everything else works great on the local network but anything relating to the myDrobo/Drobo Access apps results in the issue. This happens regardless if I’m using the domain or the statically assigned private IP for the 5n.

hi can i check if your drobo is having any solid yellow or solid red drive bay lights (on the main unit, or dashboard) - am just wondering in case your drobo is low on space?

All lights are green. I have 8TB’s on the 5N with Dual Disk Redundancy. I’m currently using about 900GB which leaves me with roughly 75% of free space.

Try to restart myDrobo. I was told that the backend had some DNS issues this last weekend which are now solved.

A restart should assign you to a different relay server, with better bandwidth.

Please keep in mind that once restarted myDrobo may take up to 5 minutes to have its DNS records fully propagated, so be patient while that happens.

thanks for the info carl, its definitely not a low space issue then - but i just saw ricardos update so thats good that an issue was found and hopefully a Restart (or pending future fix) can resolve for you.


Doing so now. Thank you for the info. I certainly hope this works![hr]


Thank you for the help. I’m going to follow what Ricardo has stated and see if that resolves my issue.

Unfortunately restarting myDrobo did not fix the issue. It’s still taking up to 10 seconds to get the log in page and minutes before anything loads after. It’s very frustrating.

btw how are you accessing your subdomain?
if it is on a computer, are there any antivirus tools you are using there, which might somehow be slowing things down in a browser, such as for scanning or intercepting ssl traffic for protection processes etc? maybe a browser toolbar or something too is conflicting if via a browser?

I’m accessing the subdomain on a Mac running macOS Sierra 10.12.2 using Safari. I’ve tried it with virus scanning enabled/disabled on both Chrome and Safari. I’ve also tried on my Windows 10 laptop. I opened a ticket with Drobo and sent them a diag as well. Everything seems to be pointing to an issue with the domain.

thanks for more info - i think there was a verified cert that expired recently with part of the mydrobo app (though am not sure if that would be preventing things if after some minutes some transfers do take place)…

raising that ticket was a good thing - is it possible to list out all of the apps you are using (either for the ticket support team though might be useful here too)

I’m only running myDrobo & Drobo Access and all of their prerequisites that are installed automatically. Drobo support told me to give my Drobo 5N a statically assigned private IP that’s outside the range DHCP from my router is issuing and use Googles DNS servers and As mentioned, this happens on multiple service providers (TWC, Frontier’s FiOS, Cox, and Charter) so I highly doubt that’s the issue and assigning my Drobo 5N a static IP outside the range of DHCP? I don’t know what that’s about honestly. I have put my Drobo 5N in a DMZ to test it and that didn’t change anything either.

Running apps

  1. myDrobo
  2. DroboAccess
  3. Apache
  4. Java 8
  5. Locale
  6. MySQL
  7. Python 2

Ports forwarded to the 5N

  1. 445 TCP
  2. 80 TCP
  3. 8080 TCP

thanks carl this is useful info, especially for the support team.
im not yet that experienced with the nas models (hopefully that will change in future), though if they did suggest those particular steps please do try as definitely will know better then me to be honest

I gave those settings a go and I’m still running into the same issue. Now it seems to be very random. The sites sometimes loads quickly but more often than not, it’s incredibly slow.

hi carl, sorry the forum has had some problems for several days, and i was able to log in again now.
do you have access to any of your software or hardware firewall logs? (maybe you could have a look in there, just in case there seem to be a lot of blocked entries, during your test sessions where it is slow?)

for example, some of the more aggressive (or protective) antivirus/firwalls, can throttle website access in general sometimes, (whereby a site making lots of connections gets some of them blocked if it makes too many within a given timeframe, which can also give the impression of a delayed, slow web connection) - i just think if you have a bit if time to have a look in there if there are any firewall logs you can access, it could help to possibly pinpoint something there, or to maybe rule something out)

(btw hope you were able to enjoy the festive season, despite the current issue) :slight_smile:

My DroboAccess ran slow as molasses, then I noticed Drobo had an apache update available. I ran the update and now it responds much better. Perhaps an update is needed?

I’m glad that worked for you. I thought an update was the issue too until I realized there were no updates. I even uninstalled all apps and system files, rebooted, reinstalled the apps, rebooted and still had the issue. It would be nice and fast for a few hours and would bog down again to the point of taking 30 seconds or so to bring up the log in screen.