Drobo

mSATA drive disappears from Drobo Dashboard

Does anyone know why the mSATA drive sometimes appears in the dashboard (below the image of the Drobo unit) and sometimes it doesn’t? How can I verify the mSATA drive is active and working properly? Last time it showed up it indicated 100% and working well, but it’s just not showing up now.

hi kloh, can you remember how long it remains found (or hidden) when it happens, and how often this take place?
btw has your drobo been physically moved recently?
(sometimes a hard drive can wiggle free or if a spring clip is pressed without the cover on so just wondering in case something happened to the msata too)

btw which msata card is it?

Hi Paul, thanks for the response.

I try not to move the Drobo at all. The last time I restarted everything (Drobo and Computer) the drive showed up, but I don’t know exactly how long it stayed until it disappeared. I noticed it was gone maybe a day or two later? I haven’t restarted either device since and it’s remained missing for about 4 days now.

The drive is a Crucial M500 480GB mSATA drive, which I’ve been using since Oct 2014, but in 2 different Drobos.

thanks for the info kloh,
it might be worth trying to use dashboard to shut it down and then to restart dashboard, as well as the drobo to see how things go.

if it still does not work, it might be worth shutting it down as above, but then to unplug all power and cables, and to try carefully removing the msata, and then powering up the drobo again to make sure all is ok in dashboard. (try not to tilt the drobo with hard drives inside, so as not to damage the backplane… if you are not easily able to do that, then you could try removing all drives in your disk pack with power all Off and cables unplugged, and remembering the order for later, before you tilt it to extract the msata, and then to put your diskpack drives back into where they came from)

(then if all ok, minus the msata, you could try shutting it down again and unplugging all power and cables, and to carefully put the msata back in, gently but firmly enough to be connected properly etc)
and then to try powering it back up and seeing what dashboard shows

if you have any more info about how and when you were using it in 2 different drobos, it might be handy to know, just in case it stopped showing up as soon as you removed it from 1 (powered off) drobo, and put it into another current (powered off) drobo?

(the msata could simply work in the same way as when a drive is put into a drobo the drobo usually wipes it and assimilates it into the pack, and as far as i know msatas are only to be inserted or removed Cold)

maybe another test could be to try using the msata in the other drobo, just to see if that behaves any differently, and if the other drobo finds it, we can try to do some more “sherlock holmesing” to try to pinpoint things further :slight_smile:

Thanks Paul. I don’t think the msata ever went “missing” on the original Drobo (5D) but I can’t say for sure since I don’t remember monitoring it that closely. I used the original for about 2 years before having to replace it due to some power failure issues I was having.

The new Drobo (also 5D) seemed to be working fine when I first got it set up, but I noticed the msata wasnt showing up on that Dashboard maybe a couple weeks later. I had a bunch of issues with other drives failing which is why I was paying more attention, and during one of the newer drive swaps is when I first started seeing the missing msata. A reboot seemed to fix that problem, but then a few days later it would disappear again. I got notifications through notification center in Mac OS that the drive had been removed at least twice over the past few weeks.

After each restart, the drive seems to appear (and indicates good life at 100%). Most recently it lasted about 7 days before disappearing again.

The other Drobo was returned under warranty so I am unfortunately unable to test it.

thanks for more info kloh,

if you happen to get another drobo, it might be worth trying the msata there, though if you still do get more msata issues in the current drobo, it might be worth trying to remove the msata with steps mentioned in the earlier post, just to see if any other notifications about a drive bring removed, in case something else is causing it.

if not, it might be worth testing the msata card in a standalone way (via an adaptor or card reader) with a utility that can check cards and flash memory (i think chkflash was also mentioned by some other users as a tool) via here:
http://mikelab.kiev.ua/index_en.php?page=PROGRAMS/chkflsh_en

btw if you had a lot of small files and changes made often, that could also affect the lifespan, and some types of larger database files that get modified often, (which could also be made of several of smaller files) can cause extra wear and tear, like with some versions of spotify that i think was affecting some ssds.

(maybe your msata was encountering too many errors but had some kind of self-correcting mode, which reset it from drobo and then it recovered with wear levelling or similar, and then drobo saw it as ok again… replacing it might solve your problems if they keep happening, though maybe some kind of tool that can monitor how much data or which files are being accessed on the drobo via your computer, might be also able to pinpoint any particular programs or files causing things too)

Thank you Paul, I appreciate all your responses. My Drobo has been in Data Protection mode all day so I haven’t been able to test out any of the new suggestions.

Not sure if this is related or not, but I have had 3 drives fail in the 5th bay within the past month. This Drobo 5D was a replacement unit on warranty that I just received toward the end of December. Prior to that, I was only using 4 bays, but I started hitting my capacity limit so I added a 5th drive (4TB WD Red). That drive failed after about 2 weeks, so I replaced it with another (same spec). The second drive did not work at all, so I returned that and got a second replacement, this time a 3TB WD Red drive. The 3TB worked also for just a little over 2 weeks, then my Dashboard showed the Drobo was going back into “Data Protection Mode” since it no longer saw the new drive in the 5th bay.

In summary, over the course of the month, I had 3 brand new drives fail (all in Bay 5) and my mSATA has also been sporadic. In all cases, Drobo Dashboard reported that a drive was “removed” before going into Data Protection Mode.

I have tried to raise this as a ticket with Drobo, but now they are telling me I am “out of support” on this unit. Really irks me since I JUST GOT this unit as a warranty replacement from them! Needlesstosay, it’s been a frustrating month with my Drobo…

Do you see any correlation between the issues? Should I be worried I have a lemon?

I had a msata SSD go bad as far as dashboard/5D was concerned so I got an inexpensive external msata drive case and ran Disk Utility on it (Mac/OS X) which reported the SSD as bad. Given this I’m assuming that SSD is shot. Note that this is the second SSD I’ve used as the first was a Crucial SSD that caused some data corruption when I was transferring data to my first 5D when it was new and after a couple days dashboard indicated the SSD was bad. I then replaced it with an Intel SSD which is the one that I recently removed.

BTW, I had a two year old 5D completely die and I’m now using a replacement unit I got from Drobo. I’ve decided not to put in a new msata SSD as I’m concerned about their impact on data integrity plus I did not notice any performance improvement.

Well, after data protection finished, I shut everything down, took the “offending” drive in bay 5 out, double-checked the “seating” of the mSATA then restarted everything like I’ve done in the past. Upon restart, the mSATA card showed up again, and I re-inserted the drive I took out of bay 5 back in. Both drives are currently reading as “good” which I suppose is good news, but it’s worrisome that this keeps happening. I’m pretty sure the mSATA will disappear again in a few days, and within 2 weeks, I’ll probably get another message that the drive from bay 5 has been removed…fingers crossed :-/

Well, that didn’t take long…

“Accellerator not active”

I don’t know exactly when that flipped, but sometime within the first 24 hours after restart.

hi kloh,
i think its definitely worth trying that power down as above and to remove and then try to run a standalone test on that msata in a separate reader when you can. (if you use chkflash, some of the tabs there have colour codes in screens that breakdown different types of errors and log results)

im pretty sure there was a tool someone mentioned, possibly docchris or johnm which happened to also specify the exact amount of data cycles (or data amount) that the unit had processed, and while i cant remember the exact name of that tool it might be worth trying that if one of us finds it on the forum.

but definitely i would run the test on it as one of the things to try out, and to also then see how things go with your drobo, and its 5th bay, (and then after the msata test we can try some more tests to see if that 5th bay is a bit of a 5th wheel or not)[hr]
also, if you can currently access your data, it is probably best to try and make a backup while it is accessible beforehand, (especially if you do not already have a backup, at least of the most important data if you can)

Hi Paul,

Thankfully, I have a separate backup on Backblaze. It’s not the easiest to restore from, but I have some peace of mind knowing it’s there.

Regarding the separate test for the mSATA, is this along the lines of what you are talking about? https://www.amazon.com/Makerfire-mSATA-Micro-Adapter-Converter/dp/B00NING8K2/

From what I can tell, chkflash is a windows-based tool. Can anyone recommend a good Mac alternative?

hi kloh it sounds like just the thing, and seems fairly cheap for an adapter too.
(in not 100% sure but it does mention not connecting with a macbook in case thats what you have)

Gah. However, after reading the description a couple times, I think they mean it doesn’t work with the SSD’s that ship with MacBooks.

Even if it does work, I still need to find some software that works on a Mac first…good times…