Drobo

Mounting Issue?

Hello. I purchased my B800i in 2012 so that makes me a POS to Drobo tech support.

I have about 20TB of total storage with 2 16TB partitions. Everything was fine until the other day when the first 16TB got full. Within Drobo dashboard the 2nd volume appeared to be mounted but the status says not available. I unmounted the drive, and tried to remount and the loading wheel next to the partition has been spinning for hours. This happens every time.

Any help would be appreciated. I was going to upgrade to the B1200 but Drobos lack of support, which I knew of before even purchasing my Drobo has been made even more clear that I should seek alternative future proof options.

Holy crap!

I had the EXACT SAME THING HAPPEN TO ME LAST NIGHT.

I have found no way to fix it yet.

None.

I now have more than 15 TB of my movies, TV shows, and music on a partition that won’t mount, but, hey! That’s ok! At least my Drobo knows that data’s there!

Ugh.[hr]
To be more specific:

Also have 2 16TB partitions (HFS+).

Last night, for whatever reason, the partition that has 15 TB of it used just up and disappeared. When I look at Drobo Dashboard, I see the EXACT SAME THING.

hi dustin, when i first read your post i was thinking maybe the drobo got overfilled somehow (for example where sometimes a user sees xTB free on a volume, but when the actual usable space of the drobo is less then the max size indicated by the operating system)… but when i looked at your screenshot, the blue leds seemed to only show about 80% being used. it probably is not overfilling, but would you be able to have a look at the physical drobo too, just to see how many blue leds the actual is showing?

(hi dsprui, its usually a good sign when the drobo recognises how much data is used… how many leds are there for you too?)

how are things going since then, is there any way that either of you can safely shutdown and computer and drobo, and to try rebooting?

Drobo is showing the appropriate #of LED’s (7 – I have about 20TB’s of it used and 10 free – 15 on one volume and 5 on the other), and it is also showing the appropriate percentage and capacity.

I’ve rebooted my computer, the Drobo, and both.

Nothing has fixed it.

thanks for the info,

one thing you could try which has worked in some other cases by essentially booting up in stages, would be to power all down.

and then to unpug the power and network cables from drobo
and to then remove all of your drives (remembering the order)
and to then power up the empty, unattached drobo
(does it boot up and go into standby mode?)

if so, can you then power up the computer,
and once the computer is up and running, to connect the drobo directly to the computer
(does it wake up and be found in dashboard as empty?)

if so, please power all down again, and unplug the drobo power and network cables from your drobo,
and then to put in all drives back where they were,
and to power up again
(does it boot up with blue leds as normal, and then go back into standby mode?

  • if it needs longer at this stage please let it do its thing

once it goes back into standby mode,
to powerup the computer and once that is up,
to connect the network cable directly back into the drobo
(does it wake up and be recognised by drobo as per normal?)

and does it then mount properly for you as before?

(please remember to only put in your drives back in while power is all off)

So I gave in and just got a support account w/ Drobo.

I figured that the files I was losing were essentially 150 movies and 250 episodes of TV shows, along w/ almost 1k songs.

I sent the drobo drag account to them.

They called me back and said they couldn’t figure out what happened. They had sent the Drobo diag file to their experts, and they were at a loss. My final chance for literally 15 TB of material is that they find a solution at the high-level coders.

Yep, not kidding. The company has said that there is no available solution to this problem.

Let’s be honest – what we need is a full backup of any files in a Drobo. Which, let’s be honest, pretty much means a Drobo’s purpose is entirely undermined…

hi dsprui
(it sounds like you had already tried the ideas in my previous post, before making a support account)

if that is the case, and if the diagnostic logs did not show any actual physical problems with the main drobo unit itself, then i think the only other thing that i can think to ask is if there is any chance that someone (with maybe not so good intentions) had access to your computer and maybe tinkered with the volumes in some way?)

0.0% chance.

I take my network’s security very seriously, and have never had any breach/malware/etc.

And I don’t think my 5 or 6 year-olds did it. :wink:

oh ok thats fair enough - i had to ask :)[hr]
at the moment, what happens if you check the settings, so that all files and folders are shown?
(for example, since some other users had to reapply a permission or setting, i was wondering if maybe all the folders became hidden somehow? just like on windows, there is a checkbox to show all system files, whether readonly or hidden etc).

also, when the ticket work has finished, one thing you could try could be to use a filesystem tool such as chkdsk or similar, initially in (tool) readonly mode, because if the volume used space is the same, then the drobo probably recognises that the same amount of space is used up with data, but maybe the volumes filesystem itself needs some maintenance. (i often find a chkdsk on my ntfs volumes helps to correct issues from time to time)

I hate to put it this way, as it will sound dismissive, but I’ve now had 20 conversations answering the Drobo team’s questions, and they have submitted the problem to their engineering and developmental teams, and their latest response is essentially ‘we’ll get back to you when we have some idea WTF is going on.’ Granted, that’s been their response for essentially the past month.

As I’ve said numerous times, I know how to find the unfindable in OS X, and I’m still flummoxed.

As, it appears, is the Drobo team…

hi dsprui,
thats ok (from my side there is definitely no offence taken in any way) :slight_smile:

please try to hang in there to see what can be done, and the only other thing i can suggest is just to see if iscsi is the only way to connect things, because if not, maybe there is another way to discuss with support. (i say this with limited knowledge of the fact that some models have a special internal connector within the chassis, a bit like a circuit board data interface socket, that have been used on some threads, which maybe could be considered if it exists in your model)

And here I was hoping to find a solution… I have EXACTLY the same issue. It actually happened right as I copied some files to a particular volume, which then promptly ‘hid’ its files (though the Volume was still mounted and visible as in the OPs example.

Clearly this has something to do with the Volume getting close to the 16TB limit.

As OP pointed out, the fact that drobo support have no way to figure this out is disconcerting, especially if it means the entire point of a drobo is void i this cannot be resolved and the data retained. 15TB of personal files gone? Disgraceful.[hr]
One thing I will point out though is that the data still seems to be present on the drobo, and this is simply a matter of visibility. I happened to open an app on my iMac and glanced at Recent Files, which showed a file that is in the ‘missing’ Volume. File opened fine… I just cannot see it directly… very bizarre behaviour.

Can you see the files from the command line? On a Mac, run Terminal.app to…drop into UNIX land. Hm. I’m not sure that helped much. Well, you could “cd /Volumes/Drobo” or whatever it’s named and then “ls -l” (list, long).
In Windows, run cmd.exe, change to the drive letter, and look. “h:” “dir /a”

Hi rdo, appreciate the suggestion. Attempted it via Terminal, just returns blank command line. Attempting same with other drobo Volumes shows the files of course.

Doing a ‘Get Info’ on the particular Volume in questions shows it has 16.45TB on it, so clearly going over the limit significantly plays with the drobo.

Any updates from those with this issue? My B800i seems to have a similar issue now. My volume was maxed out to 100%, and now when it is mounted to any machine, Windows prompts me to format the drive. Dashboard is still telling me there is 14.5tb of data though.

hi jradunske, you probably would not do this but just to mention that you should “not” format the drobo if windows asks you…

does dashboard show any other messages, and in the meantime can i check what the colours on the drobo are doing and showing?

what you could try, is to power all off, and to unplug all cables from the drobo
and then to wait 5 minutes
and then to power up just the drobo
(does it boot up with the usual blue led sequences, such as with light 1 through to 10, and then going into standby mode?)

if you then try booting up the computer, and then dashboard too.
and then try connecting the drobo as you usually do,
(does your drobo wake up shortly afterwards, and then become recognised again in dashboard?)
also what happens now from windows point of view?

btw are you still within support, and also which version of windows do you have?

Everything on the Drobo is/was fine, except what seems to be a corrupted file system. I was able to load up an Ubuntu box and mount the iSCSI volume there. I am now in the process of offloading 14.5TB of data so I can reset the Drobo unit.

These pics show all relevant screenshots of the dashboard.
http://imgur.com/a/5LEq2
This was taken off a Server 2008 machine, but Windows 7 with the latest Dashboard version was exactly the same.

Also, the diagnostics file is just flooded with this line:
TM: 000004f0 07\20 09:57:37 Error - ESABlockLUN::getOSUsedCapacity The file or directory is corrupted and unreadable.

thanks for the info and screenshots,

the screens do seem to show a full drobo (possibly it was overfilled somehow) but its good that you can still access the data via your ubuntu box.

it would be interesting to see what possibly caused it to overfill before (if it was due to a program in some way, so as to avoid something happening in the future) but i think if your data is verified as beeing fine again (once you copy things off) then a rest should hopefully get things back to a fresh state again.

My Drobo´s Power light stays yellow/orange. It is connected via “Ethernet” cable to my Modem. It always went into this stage when turning off the modem and came out of this state when turning the modem on again. Now the light stays orange - even after restarting the Drobo: first all light are green, then the blue light build up then everything looks ok - except the Drobo os not visible in Dashboard, neither on my Desktop (OS X 10.10.5) and - after about 3-5 minutes -goes into a state where all light are off except the orange power light (which said to indicate: Yellow: Your Drobo device is in the process of powering on).
As I have nothing changed to the cable connections (Drobo-Modem) and just connected my other Mac via Ethernet to the Modem - I cannot see the reason for this behaviour…

hi siamless, if you get a chance could you try plugging in your drobo directly into your computer (instead of the modem)?
am just trying to see if it wakes up or powers up differently and connects?