Mount thunderbolt Drobo on Older Mac

I have a dreaded HFS file on my New Drobo 5D Thunderbolt that is connected to my New Mac Pro (Black cylinder) that I cannot delete due to the restrictions in El Capitan.

I have a a Thunderbolt to FireWire adapter and tried connecting to my older Mac Pro, but it will not mount the Drobo for some reason.

Any suggestions would be greatly appreciated!

Screen shot here:

hi stephen,
are there any messages poping up in el capitan when you try to delete them?

maybe that font program is open (and locking the file) and if you try to close it completely, it might let you delete it?
(also, some office documents create a small temporary ~filename when a document is open and in use, so maybe that small zip file is a temporary one too?)[hr]
for the older mac, are you able to try just a single basic usb cable, to see if the 5d can connect with your mac pro that way?

Hi Paul, here is the error.

IIRC the thunderbolt to firewire adaptor only works one way. i.e. It allows you to connect a firewire device to a thunderbolt port on the computer.

thanks for the screenshot stephen,
if the adaptor works that way as adrian mentioned, then if you do get a chance to try a basic usb and to let us know how that goes, i think it would be a good test too.

can i also check if you have tried rebooting both the computer and the drobo, such as using dashbaord to shutdown the drobo and then rebooting both?

this page has a few tips that may help with that issue on mac:

i wasnt sure what those symbols were before the folder and filename in your screenshot, but looking around it seems to be nulnulnul and part of apple filesystem, and there seem to be lots of others having the problem so am thinking that it is probaly apple-related a bit more than drobo related based on this page?: