Mount Fail on Drobo 5N

I got the prompt to install Dashboard 2.7.1 and after installation I got the prompt to install firmware 3.5.6 and after installation got the prompt for the restart. The 5N restarted and all the lights are good, all green drive lights, a green power light and good blue lights. I am running Windows 10. After the system restarted I got a Mount Fail, I rebooted my computer and the Drobo 5N, I also did a manual firmware installation with the same results.

What would be the next steps without losing and data stored on the device.

hi, can i check if the mount fail was in windows 10 itself, such as from windows explorer or was it actually dashboard that gave the message?

does dashboard show any other info for the drives and status of the drobo?

Dashboard reported the mount fail after I installed the new firmware. I wonder if I can get a older version of the firmware and see if that was my problem, I would like to try that.

I also had a similar problem today. I downloaded the software and then the firmware. Everything showed good (green lights). Then, I got a message that stated my accelerator card has failed. I removed it as instructed (shutdown first) and now it doesn’t mount. Please help me with ideas on how to fix this.

thanks for the info axed,
would you be able to check dashboard just to make sure that the version info it shows, is indeed for the latest firmware that you tried to upgrade to? (there have been a few cases where the firmware upgrade didnt complete/take, in some cases also when using firewire over usb for some das models) but if your version is still showing the older one, then the newer one might just need manually re-applying as per here?

and in case you wanted to try dashboard, here too (in the windows area):

(though it might be good to try reapplying the same latest version before attempting to downgrade, and to play safe might be worth opening a ticket if you need to minimise risks as i have not downgraded before)

for thudthud,
the ssd might be a coicidence, though would you also be able to check if the version of firmware that dashboard shows you, is actually the latest one that you were trying to update to?

for both of you:
after the above, one thing you could try could be to shut all down and power off,
and to unplug the network cable and power cables from drobo
and to remove all drives (remembering the order of the disk pack)
and to power up the empty drobo on its own
(does it boot up and go into standby mode?)

if so,
to then boot up the computer, and once that it up and running, to plug the network cable back in (ideally directly attached, and not via any routers or hubs etc)
(does the drobo wake up, and still get recognised by dashboard, and does it show any firmware info)

if dashboard recognised it,
then to power all off
and to remove the network cable and power from drobo
and to put the drives back in where they were with power still off
and to boot up only the drobo with drives
(does it boot up with the blue led sequence and then go back into standby mode?)

if so,
to then boot up the computer as before, and once that is up, to then plug in the directly-attached network cable back into your 5n.
(does it wake up and become recognised as before? - and are there any messages shown in dashboard, and is the firmware version still matching what you intended?)

if all appears normal here, then can you try your normal procedure of accessing your data?
(im not sure if you “need” to mount via dashboard first, or if you could simply try accessing via the windows network path mapping)
sorry for long post, but after the above process, how do things go?[hr]
disk packs should only be removed while power is all off, or inserted again while power is also still off.

Thanks Paul, I will try and manually reinstall the firmware and see if that works. If not, I’ll try your other suggestions. Note: According to the dashboard it thinks the firmware is 3.5.6[8.84.79430].

I’ll post back later and let you know what happens.

So, it took quite a while for the firmware to load (nearly an hour) but it did. The firmware in the dashboard still showed 3.5.6[8.84.79430]. But did not ‘mount’ the drives. Health says Critical and I have the orange warning triangle at the bottom that says Mount Failed.

I then shutdown the drobo via the dashboard. Unplugged the network cord. Then unplugged the power cord. I labeled and removed the 5 drives and set them aside. After the unit was off for about 5 minutes, I plugged it back in and waited for it to boot up. I had the green power light on and the top drive light was red. I plugged the network cable back in and the dashboard was able to see the drobo. Firmware was exactly the same as before. Dashboard told me to enter a drive. I didn’t. I used the dashboard to shutdown the drobo again.

I unplugged the network card, then unplugged the power cord. I carefully put the drives back into the drobo making sure I put them back in the correct slot. I then powered up the drobo.

It booted normally (as far as I could tell). After about 5 minutes or so, all hard drive lights were green, the power light was green and I had 4 blue lights on showing the capacity.

I then plugged the network cables in and dashboard found it. But, no change. Firmware is the same as before and it still has a mount failed message.

Any other thoughts? Does anybody have the previous firmware that I can try to rollback too? Any foreseeable problems rolling back?

I did the same thing with the same results, mount fail.

Mount Failed, is basically the firmware unable to mount the internal filesystem (ext4).

When this happened, Dashboard will prompt you the mount failed, internal error msg.
If you open the Dashboard, select the 5N icon… then go to Tools section. You should see a REPAIR option now being active.

The Repair option on the Dashboard is only active when there is a mount failed. Clicking on Repair will attempt to repair the internal partition and make it mountable again after a reboot.

But please note that Dashboard’s Repair option is basically running a fsck (Linux fsck) which is a “destructive” repair in general. If there are potential very badly corrupted files… and not able to repair… they will be moved into a folder called “LOST and FOUND” … most of the time these files or folders will not bear its original names.

I have a 5N and upgraded to Firmware release 3.5.6 this morning.

The upgrade process went without any issues and my Drobo Dashboard software can connect to and manage the unit. The 5N shows no errors, has all of the disk drives healthy and the expected used space is showing.
However, I can not mount any shares old or newly created either on my iMac or my Windows PC, both of which were working fine before the 5N Firmware upgrade to 3.5.6[8.84.79430]

This feels like a Firmware issue so is there any way to revert back to a previous working release of 5N Firmware whilst 3.5.6 is verified and corrected please?

Today I have just tried adding a new User (which was successful) but still can’t mount a share from that new user.

I did a reset and now the dashboard doesn’t find the Drobo 5N. I have rebooted the computer and Drobo, tried to access through my router and direct connect to the Drobo. I have tried with a computer with Dashboard 2.7.1 and another computer with Dashboard 2.5.2 installed.

hi ahobbins, just posting here with note about a test you can try, from your other earlier post here;
if that does not solve it then please try dons advice though[hr]
(for thudthud, thanks for posting back the steps carried out and for trying that - as the empty drobo seemed to be working, and all was back as it was (with mounting problem) afterwards, then you might need to try dons suggestion as it might be some filesystem info needs correcting. i do not know how good or bad fsck is, but on all of my Das drobo volumes i have often run the windows checkdisk tool, with data fine at the end.)[hr]
for axed: could you try another network cable just in case?
(it might possibly be a faulty cable preventing dashboard from seeing it)
axed, could you please also clarify what you meant by “i did a reset”?

I am running the repair tool - over 24 hours running now…fingers crossed. On the positive side, the health is now green rather than red. Hopefully the next 24 hours it’ll come back to life and mount. Thanks for the assistance.

I reset the Drobo back to Factory settings.

I am also seeing this issue - perhaps not in the same context but similar.

Since the latest firmware update I lost a drive slot. Doesn’t matter what drive I install - it at first recognizes it and attempts to rebuild the array but then fails and the slot shows empty (slot 2) I have tried 3 drives, all function normally when not in the drobo.

This is clearly a firmware issue, I’ve opened a support ticket but nothing has been resolved at this point.

I’ve also tried everything in this thread - same issue. I also can’t mount any of the shares. So frustrating.

I’m a photographer and this has all my photos on it, over 100,000. Yes i have the data in another place and for now am okay. Data loss isn’t an option, the lack of support is a concern.

I hope this is resolved soon & they realize this is an issue with the last firmware update.[hr]

Did this fix it?

hi luv2ride, from what i could gather i dont think it solved the problem (and that axed was confirming that reset meant pinhole reset but i could be mistaken axed?)

for your issue, am not sure what exactly caused it, or how many drives you have in your drobo, though if your drobo was already utilising all slots, and then dashboard (and/or) the physical unit seem to not show any lights for a particular seemingly-faulty slot, then can i check what the other lights of the other drives are doing? (including the blue leds and capacity meter on dashboard?)

1 test that you could try, if you do have an unused (but assumed to be working) drive slot (in addition to the seemingly-failed slot), could be as follows:

  • to verify your data/backup is still fine,
  • to then power all off, and to unplug the power cable from drobo as well as data connection cable.
  • to eject the drive in the slot you believe to be faulty and to insert it still with power all off into the unused working slot
  • to then power up the drobo (what does it do now and if you leave it for at least 30 minutes?)

also, if possible would you be able to take some screenshot of dashboard and to upload them to ingur with links here (if you can, please also remember to rub out any sensitive/serial numbers to play safe before uploading)[hr]
for thudthud,
ok thanks for the update, please let us know how it goes

Hello Everyone,
If you have encountered an issue after you update to firmware v3.5.6:

  • Shares will not mount
  • Mount Failed
  • All drive bay lights solid Red

Even if you have created a support incident please email me the diag file and the support incident number to

Thank You.

I first tried to install an older firmware version and I got all red drive lights and wouldn’t talk to the dashboard. I used the pin hole on the back of the unit to reset to factory settings and it took a couple of tries to get it working again and now I have green drive lights but still not talking to dashboard. I think the unit is not talking to my network, I have tried using my router and direct connect to my computer. I have rebooted both and still not talking.

Is there a way to see what IP address the Drobo unit is using without the dashboard?

hi axed, can i check if your drobo has drives inside?
if so, then you might be able to get access to dashboard again to be able to obtain the logs for DroboMod in the following way:

  • if you can try powering all down (computer and drobo)
  • to unplug the power and network cables from drobo
  • and to then remove all drives (remembering the order)
  • and then to power up the empty drobo on its own
    (does it boot up and go into standby mode?)

if so, if you can then boot up the computer, and once that it up and running, to then plug the network cable back in, ideally directly attached, and not via any routers or hubs etc.
(does the drobo wake up, and get recognised by dashboard now for you to save the diagnostic logs)?

I powered the Drobo and restarted the unit without drives installed, I got a green power light with 5 red drive lights (is that standby mode for the 5N). I plugged in the computer and I don’t see any indication of the system is accessing the unit. Dashboard don’t see the drobo.