Drobo

MIgration of Drives from Drobo to DroboPro

Is it possible to move your disk from a Drobo V2 to DroboPro and keeping all data or do you have to buy new disks and move the data?

http://www.drobo.com/migration/

Is this a question, or an answer? I’m trying to figure out the new format, and wondering what happened to all of the old messages. Hopefully they’re not lost!

The short answer is, don’t do it unless you really need to. And if you do, keep the following in mind:

  1. Once you insert a set of disks into the DroboPro, that’s it – they will no longer be readable by a Drobo V1 or V2, regardless of the firmware version. So make sure you have the data backed up elsewhere.
  2. If you don’t have a duplicate of all of your data somewhere, such as offsite (and you really should), I would strongly advise you to buy a as many 2 TB drives as you can afford, put those in the DroboPro, then copy everything over and verify that everything went well. If you absolutely don’t need the original set of drives and are planning to sell the V1 or V2 Drobo, you can then move the old drives over afterwards, whereupon they will be reformatted and added to the capacity pool.
  3. Re-laying out your Drobo takes longer and longer, as the amount of data expands. If you have sufficient, reliable storage elsewhere, it will probably tak a lot less time to copy all of your existing data somewhere, reinitialize the entire DroboPro, and then copy it all back. Jst mak sure you don’t have a single-poin-of-failure during this process.
  4. Plan ahead if you are mixing drive sizes or thinking about using the dual-disk redundancy feature, and check your capacity with the Drobo Calculator. You may need more disks than you thought.
  5. Be sure to increase the volume size to 16 TB before doing all of this. The only exception would be if you want to reserve a smaller volume size just for use with Time Machine, or if you want to allocate a fixed amount of space for use with a Full Disk Encryption program such a TrueCrypt.

Now for the gory details, accumulated over the past week. Warning: This is lengthy! If you are interested, check back for updates, as will edit this rather than launch additional threads.

A week ago, at 7:30PM on a Friday evening, the FedEx man dropped off my new DroboPro, and I immediately set it up and started testing with it. That was my first mistake, and I went on to make several more. Unfortunately, the DroboSpace web site was taken off the air at about that time, so I was in the dark. I almost have everything up and running now, but I’d like to share my mistakes, and hopefully prevent others from making them.

  1. The first mistake was a lulu – I put a test drive in upside down, with the top plate facing to the left, instead of the right. I don’t know why, it just felt right, intuitively. The drive lock didn’t quite close, but it did seem to hold the drive OK. However, no matter what slot I plugged the drive into, the DroboPro never saw it (duh!), and I concluded that the unit was DOA. Saturday morning it finally hit me – RTFM! Oops! Chagrin! Plug it in the right way, and it works!
  2. I removed the four 90% full 1TB drives from my Home Drobo and inserted them into the DroboPro, and they all lit up properly, with one light turning yellow to tell me that I needed to add another drive. However, I wanted to turn on the dual-disk redundancy option, and I wanted to test that first, so I turned off the DroboPro, removed those drives, and inserted another set of four nearly empty 1 TB drives that I had used for testing, plus a new 2TB drive, and put the original set of drives back in my Drobo V1, intended to copy them to the new set.
  3. However, when I turned on the Drobo V1, all of the drives lit up red, and Drobo Dashboard informed me that the drives were created using a later version of the firmware, and couldn’t bee read. Since I had moved several drives around, I thought perhaps I upgraded one of the Drobos to 1.3.1, so I hunted around the Drobo web site and finally found the 1.3.1 firmware and installed it. No joy. Well, maybe it had to be on a V2, so I removed the drives from a V2, updated its firmware, and move the set of there. Still no joy.
  4. Finally, it dawned on me, and was confirmed by a FAQ. The incompatibility has nothing to do with when or where the drives were created — DroboPro updates them as soon as they are inserted, even though they are only being read. Arrgh! The DroboPro is backwards compatible with drives from the V2 Drobos, but the V1 and V2 Drobos are not forwards compatible with the DroboPro! You can’t go home again!
  5. Super! So now I had two sets of four 1TB drives, and no way to read or copy them, except on the DroboPro. Fortunately, I had enough space on the hard drive in the Mac Pro to copy the smaller set of files, so I put that set of drives back in the DroboPro, and copied them to the Mac Pro. I was very pleased to see the copy running at slightly over 100 MBPS, from the DroboPro to my four drive RAID 0 array on the Mac Pro. I then did the paperclip trick to reformat them and copy all the data back to the V2 again using FW 800 (which I used to think was fast, but not by comparison with the DroboPro over a dedicated gigabit ethernet port). That copy finished two days later.
  6. Now, back to the DroboPro, with the four 1 TB drives plus one 2 TB drive, totaling 3.63 TB of available space. Hmm. That’s only 900GB more than I had before! Oh, rats. I added a 2 TB drive, but if that drive were to fail, there would only be 1 TB drives available to fall back to, so the 2 TB drive was downgraded to 1 TB, effectively. So I bought another 2TB drive, bringing the total up to 5.26 TB. Now we are getting somewhere!
  7. Well, not quite. When I turned on the dual-disk redundancy option, that dropped the capacity back down to 3.63 TB, and now another problem popped up. That set of drives was the first set I ever created, 18 months ago, and at the time Drobo was cautioning people not to create volumes that were larger than they might need. So now I had 8 TB of hard disks in a DroboPro, and only a 4TB volume! OK, I thought, I’ll create a second 16TB volume, copy everything over to it, and then delete the original volume. I created the second volume, using the Volume Management feature of Drobo Dashboard 1.5.1.
  8. Oops! I started out with about 2.4 TB, and there is no way that two copies of that much data will fit in 3.63 TB worth of available space. I didn’t want to turn off the dual-disk redundancy feature, since that is why I bought the DroboPro in the first place. So one more trip to Frys, and now I have three 2TB drives plus the original four 1TB drives, totaling 5.14 TB of dual-redundancy space, so I started the copy job. Unfortunately, although reading a stream of data from the DroboPro to Mac Pro ran at 100 MPBS, coping from one volume to another one on the same DroboPro runs at about 4 MPBS, or 261 hours expected, although it didn’t take quite that long. That poor performance may be caused by the seeks or rotational delays that are required when reading from one partition and writing to another, and perhaps having the check the volume layout each time – I don’t know. But I’ll try not to do that again – I’ll copy data to my four drive RAID 0 array, and then copy it back again, hoping that a transmission error doesn’t occur in the process.
  9. After finishing copying the data from the Mac Pro back to the Drobo V2 via the FW 800 connection, it was time reconnect it to the Mac Mini. I had a little trouble inserting the FW 400 cable, so I tipped the V2 forward so I could see it better, then gently laid it back down again before plugging in the power. But what’s this? Only three lights light up? I immediately reseated the bottom drive, like within three seconds, and it lit up, but now the entire array was blinking Orange and Green, and sure enough it is going through a re-layout, with an expected time of 41 hours. Why can’t the error recovery do nothing at all for at least 10 seconds, in case a drive needs to be reseated? That way, Drobo could recognize the fact that the same drive had been reinserted, and a re-layout would not be necessary.
  10. Finally, after six full days and nights, I have everything up and running, and all green lights everywhere except for one too-full Drobe V2, which has yet another full backup on it. I am about to delete the 4 TB volume, but I just hope and pray that doesn’t cause a problem with the copy of that data on the 16 TB volume. Crossing my fingers, now…
  11. Whoops! On checking the Volume Management, I see that the dual drive redundancy feature is grayed out, yet I never received an e-mail notice or anything – it seems to have done that all by itself, silently. I’m going to delete the oldest and least needed folder from the 4 TB volume, and see what happens. Well, that didn’t help, and neither did deleting the entire 4TB volume, and rebooting the DroboPro. I still can’t enable the one function that I really wanted when I bought the DroboPro.
  12. Double whoops! I rebooted the DroboPro, without so much as touching it, and now it claims that the first 2 TB drive has failed??! Even after removing and reseating it, that drive light never lights at all? In addition, Drobo Dashboard is saying that it cannot protect my data, and not to remove a hard drive! It is obviously going through a re-layout. This is not good!
  13. Now, suddenly, the entire DroboPro seems to have died, with all of the lights off?? No, now it seems to be rebooting itself?! Now, at least, all of the drives seem to be recognized, including the one that “failed”, but it is now going through a relayout which is expected to take 67 hours, during which I apparently still have a single-point-of-failure, since the dual redundancy has turned itself off?.
  14. This morning, it is still going through the re-layout process, but now the dual-redundancy option is no longer grayed out. I checked the box, and for a while all of the lights went green except for a red light on an empty drive, presumably prompting me to add yet another drive. Then it went back to lay-out again, with another five hours to go.
  15. When I checked again later that day (Saturday), the expected layout time had jumped up to 361 hours!! At that point, I decided that if it was going to take that long, I didn’t want to go through it again any time soon, so I bought a fourth 2TB drive and inserted it, bringing the total to four 2 TB and four 1 TB drives. Presto! That dropped the estimated time to 191 hours, and for a while that estimate was continuing to drop. By Sunday evening it was down to about 39 hours, and this morning (Monday) it was about 29 hours. Very strange – this Monday evening it is back up to 59 hours. Did turning off my Mac Pro for four hours cause it to slow down, somehow?? The lights were still on when I returned. Update – 10 minutes later, it now says 25 hours. And now, two minutes later, it is saying 16 hours! At this point, the estimates have lost most of their credibility.
  16. All this time, Drobo Dashboard has been saying that my data was at risk, when all I did was enable the dual-disk redundancy. Are there two sets of messages, one for when there is no redundancy left, and one for when you are down to one remaining spare disk, or does Drobo Dashboard provide the same alarming message whenever it is re-laying out the data, whether you have one spare disk or two??
  17. The DroboPro finally finished laying out Tuesday evening, and at the moment, everything is cool. I ran some Xbench tests that I’ll discuss in a separate thread, but even a day after everything went all green, DroboPro still seems to be digesting its meal.

I’m closing off this thread. Anything new, I’ll post elsewhere.

Check back later for more progress, until I finally get to the point where everything has settled down.

Well I think it is possible. I just moved from a Dobo V2 to a DroboPro. I switched both machines off, took out the 4 1TB drives and re-inserted them into the Drobopro. It took about 3 days to relay out the new data (because I added additional drives and turned on dual disk redundancy) but it worked fine. I’m now editing my HD film without any hiccups!

@suiteB Yes I posted the Question then Answered it myself.

Just trying to build up the new forums!

so what exactly was wrong with the old forums?

I find it hard to basically start over when there was plenty of valid and helpful info from the old forums.
I am sure you guys had your reasons but you could have at least copied the info for all old and new users to this forum.

I certainly sympathize. Like lots of others, I put an awful lot of effort into the forum over the last 18 months, and it is a real loss to see it all vanish. Coincidentally, I had downloaded the contents fo the article I had posted, intending to update it, just before the forum went off the air with no notice.

Why DRI chose to leave the old forum (which was operated by a third party) isn’t clear – perhaps there were cost and other issues. But as I understand it, the other forum provider got mightily peeved, and cited a clause in their contract (and perhaps posted in the Terms and Conditions?) that basically said that all of contributions became THEIR intellectual property – basically the same brohouha that Facebook (?) and some other social sites have encountered.

This kind of a sandbox mentality certainly isn’t very endearing, and if I ever find out who the old form provider was, I will certainly boycott them, both professionally and personally. And if any of my old posts show up somewhere else without my approval, they’d better have a damned good attorney, because I will sue them for copyright violation in a nanosecond.

Well on one hand you’ve clearly enjoyed the closed-off community provided by DRI, albeit via Capable Net, on the other hand you complain about the sandbox mentality… am I missing something here?
I’m somewhat skeptical about all of this at the moment, especially since the last 2 threads about the issue were… how should I put it gently… ousted. I feel a little like I’m in a communist state and the central committee will strike at any rebellious thought.

Edit: Actually cancel that, after considering your point I think it is in fact a bad move from Capable to “steal” the information which was contributed freely by the users. I believe that if they want to, they should build a new forum, open to everyone, but without using the original material.

TKs Suite B for providing the Drobo & DroboPro upward compatibilty report! Glad I caught that b/f we recommend that to our customers. That’s buying a Drobo & DroboPro and thinking that the RAID or BeyondRAID is upward/downward compatible! Wonder when DRI will fix that w/ a firmware update? IMO, that’s business critical feature.

This web page discusses migration in full :
http://drobo.com/migration/

So, my/our next question is any plan to have the firmware both upward/downward compatible w/ Drobo/DroboPro? That’s a legit feature request cuz many shops will likely to have multiple units of Drobo & DroboPro and if the drives or I should say drive pac are not interchangable (aka downward compatible), that could be a problem!

It occurs to me that it takes two people to have a dispute, and that out of ignorance or misunderstanding I may have unfairly characterized one party or the other – or even both!

I’d therefore like to withdraw any accusations, one way or the other, and simply lament the disappearance of many, many man-years of effort by the contributers. Even if some were negative, those that were unfounded were generally rebuked or corrected by other members, and the others were suggestions that should be viewed as being valuable, both to DRI and the industry in general.

Even in the event of a divorce, someone still has to look after the welfare of the kids. My hope is that DRI and Capable can somehow get together and recover the lost information, and/or make it publicly available once again.