Main Drobo Partition Not Mounting

I’m hoping someone can help with this issue I’m having. The only change to my machines I think is that I updated to the latest version of OSX, 10.11.5.

I have my Drobo 3rd Gen partitioned such that I have a Time Machine Backup partition and a main storage partition. The Drobo is plugged in via USB to my Mac Mini. I have 4 drives in the Drobo and each light is green. It’s at about 50% capacity.

The Time Machine partition icon appears on my desktop, and I am able to browse it. The main partition icon does not mount like it did previously and I cannot browse it via Finder. I’ve tried running Disk Utility.

I attempted to resolve this by following the troubleshooting steps here:

Since I can see the Drobo in Dashboard and the Time Machine partition mounts, I don’t believe it’s the cable that’s the problem. I’ve tried shutting it down , unplugging it (power and firewire), plugging back in and restarting. I’ve tried accessing it via both my Mac Mini where I originally had the problem and my Macbook Pro (running the same versions of Drobo Dashboard and OSX)

Has anyone encountered this issue and successfully resolved it?

hi, can i check if you have tried disk warrior via usb, or possibly another usb cable just in case?
(it may not be the usb cable, but disk warrior has been known to fix a lot more problem than disk utility or disk cocktail utilties, though i dont believe its free)

Hi Paul

Thanks for the input. I only have one USB 3.0 cable at the moment (I ordered a second one to verify). However, I did try the cable I have in two different USB ports (as well as two different machines) with no difference in result. The Time Machine partition mounts, the main Drobo partition does not. If I go into the Capacity section of Dashboard, my free space to used space looks right.

If I look at the Volumes section in Dashboard, though, it doesn’t look right. Both partitions appear, but the main Drobo partition has a - under “Used” where the Time Machine partition says there’s 1.49 TB used.

I’m between jobs at the moment so I’d like to avoid having to spend the kind of money Disk Warrior is asking. I looked to see if there was a free trial but I didn’t see one.

Would any of the info in the Info section of Disk Utility be of use in diagnosing this?

thanks for the info (and i also know that feeling - i didnt realise it was over 100 to buy disk warrior)

while i do not have a mac myself, any other info you think could be useful is always worth posting (apart from possibly sensitive info / serial numbers) in case another user can spot something.

It is good that you tried another computer as well as different ports, (though am not sure if you tried those combinations but with the same drobo device?) :slight_smile: i guess one way to test the cable you have, could be to simply try using that cable with any other usb device, to see if that device works fine with that cable.

usually, disconnecting the drobo before upgrading “into” el-capitan is recommended, though can i check if you happened to do that when your most recent upgrade took place, and also if you can remember which version you had just before the upgrade. (such as a different version of the mac os, or just a different minor version?)[hr]
btw just to mention that another user just recently posted a similar issue about the - (dash) value, which diskwarrior did successfully fix it for him here:


I tried the new cable when it arrived to no avail, so I decided to take the plunge and cough up for Disk Warrior because I back my Drobo up to CrashPlan so I didn’t want to leave my data at risk for very long. I had it rebuild the directory or what have you and now both partitions of the Drobo mount successfully. I appreciate the advice.

hi, (aside from the tool purchase), thats great news :slight_smile: