"MacOS cannot repair Drobo Mini"?

Can access the drives, read only. Am in the process of copying the files off, which will take a while, then will have to try to fix what is causing this. Will do the Mac disk repair first, but not sure what to do other than that.

Suggestions welcome, will report back when I have backed it up and tried anything…[hr]
Oh, have the latest dashboard and firmware. And the Dashboard shows it as “healthy”.

OK, ran disk repair but got an error indicating it ‘could not repair’ the disk. Shut it down and restarted it, and it connected to my system but still indicates ‘MacOS cannot repair the drive’. Can still read it, but not write to it. Will finish copying files off of it shortly, then expect I will need to do something, not sure what but expect formatting it is the right next step.

So, should I ‘format’ it with my Mac, or with the dashboard? Should I reset to factory, then format? Sigh…

hi, once you finish copying the data somewhere, can i check how you are currently connecting the mini to the computer?

for example if you are using firewire, what happens if you were to shut it down and then try connecting via a direct usb cable instead (or vice versa for example), but also after shutting down and restarting the computer too?

if you still have the same issue, then if you happen to have access to diskwarrior, that has been known to fix a lot of mac problems and might be able to help too. (while it maybe a worth while investment for macs in general, if you dont have diskwarrior though, which seems to be a fair amount to buy, then it may just be better to reset and then copy things back again (but if you do copy things back please only copy, and not move, so that you can end up only deleting your backup once you are happy that the copy worked)

Thanks, Paul. Am using Thunderbolt for my Mac, but occasionally connect it to an old Windows PC that I use as a ‘network sharing’ device (had it left over from the time I finally got my wife to shift from Windows to Mac). It’s Journaled HFS, using the Paragon drivers to provide read only access on my home network. This actually started shortly after I applied the latest update to the Drobo, though not sure if that had any impact. Reformatted it with the dashboard after copying off my files, and have (mostly) copied them back (have about 5TB of stuff out there, takes a LONG time). Use the Drobo to consolidate a bunch of disks, into a single spot. Still have to carry some of the disks when I travel, but have a backup at home where I can access everything in a single location. Will post back if I this did not correct the problem.