Mac Journaled Volume corrupted?

I have a Gen 3 Drobo attached to a Mac. Split into two volumes one for data the other, smaller, for Time Machine.

I just upgraded to Mac OS Sierra and the latest Drobo 3.0 Dashboard. All was fine…until the main data drive disappears.

I tried rebooting the Mac and the Drobo. Things got worse when the Dashboard stopped recognizing the Drobo device. Meanwhile all green lights on the device itself.

I could see the raw device within Mac’s Disk Utility. A run of First Aid showed that there was corrupt data in journal. Looking around I found advice to remove journaling and lo! the disk remounted and the Dashboard recognizes the unit.

Lastly, I tried re-enabling journaling and the entire device drops, unmounts and I have to recycle its power to get it to reappear.

Is there anything I should be doing to re-enable journaling? Or am I facing a disk reformat?

MacOS Sierra changed the way that access to network drives is moderated. This sounds as though your Drobo is connected via USB. It could be a file system check in progress, do you have virus checking or other software that’s scanning the data drive? These programs have caused lots of issues with Sierra.

Yes it is connected via USB

I left the system alone for a long time in the hopes that if a system check was being performed it would resolve itself. It never did. But the moment I took the journaling off the disk it mounted immediately.

I’m backing up the data to second source (and a third) before trying to turn journaling on again.

I do run Avast on this mac.

hi can i check if sierra has a new feature, which is to enable journalling on a drive that maybe didnt have it before?
(such as the internal mac drive)

can you also remember if you first setup your drobo with journalling, for example as mentioned here?

there is a page here which mentions about how to enable journalling (slightly old page with some missing image or links) but you may have seen it here:

its good that you got things working again, (and that you are doing some more backups before trying again). one thing i also saw on the knowledge base is a note about only being able to support 1 kind of journalling… with this in mind, maybe a non-case-sensitive version could work for you? for example as mentioned here: