Drobo

mac + drobopro + iscsi + diskwarrior = trouble

i tried running diskwarrior on my drobopro (latest software/firmware as of halloween 2010). my drives were basically healthy (no observed problems) – so this was mostly a “good hygiene” kind of operation.

disk warrior ran successfully on several other disks attached to the same machine (connected via firewire and SATA and including a drobo2G), but failed on the drobopro connected via iscsi. diskwarrior first issued some warnings about slow performance, then indicated that the operation failed when trying to write the new directory to the volume. the dialog said something to the effect of “the disk is failing and you should copy all content to another volume” .

i disconnected the iscsi connection and connected the (same) unit via firewire to the same server, then ran diskwarrior again. it completed successfully.

speculation follows:

  • it seems that diskwarrior there is a specific bug or incompatibility between diskwarrior and the drobopro connected via iscsi. perhaps dw’s threshold for thinking that an operation has timed out is set too low for drobopro over iscsi?

  • and/or possibly i have a drive in my drobopro that is somehow marginal and generating some low-level errors or retries which the drobopro is “managing” (but not generating anything in the logs) and which is causing timeout errors on some i/o ops, but is not bad enough (yet) to cause the drobopro to turn on the red light. it would be nice if i could get more detailed reporting from the drobo.

  • and/or perhaps it was just a “fluke” that dw failed (twice) over iscsi then succeeded over firewire – i.e., it may be that just the shutdown/restart of the drobopro played a role in making the problem go away.

anyone have any ideas? it is very inconvenient to have to disconnect and reconnect to run “routine” utilities. i’m sure there must be others out there with experience with diskwarrior+drobopro… anyone seen this problem? diskwarrior is even recommended by drobo inc. as a tool for maintaining/troubleshooting drobos, no?

details:
mac os x server v.10.6.4
diskwarrior v. 4.2.
drobopro with latest firmware, 8 drives, dual redundancy, 26% capacity

i forwarded the contents of the original post to alsoft (makers of diskwarrior) and got this reply:

[i]An iSCSI connection is a network protocol. While it shows the device as
a local device, it is not truly a local device.

Network protocol is not a stable enough connection for the throughput
needed to rebuild or repair a device. You will need to connect the
device locally.

– Marc[/i]

so it would appear that drobopro falls in an uncomfortable middle ground as being not a true local storage device such that diskwarrior can work with it, nor a true standalone device such that it has its own internal filesystem integrity maintenance utilities.

any know if there are there other utiltiies (besides diskwarrior) that are more tolerant of iscsi? i actually own tech tools pro, but i haven’t tried it yet on drobo or drobopro.

And honestly, when we have contacted Alsoft, they have always told us to tell our customers to connect via USB instead of Firewire. They say their product works the best over a USB connection.

so does drobo support have a recommendation for mac drobopro owners?

maybe one of these options:

  1. you can use iSCSI, but if you want to perform (recommended) diagnostics and file system upkeep, you have to disconnect from iSCSI and reconnect via USB or firewire.

  2. drobopro users connecting via iSCSI should use some utility other than diskwarrior for filesystem upkeep (perhaps tech tools pro? or just use (apple) disk utility?).

  3. file system upkeep via a utility like diskwarrior is simply not needed or not recommended.

or something else?

Option 1.