Drobo

Mac Drobo 5N file copy problem

2 years ago I purchased a Drobo 5N primarily to use as a TimeMachine backup for two Macs. Since it had a lot of extra space I also decided to use it as archival storage for a variety of files.

The TimeMachine backup has worked fine since day 1. The archive function has not until I found an article here that solved my problem. When I tried to copy a folder containing more than a few dozen files the copy would fail often with a -36 error from the Finder. Even when there was no apparent error some files were corrupted.

Drobo support was of little help. Over 2 years I opened about half a dozen support cases that did no good. My internet searches turned up nothing because I was asking the wrong questions.

During this time I have been using a 2013 Mac Pro connected to the Drobo via an ethernet router. Initially I was operating under OSX 10.12. Since then I’ve migrated through OSX 10.13. At present I’m running under OSX 10.14.6. My Drobo 5N has three shares. Two are configured for TimeMachine and one for general access.

All this time I had assumed that the Drobo Dashboard would properly connect my Mac to the Drobo 5N. I’ve now learned that there are two alternative protocols smb and afp. The dashboard uses smb. When I manually connected using afp following the instruction of Drobo Article AA-01304 How to manually mount Network Shares with Mac or Windows, my problem was solved.

I see from other posting here that there may be problems using afp, but for my purposes this works fine.

I’m posting this here because the 5N2 may have the same problem that my 5N had.

I forgot to mention that the share would randomly disconnect from my Mac as well. This stopped when I switched to the afp protocol.