Drobo

Mac 10.6.8 Server, Drobo Pro, and iscsi

#1

I am attempting to setup a Mac Pro with 10.6.8 Server and want to attach a DroboPro via the 2nd ethernet port. The firmware is up to date but the software is where I seem to be getting stuck. I understand that D-R removed iscsi support in Dashboard after their agreement with ATTO ended. I have Dashboard v1.7.3, 2.0.4, and 2.7.1. Version 1.7.3 seems to be the most reliable in terms of scanning the ethernet bus, locating the drive, and mounting it after opening dashboard. Is it safe to use that version long term? 2.0.4 apparently included an improved driver for iscsi but I cannot seem to get the Drobo to be recognized using iscsi and ultimately the DroboPro goes to sleep and powers down. It does powerup and mount using usb as expected. Version 2.7.1 does not recognize the DroboPro at all under 10.6.8. Booting 10.7 or better allowed 2.7.1 to see the drobo via usb.

In a thread I thought I read that if you initially install Dashboard that included the iscsi initiator, that later installs would continue to use the existing initiator software to find and mount the DroboPro. Is this truly the case? What would be your suggestion in getting 10.6.8 on a Mac Pro to mount a DroboPro via iscsi reliably?

I know Drobo is now leaning customers towards SNS but there seems to be a recent instance of their initiator and DroboPro throwing some error messages. Plus their tech specs indicate 10.7 as the minimum OS.

Any advice you can provide would be greatly appreciated.

TIA

#2

hi, while i do not have a mac, i was wondering when you mentioned that booting 10.7 or better, allowed dashboard 2.7.1 to recognise the drobo via usb… is there maybe a mac with 10.7 server that you could use, instead of the 10.6.8?

#3

Firstly - OSX 10.6.8 is very old. Drobo Dashboard (latest or slightly newer… 2.x series) does not support 10.6.8 anymore.

And also 3rd party iSCSI initiator like ATTO or globalSAN also no longer support OSX 10.6.x with their latest software.

The latest ATTO drivers requires somewhat newer OSX and also Drobo Dashboard 2.7.1. It also may requires the latest JAVA runtime.

#4

I would like to use 10.6.8 server because it was the last version of server that included Print Server capabilities, which makes installing print drivers on every Mac much easier. From the testing I have done for the last 2 weeks or so, Drobo Dashboard 2.0.3a is seeing 2 Drobo Pros connected to a 8 port gigabit switch and achieving about 90MB/s transfer rate. I have tested and verified documents copied to and from and do not see any reason to believe the files are corrupted in any way.

I understand Dashboard can write a few parameters (partition, IP Address, spindown time, etc) but shouldn’t the drobo work without the requirement of Dashboard once configured. It seems to me that Dashboard predominately just reads health and status info from the device.

Am I sitting on a ticking time bomb?

#5

hi, if everything is working fine for you currently, and you are happy with the speed and usage etc, then you could simply keep using it in this way… i guess the only thing is that any kind of updates could affect things.

for example:

  • if the mac auto-updates in some way, it could muck things up
  • if you install some programs which in turn, auto update or update certain drivers or dependencies, it could cause problems.
  • also, if you wanted to upgrade some drives (or had to replace some failed drives with newer ones), then you might need to update the firmware, which might also need a new dashboard, and then any one of those updates could encounter a compatibility problem of some sort.

then again, if you are happy how things work now, and have backups and more control over what gets installed or not, then you could be ok for a fair while yet. (i still have dashboard and firmware 1.7.3 and 1.3.7 on my gen1 and gen2 drobos)

#6

I guess a question that could be asked is when did the last firmware get released and when was 2.0.3a released. They seem to be playing together just nicely and swapping drives executed without problem. All 3 Drobo Pros have the latest firmware on them, so they can accept higher capacity drives. I think I will continue some additional testing but consider this combination of hardware and software reliable and move forward.

Thanks for your help.

#7

ok sure i (think) it was mid 2011 when v1.2.2 firmware for the drobo pro was 1st released according to the linked site here:
http://www.drobospace.com/forums/showthread.php?tid=145684
&
http://www.drobo.com/drobo-downloads-2/

#8

Hi paulgalati,

I tried all different kinds of combination since a couple of weeks ago. The Drobo support isn’t helpful at all, I only got ridiculous answers. I had the same problem like you. There are only 2 ways to solve it.

  1. keep running OS X 10.5.8 server. There is a PPC version for G5 or a Intel version for the MacPro, both work with the Drobo Pro’s and the iSCSI initiator software / Drobo Dashboard.
  2. Upgrade to 10.11.6 and use the ATTO Xtend SAN software. Expensive, but it works.

I totally love the old Drobo Pro’s and see no reason to through them away. They are still good for storage and backup systems.

By the way: I tried all OS X systems: 10.5.8, 10.6.8, 10.7.5, 10.8.5, 10.9.5, 10.10.5, 10.11.6. None of them worked for me with the Drobo Pro iSCSI software. 10.5.8 is really the last system that supports iSCSI native.

Cheers,
Mathias