Lost Files

I’ve been using my Drobo S with 16 TB for two years now. Everything has been working fine (other than I went through about three hard hard drives). Today I noticed in one of my folders that I’m missing 7 folders with images in them and all of the stand-alone images within this folder. I know these folders were there yesterday and I’m confident I didn’t delete or move the folders.

Any suggestions on what happened and how I can recover these folders/files. I’ve tried shutting down drobo to see if that helped. I haven’t tried check disk yet.

hi are you using windows?

if so, you could try the following:

  • use dashboard to safely shutdown the drobo

  • then once down and its drive letters vanish etc, log off and shutdown the computer

  • unplug the usb cable of the drobo and computer

  • wait a few mins and then power up the drobo through its boot cycle (blue leds etc up to normal green/lights as appropriate) - it should then go into standby mode after a short while of activity.

  • then power on the computer (technically you could power up the computer separately in the meantime too)
    and when the computer is fully booted up, close down dashboard app and service etc from services.msc

  • plug in the usb to connect the drobo-S to the computer and let windowws recognise the driver letters and drobo etc.

  • then can you see the files and folders as per normal?
    if so, great (and you can enable dashboard and service again)

  • if not, then you could try the following:
    eg, to run command prompt (start menu> cmd) run as admin if possible.
    “chkdsk a:”
    (if a is your drobos volume letter)

and let it run to completion (hopefully it will say no errors found)
then run the following
“chkdsk a: /x”
(if a is your letter)

it may complete without a (no errors found) message (which actually means that it Did find some minor problems etc) in which case run the chkdsk a: /x command again until you get the no errors message.

(you might need to run chkdsk on each of your drobo volumes if you have more than 1 volume/drive letter, but only run 1 instance of chkdsk at a time)

hopefully this will help as i have had a similar thing happen to my drobo and the above seemed to fix it, and please let us know how you go :slight_smile:

I tried as you suggested. Chkdsk ran without errors for the drive I was having issues with; the other drive gives me “insufficient disk space to correct errors in $I30 of file …” error. I still can’t see my files.

I downloaded Seagate’s File Recovery program (demo version), I can see the files in there, but when I try to recover them, most remain corrupted.

hi, when you say drive, do you mean drive letter?
if so, then its good if chkdsk found no errors on one of them.

if the other one is saying insifficient space, then maybe you could try the following…

  • to identify one of the files on that drive letter which is both fairly large (AND) working fine (eg not corrupt etc)
    and to copy and paste it to another device (eg a usb stick or your main windows hard drive etc) and to verify that it is still working fine on that other device.
  • then, to delete it from the drobo,
  • and to wait while the drobo reclaims its space (maybe look at dashboard to see how much data is being used, and when dashboard shows that value has reduced by the same amount as the file you have deleted, then its probably finished reclaiming the space).
  • to then try chkdsk again to see if it gets any further.
    (you may have to repeat a few times depending on space needed - probably by at least twice the value of your images that you are trying to repair etc)

btw how much data to you have on the drobo and drive letters (volumes) btw?

Yes, I meant drive letter.

Here is my current setup:
Drobo S Gen 2
5 3tb Seagate hard drives (16 TB)
2 partitions of 8TB each E: and F:

E: used for videos, images, documents, etc (using about 1TB -6.98 TB free of 7.99 TB) – This is the one that lost the images, but isn’t finding errors

F: used for backup and local webhost (using about 2 TB - 6.05TB free of 7.99 TB) – This doesn’t seem to have a problem but says it has insufficient disk space to finish chkdsk.

Would F haven’t any influence on the missing files for E:? If not I’m not going to spend my time troubleshooting F:

BTW, I downloaded the Seagate File Recovery tool and I can see the files in E: with an X on them. When I recover some of the jpg files that are small enough for the demo version, the files are corrupted. I’m willing to pay the $100 for the full version if that’ll help, but if the files are going to be corrupted anyway, it’ll do me no good.

hi thanks for the extra info,

if you are running your drobo in SDR mode then you probably have 10tb raw space and about 10.8tb of usable space.
(this would be approximately the max space your drobo can hold, adding up all data used on e: and f: letters).

from what you have above, it seems as though you are not using up that much space though,
eg probably about 3tb like you say.

i was expecting your E: to be the one having problems (and) saying not enough space, but its interesting tht both problems/problem messages are on a different letter…

i cant see why F: would be affecting E: - but, do you know if the Not enough space message happened when you did a normal “chkdsk” or just on the “chkdsk /x” version.

also, were you running a webserver (webhost) at the time of chkdsk? if so, id try it agian without anything else running as maybe it had locked certain files.

A coworker has a drobo S at home. One thought is could we take these drive out of this drobo and put them in his.

  1. Will that have any effect on accessing these files?
  2. Will that have any negative effect for either of us?

Also - if you do get any other tools, then it might be good to copy and paste your important data or images to another device while you have access to them, just in case a 3rd party tool mucks anything else up

I believe it was just when I did the chkdsk /x

I don’t think webhost was running, unless it was running in the background. I’ll try it again on Monday and make sure everything is closed. Although when you unmount using /x, shouldn’t that unlock the files?[hr]

Thanks, I did that as soon as I lost these files.

hi, ok good that you did a backup,
and just reading your other post (which i think we posted at the same time) …

technically, while you could try your disk pack in his, im not sure if it will suddenly find more files which arent there at the moment for you. (you would both need to fully understand the diskpack swap procedure, with all power off etc, and he might want to make a backup of his data beforehand to play safe) - but, it might be better to try taking your complete drobo to his place and to try and plug it in there. (he should put his drobo in standby mode and then unplug it before you put in yours).

see if you find any more files that way, but i dont think doing a full diskpack swap would help as it sounds like the drobo hardware is still working. it seems more like the windows filesystem. when you finish running chkdsk, could you search your main windows drive folder and drobo for any CHK files? (sometimes chkdsk will convert problematic files into chk files) if you find any, have a look here too:

(usually you can open the file in notepad and recognise the filetype but theres some info and comments on that page too)

for the chkdsk, i think some programs can still lock certain files or drives, such as if you try and run a full chkdsk on the operating system’s drive. if your webserver runs as a service then you might want to turn it off during the chkdsk. (basically anything that is likely to be accessing and modifying files in some way etc is good to disable while running chkdsk)