Drobo

Losing hope

Been using my second gen 4 bay drobo (firewire 800, usb, 3 3tb disks and 1 1.5tb disk) for years as the main drive for a mac mini media server.

About a month ago it said one of the drives was failing and went into rebuilding mode. After a couple of days the drive unmounted, and all the lights went solid orange. After looking around the forums I tried several variations on ways to get it back up:

  • rebooted computer and drobo
  • turned drobo off, removed drives, turned drobo on until it came up in the dashboard, then off, reinstalled drives and rebooted

The first several of times the reboots happened the drive would appear and be usable during the rebuild. To speed things up, I shut off the computer. Eventually these all ended with solid orange lights.

The next couple attempts started the same way, the drive was never mounted on the computer, but was visible to the dashboard. These ended with the familar solid orange lights.

Finally, I bought another identical drobo, made sure it had the current firmware and swapped discks. Same result. Starts to rebuild and within a day, it ends with solid orange lights.

Any suggestions?

hi can i check how much data you have on the drobo, and does the usage capacity reflect this via the blue leds?
can you also remember if you have single sdr or dual ddr protection?

I had dual drive protection on. In terms of capacity, I can’t get it to mount to check for exact information, but it was at about half and the blue lights still show about half.

thanks for the info,

as you have these drives, 3+3+3 + 1.5tb
that would give 10.5tb total capacity -3-3 for ddr = 4.5tb
*0.9 = about 4tb usable so maybe about 2tb of data as about half the leds shouldnt cause a problem from overfilling…

would you could try, is to power off all drobos
+
to boot up the newer drobo, (while empty)
and to upgrade its firmware to the latest version for that model
and to then reboot it (still empty) just to make sure the drobo still boots up as normal and detected by dashboard
and then to power it down
+
to remove all drives of your disk pack from original (troubled) drobo, while off, remembering the order
and to put those into the newer (newly firmware upgraded) drobo,
and to then power that on (without any computer connection)

does this now boot up ok when starting up?
if so, could you then try connecting to the computer and seeing what dashboard shows?

(if none if this works, it may be a case of multiple issues with drives but i think the above is worth trying first though when possible)

Went through the process outlined and kept a close eye on things. Here’s what happens:

  • Drobo boots and shows one of the 3TB drives is defective. Warns me that it can’t protect my data.
  • After a few min, the drobo goes into protectino mode. Shows none of the drives as red, and flashes orange/green.
  • After 10 min or so, the drobo reboots and goes through this cycle again

Thoughts?[hr]
The drive never does mount, but it does show up in the dashboard.

thanks for more info,
am not 100% sure, but i think if you have tried the above steps and it is still rebooting, it may indicate problems with the drives in the disk pack.
(for example where multiple drives have multiple errors during the rebuild process, the drobo may be trying to recover/rebuild but after part of the process might be having to restart due to other drive errors.

if that is the case, you may need to consider block cloning the drives if possible, as this is a process yerry is going through at the moment for his post here:
http://www.drobospace.com/forums/showthread.php?tid=144867