Drobo

Lion + TM, still completely broken? False advertising...??

Ok, I rarely post unless I just can’t take it anymore. So, am I missing something here, or are the Drobo FSs completely incompatible with Lion and Time Machine? I hit the issue as soon as I upgraded to Lion when it came out a couple months, and sat around on these forums waiting for a fix.

1.2.0 comes out, supposedly fixing everything. It’s still broken. I can now connect to the drobo fs now, but file transfers are much slower than before. Time machine, however, is plain unusable. Any back-up takes 20+ minutes to initiate, and when it finally does, the back-up of only a few new files will take hours, if it even finishes without crashing. I have yet to successfully back-up to Time Machine since the update.

So my question is: did I miss something? Last time I checked this forum was a few weeks back, and I logged on today expecting some kind of a fix. Am I blind, or have data robotics completely ignored the fact that their Drobo FS product simply doesn’t work with Lion and Time Machine?

What bugs me is that if I google “Drobo FS lion Time Machine”, I get linked to help pages on the drobo website stating that it works if you download the newest firmware. So there are some poor suckers out there still buying this piece of crap today, thinking it will work when it doesn’t. I’m actually surprised there isn’t more uproar on these forums about it… or maybe I just missed it? Please enlighten me!

Okay, the problems you’re seeing are most likely changes made to netatalkd to support Time Machine in Lion, so I don’t know that there’s much that can be done other than put up with it.

However, since I know that is exquisitely unsatisfying an answer, try this. One thing that can make Time Machine absolutely crawl is problems with Spotlight. If anything is awry with the Spotlight index or Time Machine suspects it might have missed an update, it will do what’s called a “deep traversal”, which more or less means ignoring the index and re-checking everything. This can take forever - especially to the DroboFS with its somewhat crappy netatalkd stack. I would try deleting and reindexing your main drive with Spotlight, then letting it run a full backup. This will take a long time, even by the standards you’re stuck with right now. However, once it’s done you’ll be assured that both locally and remotely Time Machine has all its ducks in a row, and things should improve from there on out. Also, using wired ethernet is obviously preferable to WiFi for sheer performance.

Best of luck; I don’t run Time Machine to the DroboFS, but I’ve seen similar behavior out of my Time Capsule from time to time. The above usually gets it back to normal.

Funny you should mention that. The netatalk guys finally released the source code for the 2.2.x branch (the Lion compatible version), and I managed to cross-compile it.

I’m on the 1.1.1 firmware and I managed to backup my Mac Mini running Lion using TimeMachine to the FS. I couldn’t really make a fair performance analysis since the Mini connects to it over wifi, but I’ve seen it averaging at 3 MB/s. The problem is that the Mini is sitting in a place where the wifi is kind of flaky.

Anyway, I plan to package the newest netatalk for the FS as soon as I have some time, but not before I’m confortable that it won’t be messing people’s backups. :slight_smile:

If I manage to do it right we might get best of both worlds: firmware 1.1.1, which is pretty good, and the latest netatalk with support for Lion and its version of TimeMachine.

Wow - I will be watching this development with bated breath. The idea of replacing a core package like netatalkd kind of gives me goosebumps - I’m not sure if they’re terror or excitement. :slight_smile:

It is actually not a big deal*. First, get the thing compiled; second, kill the embedded processes; third, start my binaries with the configuration files that ship with the OS.

*: Well, sure, there is a little bit more than that, but that is the gist of it. Right now the whole procedure is very much manual, and automating it (i.e. packaging it a DroboApp) may be more complicated than I expect

I’ve been running it for a few days now and so far the Mac Mini seems to be happy with it. Mounting the shares over AFP seems to be just as fast (or just as slow :)) as before, but I have the feeling that the actual TimeMachine transfer speed is slower. But like I said it could be the flaky wifi.

Well 1.2.0 made my Time-Machien share empty and only viewable through SMB. Did all the help topics but still no go. They say the only option is to copy data to a new share. Problem? My data is 3.4TB while my Drobo is 5.8TB. I am not spending another $80 to get another 2TB drive to free up enough space.

That issue has been discussed significantly in the forum; in a nutshell, you need to delete the “.AppleDB” folder(s) at the root of a share. They’re corrupted and preventing netatlkd from showing the contents of the share.

I did delete that file, still no go. To be more precise I get

rm: cannot remove '/mnt/DroboFS/Shares/Time-Machine-old/.AppleDB': No such file or directory

So now what do I do then? Still mounts via AFP with no files.

I have exactly the same issue.

There isn’t an uproar because many of us are exhausted. I can’t spend one more minute worrying about my FS. As far as I am concerned, mine does not work with Lion. It works with our one Windows 7 system which has now been removed. In short it doesn’t work. It doesn’t do TM, it doesn’t transfer files faster than I can walk and in my case won’t accept smb logins. I have deleted shares, etc… and no matter what I do any AFP share freezes up my Mac’s. I just use NFS ( a 3rd party unsupported extra) and the FS works great that way. Very fast.

I had been thinking of downgrading the firmware to at least get afp and smb back, and I might still do that, but at the moment I just don’t seem to care. I went and bought portable drives to act as Time Machine backups. I have had Drobos for a long time and really like(d) them. In my current state of mind they are just 3.5" hard drive containers that will soon have no place in homes. Basically, the 1.2.0 firmware or whatever the latest firmware is made my FS useless. By the time Drobo fixes that the 3.5" drive may be a thing of the past.

I am sorry to sound so negative. I stop by here every now and then to see if a solution has happened ( it hasn’t) and to submit a support question which does get responded to. I think Drobo is trying. Perhaps it’s only a few FS systems that don’t work and we have them. That’s the only explanation I have. It’s not possible that the majority of FS users have broken systems. That would reflect really badly on Drobo and I still believe they are a great company.

Try NFS. Very fast and it just works.

philip[hr]

I don’t believe it would work. It might take years to get that backup. The problem is the firmware. Until they fix that nothing will make the Drobo have useable AFP shares. I don’t have my systems wireless, have done the whole spotlight, etc … tricks. Helps a bit but would you rely on that to provide a backup? That just sounds risky. Better to buy cheap portable drives.

Anyway, it’s possible that some of our FS systems are defective though I doubt it. It isn’t an issue of deleting hidden files, shares, etc… It has to do with Drobo fixing their product and if customizing the unit is what it takes to get it sort of working then it shouldn’t be used as a backup anyway.

philip

Are there instructions how to install/use this? If so, could you provide a link?

TIA

Keep checking back periodically, expecting a fix, haven’t had any backups for 3 months.

I’ve stopped recommending Drobo to any of my clients as I can’t support this scam anymore. Logged numerous tech support calls and always get stupid responses like, what’s the serial number on your power supply.

They definitely know there’s a problem, but they want to make it difficult for us to tell them.

Having purchased 3 drobo’s personally over the years and having recommended approx 40 other purchases for the enterprise, I’m changing from recommending them to recommending to avoiding them at all costs.

They look cool, but that’s about it, I’ve had too many backups trashed for no reason, faulty drives that aren’t recognized by drobo as faulty and problems with compatibility and bugs like this current issue with Lion.

Bottom line from the way I see it is that Data Robotics just don’t care about their customers, after all they already have our money.

Although I’ve influenced far fewer purchases than you, I too have changed from recommending them to advising clients and colleagues against the products. I love the idea, but can’t associate my reputation with Drobo at this time.

Every DRI employee I’ve talked with has at least one Drobo. The tech who helped me this morning has a Drobo FS, in fact. They eat their own dog food and are no doubt quite aware of the limitations of their products. Frankly, at a small company like Drobo you have to be passionate about what you do.
There’s no reason to not fix these problems. If they had a higher end product there might be a perceived opportunity to use these problems to upsell, but right now the only “upsell” is to their competition.

I don’t claim that “unable to fix” is better for customers than “unwilling to fix.” It is a different problem though.

[quote=“zawie, post:12, topic:3179”]
I’ve stopped recommending Drobo to any of my clients as I can’t support this scam anymore. Logged numerous tech support calls and always get stupid responses like, what’s the serial number on your power supply.[/quote]
I wouldn’t be so quick to call that particular response stupid…

There have been at least a few folks on the forum who posted weird problems that were solved by a replacement power supply. No matter how unrelated it seems, as long as it touches (or even doesn’t touch, if it’s a wireless/EM issue) the unit, it still might be the problem.

Reminds me of a conversation I had back in the day with a guy who worked at a hard drive manufacturer… He said using Cable Select gave faster performance than using Master/Slave jumpers. At first I thought “No way, that makes no sense” - but I went home and tried it, and it was faster. The only way I could justify it in my head was that in CS the drive relies on a proper UDMA66/100/133 cable (with the disconnected line at the slave end) for proper operation, and thus could safely “push” data faster. It’s no longer the case (especially as PATA is quickly disappearing), but it was a good reminder to keep an open mind for me…

Given the volume of calls they have had and the complaints on this forums regarding the Time Machine and Lion Issue, then I think it highly unlikely that everybody’s problem is due to a faulty power supply, when it worked fine on Snow Leopard before, the Drobo is online and it works fine on anything but Time Machine on Lion.

I resent being asked for the same dumb and irrelevant information time and time and again when Drobo know of the issue and the reasons for the issue.

I’ve dealt with them enough to figure out how they operate, here’s a summary:

  1. We offer one year of support. After that you pay. However you will need to always pay because we ensure that we’ll regularly release faulty firmware upgrades and dashboards that are unstable. QA testing, what’s that? Occasionally we will trash your backups and randomly wipe volumes, no biggie, you can start again. For sure, we care a lot less about the integrity of your backups than you do.

  2. We know that operating systems get updated from time to time, but we won’t bother with looking at Developer releases of the OS, so we can be ready when the OS is released. We probably won’t even bother fixing these issues even months later. It’s your fault that you decided to upgrade. We’d prefer it if you didn’t upgrade, then we wouldn’t have to get around to upgrading our software, that’s easier on us.

  3. We will claim your operating system version is supported but we want to make money with new suckers coming along, so don’t always believe what we tell you.

  4. Our products look cool. Did we tell you that? Real cool. They look good, isn’t that what you wanted? See all those cool blue red / green and blue flashing lights. Did we mention too that it’s black?

  5. We promise we will always answer the phone and respond with automated responses wherever possible without reading what you said. We figure that if your question involves reading or looking at posts on a forum, then that is too much effort for us. So in these cases, you should expect an unrelated automated cut and paste cos we just love cut and paste, it’s soooo fast.

  6. When contacting us, we may from time to time send you requests for irrelevant information to your problem. This is because there are thousands of problems, so we need to ask for many pieces of information for all the potential problems. This is because we don’t really take the time to read what you’ve written.

  7. We figure that if you get bored of sending repeated irrelevant information, then no problem, we get to close the call and it looks good to our bosses. No calls on the stack, there are no problems and we’ve done a good job.

  8. Did we tell you, we don’t have time to read, so all the information you entered on the website, we’re going to ask you for again anyway.

  9. Have a problem? Oh, we have an easy fix for that, just wipe the volume, 99% of the time that solves the problem. Can you see the volume now?, great problem solved. When it happens again, just wipe it.

  10. If all else fails, and you’ve responded to all our numerous irrelevant questions and completed all our irrelevant recommendations, then we will just leave your call hanging.

After nearly 3 months of waiting, I figure I can fix the problem quicker than Data Robotics can, so I’m purchasing a PC for “FreeNas” today, which does have Time Machine Support for Lion, and I will wipe and re-use my Drobo Disks.

I have a Drobo FS and regular Drobo for sale. If you wish to purchase one and get suckered like I did, contact me. All the blinky lights still work great, but the FS don’t work with Lion and Time Machine.

So I’ve made some progress in that I have got Lion TM backups working, although at the expense of 18 months worth of Snow Leopard backups. I can browse to the individual backups in the spars bundle with finder, so I know they are there…

But when I try to ‘Enter Time Machine’ to restore a file I can’t connect, nothing happens, or I get a connecting message that eventually times out.

Have tried the multiple reboot, plist delete, smb attach, suggestions without success.

Anyone get any suggestions?

Regards

How desperate are you? I have cross-compiled the latest netatalkd for the FS, which means I have complete support for Lion, but on the 1.1 firmware (I didn’t update to 1.2). It’s been running on my FS for about a week now and my Lion-based Mac Mini seems to be happy about it.

I haven’t packaged it yet because I was not 100% it was safe to use. But since this I had no troubles so far I guess I could make a package for some brave souls to test.

Any takers?

[quote=“zawie, post:15, topic:3179”]
Given the volume of calls they have had and the complaints on this forums regarding the Time Machine and Lion Issue, then I think it highly unlikely that everybody’s problem is due to a faulty power supply, when it worked fine on Snow Leopard before, the Drobo is online and it works fine on anything but Time Machine on Lion.[/quote]
I’m not saying that all the problems are caused by faulty power supplies. What I’m really after is… are you certain your FS was working properly before using it with Lion?

If the answer is a definite yes, then I agree, the power supply is irrelevant.

I’m happy to test, would love to give it a go…

Just go to the DroboApps. There’s only one NFS app there. It works really well. Not hard to install, really!

philip