Drobo

lighttpd

trying to setup the http server. Running into some road blocks. Initially I tried to just edit the config file and assumed the server was running. However I don’t think thats the case. So I tried this command

/mnt/DroboFS/Shares/DroboApps/lighttpd/lighttpd -f lighttpd.conf -m /mnt/DroboFS/Shares/DroboApps/lighttpd/lib start

I get the error message can’t bind to port: 80 Address already in use

based on this page http://redmine.lighttpd.net/projects/lighttpd/wiki/TutorialConfiguration everything should work as entered, but it doesn’t seem to work. If I don’t use -f and -m commands I get error messages saying that the library and configuration files can not be found under default paths.

A little help would be appreciated.

This usually means you have another HTTP server running already. Maybe the Apache one provided by DR?

In any case, try to change the “server.port = 80” line in lighttpd.conf to something else, for example, “server.port = 8080”.

I got it working on port 85. The strange thing was that when I had it running on port 85, when I tried to stop it, it gave me an error message. I tried running it on port 86 and it worked again, then I tried 80 after repeatedly trying to stop lighttpd via the lighttpd stop command and it WORKED. Now I have all three ports working. Can it be that I’ve started three different instances of lighttpd. Should I be using service.sh stop to stop lighttpd or lighttpd stop?

Most likely the script is not finding the file containing the process ID or does not have the rights to change/delete it. In other words, service.sh is not able to properly shutdown the server.

You can execute this from an SSH prompt:

ps w | grep lighttpd

The output looks something like this:

PID TTY STAT TIME COMMAND 30296 pts/6 Ss 0:00 <blah blah>/lighttpd <more blah blah>

This should list all running instances of lighttpd. You can them manually kill each one by calling "kill ", replacing PID with the number in the first column of the previous output (e.g. “kill 30296”).

Although, in the long term you should find which is the PID file being used by the service.sh script and make sure that the permissions on that file are correct.