Lights don't stay on, Drobo won't mount on desktop

After working perfectly for a year, my Drobo either does not appear on my desktop upon startup or disappears. The lights activate, then all go off, though the fan keeps operating. What can I do to get it working properly? I appreciate any help you can offer.

IMAC 21.5" , mid2010
OS 10.11.1

hi i saw your other post here:

can i check how the drobo gen3 is connected to the mac?
for example is it just a usb cable going into your macs usb port, ,or are there any other hubs or adapters or screen in the middle?

in case not, what happens if you can try using another cable, directly connected from the usb slot on drobo straight to the mac computer main usb slot? is there any diference?

2nd test:
can you also power all off
and then unplug the usb from the drobo
and then power up just the drobo
(what happens now, do the lights flash up with blue led booting sequence and slots and then the drobo goes into standby mode?)

also what colour are the lights on the power supply?

I did the power off, unplug, power up sequence and it still doesn’t connect. I talked to someone from Drobo support yesterday who walked me through all the obvious checks and tests. When nothing solved the problem, he kicked it upstairs and I’m waiting for a response. I think the unit has simply gone bad. In the meantime, I’m dead in the water.

I’ve had Synology RAIDs and NAS for over 15 years without anything out of the ordinary going wrong. This is my first Drobo and I’m disappointed that it hasn’t even gone a year without an issue.

ah ok, yes sometimes these things can unfortunately happen, (i just posted on another thread earlier today about something similar for failure points for devices in general here)

hopefully your issue can be address soon so you can carry on with what you need to do

(btw have you got a cat, maybe the cat scratched a power cable - jokes aside it might be worth checking that though, for safety too)