Keeping Drobo5N Mounted

Hi folks.

I’m having problems keeping this volume mounted through the network (obviously). I don’t know why it always seems to unmount if I’m not using it for over 5 minutes.

How can I fix that?


windows ? osx ? linux ?

try a continuous ping to the ip address of the drobo to check if the network connection is reliable

OSX. Will try the pinging.[hr]

I had the same problem. I now use MountWatcher to mount the Drobo shares and it remounts them it they ever drop off. It’s worked great for six months now. Currently running El Capitan.

So this app has to be open all the time then? I might as well sell the unit as this is horrible.

But thanks for the post. It is a solution, and it validates that I can’t keep this thing mounted.


hi beerich,
it might also be worth checking some settings to do with powermanagement or power saving features, as there was a post i saw the other month or so where someone changed their hibernation or powersaving mode settings and got things working better? just in case

Hi Paul. Where can I find these settings? The Dashboard doesn’t offer any that I can see.


ah i think this was on the actual computer operating system, such as control panel or mac equivalent

Yeah. This workstation is on all the time. No energy-saving at all. It doesn’t sleep, etc.

Would like to share some thoughts…

I alway mount OS X shared using Finder. This is not exactly the same as using the Drobo Dashboard to mount shares, which I do not recommend. I feel it is always better to work directly within the OS X Finder app. Also, you might see different results mounting shares with AFP versus SMB. (AFP is needed when working with Time Machine functionality). You can control how the Drobo shares are mounted by using the Finder’s “Go” Menu and clicking “Connect to Server…” For example, use “afp:/drobo5n.local” to open a shares selection window using the Apple Filing Protocol.

You can mount a share automatically on User Account Login by dragging the share’s desktop icon to the Users and Groups Preference Panel Login window.

In the Energy Saver Preferences Panel, make sure that “Wake for Network Access” is selected.

I use Drobo 5N to host Time Machine shares. These shares auto mount when Time Machine is scheduled to access them. Ditto when using Carbon Copy Cloner. On occasion, the auto mount function does not connect successfully, and the share should then be mounted manually to resume the connection. Once a successful backup takes place, the automounting functionality should resume working properly.

I hope that some of these suggestions can help you out. The suggestion above to use “MountWatcher” is not a bad idea - the resources used keeping this app open are probably outweighed by your needs to keep your shares mounted. You can monitor resource use by launching Activity Monitor from the Applications/Utilities Folder.

Hope some of these can help you with this problem. Good Luck!

Ya I always use the finder. I’m always in there, so it’s in my sidebar. That Dashboard thingy is not so good. I’ve tried AFP and SMB. I don’t have Time Machine on this unit.

I never log out. No point in my circumstance. So login doesn’t work, especially when it disappears within minutes.


theres a lot of good info there sboydman,
ideally there shouldnt be dismounting, though maybe you could try that mountwatcher too that hud mentioned, to see if it helps[hr]
btw is it directly connected to the computer?

It is on the other side of a router. I’ve had MountWatcher enabled. I just checked it to see how big this file is, and even with MountWatcher, it wasn’t mounted. Truly an odd experience.

The file I want to erase is 113 GB. It’s my photolibrary. It’s taking forever to get rid of. I’d say close to an hour or more.

hi once you finish any operations in progress, can you try to connect the 5n directly to the mac without the router? am just wondering if it behaves any better that way

maybe the best way to delete such a big file, is to do that thru direct ssh terminal commands :wink:

It’s actually just as slow. This unit has slowed down to an absolute crawl.

Hi Bee

I think he is referring to me where my Drobo mounted fine, then would suddenly “dismount” without warning. After getting the usual “copy and paste help” from Drobo of “make sure software up to date” … “buy a new Drobo (without knowing the reason for the problem)” I did come up with the idea that the USB ports had power controls which reduced the power to the port. This seemed to help somewhat, but not completely, I must admit

I refuse to buy another Drobo, unless this can be worked out, as there seems little point in doing so if it just happens again on the next one…

I bought a Lacie and prayed the Drobo could stay mounted for long enough to copy and back up … (I normally just back up from Drobo by folder, but wanted a "working drive of many folders) … it did…

I am convinced that this issue arose after a software update - but can’t prove it.

So am stuck really - I dare not buy another Drobo as the same thing may happen with a new one … and the support of copying and pasting was pretty thin … No one can tell me yet how to update the software to a Drobo that won’t mount, as to migrate to a new Drobo, both firmwares need to be the same …

My main worry with Drobo is although the support forum can be helpful, the support itself of “update the firmware” or “buy a new one” doesn’t exactly endear me to spending out on a new one …

I am hoping that someone in the forum will come up with an answer to this dropping of connection …

Everything else on the LAN is just fine.[hr]
Yeah this is over the LAN.[hr]

It still took a lot of time. It shouldn’t.

hi if the file deleting actually finished, can i check what does dashbord show as used and free space now?
(and % level) - a drobo (or other device) usually would slow down as it becomes quite full but just wondering what free space yours is at currently?

Capacity 9.94 TB
Used 3.90 TB
Free 6.04 TB

39% full