Drobo

Keeping Drive Running on Drobo Windows 7 x64

Help.

I tried to search the forums to get an answer for the question, but still have questions as to the correct methods to keep drobo from spinning down.

So here is the senerio. I am running Drobo v2 with 4 2TB drives. Using windows 7 64 bit. Drobo is connect via USB 2 connection. I am trying to use Drobo mostly for my music and video library. Currently I am using window live sync to maintain a sync exchange with several friends.

Here is the problem, every morning, I get a few hundred error messages from live sync because the drobo drive was no longer available. I am assuming this is because the drives went into sleep mode or spun down . How can I prevent this?

Sorry to the newbie question.

Thank you for your help.

What about this: http://lifehacker.com/5163175/nosleephd-stops-external-hard-drives-from-shutting-down

You can also create a batch file with the following commands:

type NUL > E:\nospindown
del E:\nospindown
EXIT

Replace E: with the drive letter to which your Drobo is mounted. Create a task in task scheduler to run the batch file every 10 minutes or so. This does cause a DOS window to pop up for a few seconds every time the batch file is run but will keep the drives spinning.

Thank you for the helpful info.

“I am assuming this is because the drives went into sleep mode or spun down”

sorry but this is completely wrong (im just trying to avoid you troubleshooting something which is not the issue)

if the drives spin-down this does not mean that they are unavailable.

I also use live sync and whenever there is request / change made to files on drobo - it simply spins up again! at no point should it ever be unavailable as far as windows is concerned. (which is what you say is happening)

If drobo is disconnecting for some reason - that is a totally separate issue to drobo spinning down its drives to save power, and you will need to look at why the drive is not available when live sync tries to access it.

I agree with Docchris - I’m using a Win7 x64 machine to share my Drobo direct-connected via USB.

Sometimes there is a slight 5-10 second delay, but I have never had my Drobo (via the Win7 machine’s share) come up unavailable.

Is your Win7 machine set to power off, or allow USB devices to turn off to save power? That might be putting the Drobo to sleep (versus just drive spin-down).

If that’s not the case, check how many shares or syncs you’re using. Win7, being a workstation class OS, has a limit of 5 or 10 simultaneous incoming connections. Professional and above have 10 as the limit, lower versions I believe have 5.

This limit includes mapped network drives, so if you have 10 mapped drives and start another operation, one of them will get “hung” until the other operation finishes.

Likewise, if you have too many sync operations going, it might get stuck (depends on how Live Sync works - I haven’t tried it yet).

Brandon